summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/pygments_rb
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/pygments_rb')
-rw-r--r--dev-ruby/pygments_rb/Manifest2
-rw-r--r--dev-ruby/pygments_rb/metadata.xml8
-rw-r--r--dev-ruby/pygments_rb/pygments_rb-0.6.2.ebuild62
-rw-r--r--dev-ruby/pygments_rb/pygments_rb-0.6.3.ebuild62
4 files changed, 134 insertions, 0 deletions
diff --git a/dev-ruby/pygments_rb/Manifest b/dev-ruby/pygments_rb/Manifest
new file mode 100644
index 000000000000..256b2c5c4830
--- /dev/null
+++ b/dev-ruby/pygments_rb/Manifest
@@ -0,0 +1,2 @@
+DIST pygments.rb-0.6.2.gem 1892352 SHA256 f4a1743be41a14f1f7ce63e03acefb9c6fabf7261c296b001191e0800f56e032 SHA512 8fd2da56d669882fa6b73073f02371ed7f9523ae115dd66bd77f2ed1d2e0abe5336e52d94fd92e85a55d813d163b0a6615233c2b27d16b5d089e0f97a2647d9c WHIRLPOOL 4caecb6182dcc712f2cdeded83bb734db7c5f988b70c0e87dd63c09ab0e75877cd780f4c5d1d64f751ca0fe3f0d8794e6f27d16a72fdfe4f1724312a705f6f12
+DIST pygments.rb-0.6.3.gem 1892352 SHA256 d19824fe964cf10388e2852ce3ee888f3e1446c9c2cdc89a55137d8183391198 SHA512 faa9d04b0571e34d5b01cf8ac8b70a68aa3e2555d222199c0090c0b71ae4046e74fc6e64fe8fd0c327fbe9c4a4efb34a91a02dec962086e8d9f8d881bff1eff0 WHIRLPOOL 6663226ee996827dd480a326a5c55c8603d5ab159c78969a2c774a45ff302c7d0b2eb4ee12601de59fb43bac207faf9b4222f1eb017ded313721906c02709db9
diff --git a/dev-ruby/pygments_rb/metadata.xml b/dev-ruby/pygments_rb/metadata.xml
new file mode 100644
index 000000000000..c5a2937fe773
--- /dev/null
+++ b/dev-ruby/pygments_rb/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+ <upstream>
+ <remote-id type="github">tmm1/pygments.rb</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/pygments_rb/pygments_rb-0.6.2.ebuild b/dev-ruby/pygments_rb/pygments_rb-0.6.2.ebuild
new file mode 100644
index 000000000000..61148065fd9c
--- /dev/null
+++ b/dev-ruby/pygments_rb/pygments_rb-0.6.2.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21"
+PYTHON_COMPAT=( python2_7 )
+
+RUBY_FAKEGEM_NAME="pygments.rb"
+MY_P="${RUBY_FAKEGEM_NAME}-${PV}"
+
+RUBY_FAKEGEM_RECIPE_TEST="rake"
+RUBY_FAKEGEM_RECIPE_DOC="none"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+RUBY_FAKEGEM_GEMSPEC="${RUBY_FAKEGEM_NAME}.gemspec"
+
+inherit ruby-fakegem python-single-r1
+
+DESCRIPTION="pygments syntax highlighting in ruby"
+HOMEPAGE="https://github.com/tmm1/pygments.rb"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+REQUIRED_USE+=" ${PYTHON_REQUIRED_USE}"
+
+RUBY_S="${MY_P}"
+
+RDEPEND+=" dev-python/pygments[${PYTHON_USEDEP}]
+ dev-python/simplejson[${PYTHON_USEDEP}]"
+DEPEND+=" test? ( ${RDEPEND} )"
+
+ruby_add_rdepend ">=dev-ruby/yajl-ruby-1.2
+ dev-ruby/posix-spawn"
+ruby_add_bdepend "dev-ruby/rake-compiler"
+
+pkg_setup() {
+ ruby-ng_pkg_setup
+ python-single-r1_pkg_setup
+}
+
+all_ruby_prepare() {
+ sed -i -e '/[Bb]undler/d' Rakefile || die
+ sed -i -e 's/~> 1.1.0/~> 1.1/' -e '/s.files/d' pygments.rb.gemspec || die
+ python_fix_shebang lib/pygments/mentos.py
+ # we are loosing a "custom github lexer here", no idea what it is,
+ # but if we need it, it should go into dev-python/pygments
+ rm -r vendor lexers || die "removing bundled libs failed"
+}
+
+each_ruby_compile() {
+ # regenerate the lexer cache, based on the system pygments pkg
+ ${RUBY} cache-lexers.rb || die "regenerating lexer cache failed"
+}
+
+each_ruby_install() {
+ each_fakegem_install
+ ruby_fakegem_doins lexers
+}
diff --git a/dev-ruby/pygments_rb/pygments_rb-0.6.3.ebuild b/dev-ruby/pygments_rb/pygments_rb-0.6.3.ebuild
new file mode 100644
index 000000000000..d50ffbcf9c62
--- /dev/null
+++ b/dev-ruby/pygments_rb/pygments_rb-0.6.3.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+PYTHON_COMPAT=( python2_7 )
+
+RUBY_FAKEGEM_NAME="pygments.rb"
+MY_P="${RUBY_FAKEGEM_NAME}-${PV}"
+
+RUBY_FAKEGEM_RECIPE_TEST="rake"
+RUBY_FAKEGEM_RECIPE_DOC="none"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+RUBY_FAKEGEM_GEMSPEC="${RUBY_FAKEGEM_NAME}.gemspec"
+
+inherit ruby-fakegem python-single-r1
+
+DESCRIPTION="Pygments syntax highlighting in ruby"
+HOMEPAGE="https://github.com/tmm1/pygments.rb"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+REQUIRED_USE+=" ${PYTHON_REQUIRED_USE}"
+
+RUBY_S="${MY_P}"
+
+RDEPEND+=" dev-python/pygments[${PYTHON_USEDEP}]
+ dev-python/simplejson[${PYTHON_USEDEP}]"
+DEPEND+=" test? ( ${RDEPEND} )"
+
+ruby_add_rdepend ">=dev-ruby/yajl-ruby-1.2
+ dev-ruby/posix-spawn"
+ruby_add_bdepend "dev-ruby/rake-compiler"
+
+pkg_setup() {
+ ruby-ng_pkg_setup
+ python-single-r1_pkg_setup
+}
+
+all_ruby_prepare() {
+ sed -i -e '/[Bb]undler/d' Rakefile || die
+ sed -i -e '/s.files/d' pygments.rb.gemspec || die
+ python_fix_shebang lib/pygments/mentos.py
+ # we are loosing a "custom github lexer here", no idea what it is,
+ # but if we need it, it should go into dev-python/pygments
+ rm -r vendor lexers || die "removing bundled libs failed"
+}
+
+each_ruby_compile() {
+ # regenerate the lexer cache, based on the system pygments pkg
+ ${RUBY} cache-lexers.rb || die "regenerating lexer cache failed"
+}
+
+each_ruby_install() {
+ each_fakegem_install
+ ruby_fakegem_doins lexers
+}