summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/rspectacular
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/rspectacular')
-rw-r--r--dev-ruby/rspectacular/Manifest3
-rw-r--r--dev-ruby/rspectacular/metadata.xml8
-rw-r--r--dev-ruby/rspectacular/rspectacular-0.61.0.ebuild24
-rw-r--r--dev-ruby/rspectacular/rspectacular-0.62.1.ebuild24
-rw-r--r--dev-ruby/rspectacular/rspectacular-0.63.0.ebuild24
5 files changed, 83 insertions, 0 deletions
diff --git a/dev-ruby/rspectacular/Manifest b/dev-ruby/rspectacular/Manifest
new file mode 100644
index 000000000000..3130382157aa
--- /dev/null
+++ b/dev-ruby/rspectacular/Manifest
@@ -0,0 +1,3 @@
+DIST rspectacular-0.61.0.gem 14336 SHA256 fffd8099063f110244314aa87e20058899d8dca15378eb4de21f740c2c0c4f82 SHA512 bdabc855ea9bb0cdcb222de47773be6d9ea2d9208bef416e3ab24195a16fc59b2d1af045b9c59851f87dd3ce7cc0ffe479d9ac5e07f4b5418c530dd3a8f7c922 WHIRLPOOL 0b3d98b3ec2991ce70d0a8d50f769f1715353fb9760ae1a7b23e7f53f7793b6bf702e640eaf95f36b9cb9647570d6c44cac634129dadd21dab6b0954728a19b6
+DIST rspectacular-0.62.1.gem 15360 SHA256 2a5e394b96f56ad5f96dbd491666ea96d3ec542815cf3fc6b206bb14141508ca SHA512 60579982d6551b355648237acb0eeb962bf61afe11049fd25e86dc9305612896453edb139ea73e42af0149aa80b39b04ea8698b016bbafb6e197e6a0315da0ba WHIRLPOOL 7766e6e67fbdd757046640d92faaf862241e0d4e4d66146eb1797a0f134b9db423f92baa8b69d5aa35ac8b000f23e56c6ecb833506182f081ccbc19c31be25b6
+DIST rspectacular-0.63.0.gem 15360 SHA256 2bd2ffda1727f789815fdc8bc3e6833de0b13d050eee09e1e82218fd20cdb51d SHA512 9e41f8b94542f7f82554b6473452ce23c81f15994f0b260dc7def3ada7bbbab2e4e65be57c42db6df04bb8dd98efd4ba40cf9c866814aa6812a6485d8d7c623f WHIRLPOOL 09463a228625d75949ffc909142d35d2d5e95e610e3949828426cb0acd3da981732e5e1c2dfcb7cb12dfc17302cb13cf12473aefac9c41a3f9b6fa367d2d2387
diff --git a/dev-ruby/rspectacular/metadata.xml b/dev-ruby/rspectacular/metadata.xml
new file mode 100644
index 000000000000..f915835062d4
--- /dev/null
+++ b/dev-ruby/rspectacular/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+ <upstream>
+ <remote-id type="github">thekompanee/rspectacular</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/rspectacular/rspectacular-0.61.0.ebuild b/dev-ruby/rspectacular/rspectacular-0.61.0.ebuild
new file mode 100644
index 000000000000..afcaa36e8501
--- /dev/null
+++ b/dev-ruby/rspectacular/rspectacular-0.61.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_TASK_TEST=""
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="RSpec support and matchers"
+HOMEPAGE="https://github.com/thekompanee/rspectacular"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/rspec-3.1:3 dev-ruby/fuubar:2"
diff --git a/dev-ruby/rspectacular/rspectacular-0.62.1.ebuild b/dev-ruby/rspectacular/rspectacular-0.62.1.ebuild
new file mode 100644
index 000000000000..afcaa36e8501
--- /dev/null
+++ b/dev-ruby/rspectacular/rspectacular-0.62.1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_TASK_TEST=""
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="RSpec support and matchers"
+HOMEPAGE="https://github.com/thekompanee/rspectacular"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/rspec-3.1:3 dev-ruby/fuubar:2"
diff --git a/dev-ruby/rspectacular/rspectacular-0.63.0.ebuild b/dev-ruby/rspectacular/rspectacular-0.63.0.ebuild
new file mode 100644
index 000000000000..70fe33156db1
--- /dev/null
+++ b/dev-ruby/rspectacular/rspectacular-0.63.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_TASK_TEST=""
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="RSpec support and matchers"
+HOMEPAGE="https://github.com/thekompanee/rspectacular"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/rspec-3.1:3 dev-ruby/fuubar:2"