summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/ruby-gettext
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/ruby-gettext')
-rw-r--r--dev-ruby/ruby-gettext/Manifest3
-rw-r--r--dev-ruby/ruby-gettext/metadata.xml5
-rw-r--r--dev-ruby/ruby-gettext/ruby-gettext-3.1.1.ebuild63
-rw-r--r--dev-ruby/ruby-gettext/ruby-gettext-3.1.2.ebuild63
-rw-r--r--dev-ruby/ruby-gettext/ruby-gettext-3.1.6.ebuild63
5 files changed, 197 insertions, 0 deletions
diff --git a/dev-ruby/ruby-gettext/Manifest b/dev-ruby/ruby-gettext/Manifest
new file mode 100644
index 000000000000..846cce7c49a2
--- /dev/null
+++ b/dev-ruby/ruby-gettext/Manifest
@@ -0,0 +1,3 @@
+DIST gettext-3.1.1.gem 221184 SHA256 323a1b07db0863e032436f6935a0e63a5ab7475ac8c387d2632065ee7bafc12a SHA512 b59462fd5c75aa64c1671fd54248ff86325be9aa53df2b4e720e663ae04d40febe83205c6ec75f6200dcf75abfdefe23db1effe838dc1149154457acc2fadc05 WHIRLPOOL 445999cff5241654252073b027388b058f272ffbaaa7d844208908996275cc22ed15c7055bd99a89977737192e60af84e0539bd6461b2da748bf97d41d5744f3
+DIST gettext-3.1.2.gem 224768 SHA256 1ed987d0a46448cfc76617b486ad9a991e0d48501855e49eacb781aa531df6eb SHA512 14fbccf1d853bd58ae3ecbda3188294147404fb8473a54caeac505b93ffa25f96098786bd1171449aa1f0f74c4116e93b5d2f7c0705930dd014b210720667479 WHIRLPOOL 5a31bf87b38370276bf4c61886025f8721a7cb297012fbe6d1947abf82d1d35d779838506f5e56adbdda090a0ae20d4e5c74b9c4a08a4c782998d78b3a7c1768
+DIST gettext-3.1.6.gem 282112 SHA256 b3b0d6cd779e3f99b3bd541300fd5ae8f5425f90d0314209b6eb70a7772c8a81 SHA512 8bf0f8203eef8b181400dfca8c67376b6dd64c7fc00177c20ced840791883c3988f12eefe55bb6b487473d8875f86ea8143feb15e814c83e29dcd0133dc2f73c WHIRLPOOL 5976fba52e84da77aa92aa61e498537ae8ee6294cdd64a0b18257b9df52e803e7ad3233a3964bdac9048cc4e78fc7a372b31cdbc117b2e164a84385419cc0f57
diff --git a/dev-ruby/ruby-gettext/metadata.xml b/dev-ruby/ruby-gettext/metadata.xml
new file mode 100644
index 000000000000..852136183369
--- /dev/null
+++ b/dev-ruby/ruby-gettext/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ruby</herd>
+</pkgmetadata>
diff --git a/dev-ruby/ruby-gettext/ruby-gettext-3.1.1.ebuild b/dev-ruby/ruby-gettext/ruby-gettext-3.1.1.ebuild
new file mode 100644
index 000000000000..b9bc5be47bd8
--- /dev/null
+++ b/dev-ruby/ruby-gettext/ruby-gettext-3.1.1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20"
+
+RUBY_FAKEGEM_NAME="${PN/ruby-/}"
+RUBY_FAKEGEM_VERSION="${PV%_*}"
+
+RUBY_FAKEGEM_RECIPE_DOC="yard"
+RUBY_FAKEGEM_EXTRADOC="README.rdoc"
+
+RUBY_FAKEGEM_TASK_TEST="none"
+
+RUBY_FAKEGEM_EXTRAINSTALL="po"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Ruby GetText Package is Native Language Support Library and Tools modeled after GNU gettext package"
+HOMEPAGE="http://www.yotabanana.com/hiki/ruby-gettext.html"
+
+KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 sparc"
+IUSE="doc test"
+SLOT="0"
+LICENSE="Ruby"
+
+ruby_add_rdepend ">=dev-ruby/locale-2.0.5 dev-ruby/text"
+
+ruby_add_bdepend "doc? ( dev-ruby/yard )
+ dev-ruby/racc"
+ruby_add_bdepend "test? (
+ dev-ruby/test-unit:2
+ dev-ruby/test-unit-rr )"
+
+RDEPEND+=" sys-devel/gettext"
+DEPEND+=" sys-devel/gettext"
+
+all_ruby_prepare() {
+ # Fix broken racc invocation
+ sed -i -e '/command_line/ s/#{racc}/-S racc/' Rakefile || die
+
+ # Avoid bundler dependency
+ sed -i -e '/bundler/,/helper.install/ s:^:#:' \
+ -e 's/helper.gemspec/Gem::Specification.new/' Rakefile || die
+
+ # Avoid dependency on developer-specific tools.
+ sed -i -e '/notify/ s:^:#:' test/run-test.rb || die
+}
+
+each_ruby_test() {
+ # Upstream tries to daisy-chain rake calls but they fail badly
+ # with our setup, so run it manually.
+ ${RUBY} test/run-test.rb || die "tests failed"
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ insinto /usr/share/doc/${PF}
+ doins -r samples
+}
diff --git a/dev-ruby/ruby-gettext/ruby-gettext-3.1.2.ebuild b/dev-ruby/ruby-gettext/ruby-gettext-3.1.2.ebuild
new file mode 100644
index 000000000000..cc48d54b8c48
--- /dev/null
+++ b/dev-ruby/ruby-gettext/ruby-gettext-3.1.2.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20"
+
+RUBY_FAKEGEM_NAME="${PN/ruby-/}"
+RUBY_FAKEGEM_VERSION="${PV%_*}"
+
+RUBY_FAKEGEM_RECIPE_DOC="yard"
+RUBY_FAKEGEM_EXTRADOC="README.rdoc"
+
+RUBY_FAKEGEM_TASK_TEST="none"
+
+RUBY_FAKEGEM_EXTRAINSTALL="po"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Ruby GetText Package is Native Language Support Library and Tools modeled after GNU gettext package"
+HOMEPAGE="http://www.yotabanana.com/hiki/ruby-gettext.html"
+
+KEYWORDS="~alpha amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc x86"
+IUSE="doc test"
+SLOT="0"
+LICENSE="Ruby"
+
+ruby_add_rdepend ">=dev-ruby/locale-2.0.5 dev-ruby/text"
+
+ruby_add_bdepend "doc? ( dev-ruby/yard )
+ dev-ruby/racc"
+ruby_add_bdepend "test? (
+ dev-ruby/test-unit:2
+ dev-ruby/test-unit-rr )"
+
+RDEPEND+=" sys-devel/gettext"
+DEPEND+=" sys-devel/gettext"
+
+all_ruby_prepare() {
+ # Fix broken racc invocation
+ sed -i -e '/command_line/ s/#{racc}/-S racc/' Rakefile || die
+
+ # Avoid bundler dependency
+ sed -i -e '/bundler/,/helper.install/ s:^:#:' \
+ -e 's/helper.gemspec/Gem::Specification.new/' Rakefile || die
+
+ # Avoid dependency on developer-specific tools.
+ sed -i -e '/notify/ s:^:#:' test/run-test.rb || die
+}
+
+each_ruby_test() {
+ # Upstream tries to daisy-chain rake calls but they fail badly
+ # with our setup, so run it manually.
+ ${RUBY} test/run-test.rb || die "tests failed"
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ insinto /usr/share/doc/${PF}
+ doins -r samples
+}
diff --git a/dev-ruby/ruby-gettext/ruby-gettext-3.1.6.ebuild b/dev-ruby/ruby-gettext/ruby-gettext-3.1.6.ebuild
new file mode 100644
index 000000000000..d7915fe45238
--- /dev/null
+++ b/dev-ruby/ruby-gettext/ruby-gettext-3.1.6.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_NAME="${PN/ruby-/}"
+RUBY_FAKEGEM_VERSION="${PV%_*}"
+
+RUBY_FAKEGEM_RECIPE_DOC="yard"
+RUBY_FAKEGEM_EXTRADOC="README.md doc/text/news.md"
+
+RUBY_FAKEGEM_TASK_TEST="none"
+
+RUBY_FAKEGEM_EXTRAINSTALL="locale po"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Ruby GetText Package is Native Language Support Library and Tools modeled after GNU gettext package"
+HOMEPAGE="http://ruby-gettext.github.io/"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc test"
+SLOT="0"
+LICENSE="|| ( Ruby LGPL-3+ )"
+
+ruby_add_rdepend ">=dev-ruby/locale-2.0.5 >=dev-ruby/text-1.3.0"
+
+ruby_add_bdepend "doc? ( dev-ruby/yard )
+ dev-ruby/racc"
+ruby_add_bdepend "test? (
+ dev-ruby/test-unit:2
+ dev-ruby/test-unit-rr )"
+
+RDEPEND+=" sys-devel/gettext"
+DEPEND+=" sys-devel/gettext"
+
+all_ruby_prepare() {
+ # Fix broken racc invocation
+ sed -i -e '/command_line/ s/#{racc}/-S racc/' Rakefile || die
+
+ # Avoid bundler dependency
+ sed -i -e '/bundler/,/helper.install/ s:^:#:' \
+ -e 's/helper.gemspec/Gem::Specification.new/' Rakefile || die
+
+ # Avoid dependency on developer-specific tools.
+ sed -i -e '/notify/ s:^:#:' test/run-test.rb || die
+}
+
+each_ruby_test() {
+ # Upstream tries to daisy-chain rake calls but they fail badly
+ # with our setup, so run it manually.
+ ${RUBY} test/run-test.rb || die "tests failed"
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ insinto /usr/share/doc/${PF}
+ doins -r samples
+}