summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/sdoc
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/sdoc')
-rw-r--r--dev-ruby/sdoc/Manifest2
-rw-r--r--dev-ruby/sdoc/metadata.xml11
-rw-r--r--dev-ruby/sdoc/sdoc-0.3.20.ebuild21
-rw-r--r--dev-ruby/sdoc/sdoc-0.4.1.ebuild28
4 files changed, 62 insertions, 0 deletions
diff --git a/dev-ruby/sdoc/Manifest b/dev-ruby/sdoc/Manifest
new file mode 100644
index 000000000000..62d4670fd657
--- /dev/null
+++ b/dev-ruby/sdoc/Manifest
@@ -0,0 +1,2 @@
+DIST sdoc-0.3.20.gem 279552 SHA256 c2f54086862252f487e0c4b05fc46d8659a4dba6deb2ad0a24ff9046c1c4889e SHA512 643ca5c2729ae100a6853771c6f548d929873eefa5d12de1938640bdaec261f5a11ff52023869ab1a36ff351398d1c84725e69f216ba25624c80c0bec9d099d8 WHIRLPOOL 7db0f398491a1f36d6751eb36dcd33f7268d6b3183156824aa83c4554ea81438749b459a6ac8b407891f843fcc7dc84a5b5ffb632ed5dd277cd15590b6b647e9
+DIST sdoc-0.4.1.gem 281088 SHA256 177b6c1d55f33afb337d704f4ec3f9a7a4a958abbb6bd3a6cb91c890a372be9b SHA512 2c68b5d49ac29d453440447869b4567554d5fb722ea17b06935184d6df7e972d73a5323c1d8777461c196fa3cceb9380f8c50f824bad9a665b36ab6cc4cc3a71 WHIRLPOOL 7cfe1d9fc79dcf8edcf6348f188cef4d49fbf17889ba7591cc2ec0d033aa30f525bd574e4549e37327c442831e326a4a513e37cb95ab9f4e02d7731236861a4f
diff --git a/dev-ruby/sdoc/metadata.xml b/dev-ruby/sdoc/metadata.xml
new file mode 100644
index 000000000000..67d8219afee7
--- /dev/null
+++ b/dev-ruby/sdoc/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ruby</herd>
+<maintainer>
+<email>zerochaos@gentoo.org</email>
+<name>Rick Farina</name>
+</maintainer>
+<longdescription lang="en">
+</longdescription>
+</pkgmetadata>
diff --git a/dev-ruby/sdoc/sdoc-0.3.20.ebuild b/dev-ruby/sdoc/sdoc-0.3.20.ebuild
new file mode 100644
index 000000000000..c5c7ff46df08
--- /dev/null
+++ b/dev-ruby/sdoc/sdoc-0.3.20.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+inherit ruby-fakegem
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_RECIPE_TEST=""
+
+DESCRIPTION="rdoc generator html with javascript search index"
+HOMEPAGE="https://rubygems.org/gems/sdoc"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+
+ruby_add_rdepend ">=dev-ruby/json-1.1.3
+ >=dev-ruby/rdoc-3.10"
diff --git a/dev-ruby/sdoc/sdoc-0.4.1.ebuild b/dev-ruby/sdoc/sdoc-0.4.1.ebuild
new file mode 100644
index 000000000000..7342f88f721e
--- /dev/null
+++ b/dev-ruby/sdoc/sdoc-0.4.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+inherit ruby-fakegem
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_TASK_TEST="spec"
+
+DESCRIPTION="rdoc generator html with javascript search index"
+HOMEPAGE="https://rubygems.org/gems/sdoc"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="test"
+
+ruby_add_rdepend ">=dev-ruby/json-1.7:0
+ =dev-ruby/rdoc-4*"
+
+ruby_add_bdepend "test? ( dev-ruby/minitest:0 )"
+
+all_ruby_prepare() {
+ sed -i -e '/git ls-files/ s:^:#:' sdoc.gemspec || die
+}