summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2016-12-24 15:12:03 +0100
committerManuel Rüger <mrueg@gentoo.org>2016-12-24 15:12:03 +0100
commit5e7b2705955b490bbe5661ef5a486cdfd3354c78 (patch)
tree84f933847ab9bb59fb5b7c447cc18c172c426f34 /dev-ruby/shoulda
parentdev-ruby/bones: Add ruby23 (diff)
downloadgentoo-5e7b2705955b490bbe5661ef5a486cdfd3354c78.tar.gz
gentoo-5e7b2705955b490bbe5661ef5a486cdfd3354c78.tar.bz2
gentoo-5e7b2705955b490bbe5661ef5a486cdfd3354c78.zip
dev-ruby/shoulda: Add ruby23
Package-Manager: portage-2.3.3
Diffstat (limited to 'dev-ruby/shoulda')
-rw-r--r--dev-ruby/shoulda/shoulda-3.5.0-r3.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-ruby/shoulda/shoulda-3.5.0-r3.ebuild b/dev-ruby/shoulda/shoulda-3.5.0-r3.ebuild
new file mode 100644
index 000000000000..aaa0e46b5bb9
--- /dev/null
+++ b/dev-ruby/shoulda/shoulda-3.5.0-r3.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby21 ruby22 ruby23"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Making tests easy on the fingers and eyes"
+HOMEPAGE="http://thoughtbot.com/projects/shoulda"
+SRC_URI="https://github.com/thoughtbot/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="3"
+KEYWORDS="~amd64 ~arm ~hppa"
+IUSE=""
+
+# This now more or less a meta-gem and it only contains features for
+# integration tests using Appraisals, which we don't currently package.
+RESTRICT=test
+
+ruby_add_rdepend ">=dev-ruby/shoulda-context-1.0.1
+ >=dev-ruby/shoulda-matchers-1.4.1:0"
+
+all_ruby_prepare() {
+ sed -e '/git ls-files/d' -i ${RUBY_FAKEGEM_GEMSPEC} || die
+}