summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/textpow
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/textpow')
-rw-r--r--dev-ruby/textpow/Manifest2
-rw-r--r--dev-ruby/textpow/metadata.xml8
-rw-r--r--dev-ruby/textpow/textpow-1.3.1-r1.ebuild27
-rw-r--r--dev-ruby/textpow/textpow-1.4.0.ebuild28
4 files changed, 65 insertions, 0 deletions
diff --git a/dev-ruby/textpow/Manifest b/dev-ruby/textpow/Manifest
new file mode 100644
index 000000000000..f24f1dd4b428
--- /dev/null
+++ b/dev-ruby/textpow/Manifest
@@ -0,0 +1,2 @@
+DIST textpow-1.3.1.gem 384512 SHA256 706bf3a6e440daaf06db532438051434747335651a19f4cb2b88cb021d8c04d3 SHA512 58233fc5f045103878279585ece2db8b9043f5f036372d75903c95200fa6c8c4ea553c2eeab1675ce4352f08c64aebcd2e39989989db29e0ffa6e4be7803cee1 WHIRLPOOL 76f4a07f4fb25cf9d94b44fcce8de55856c90fad9e8af904ec42056a5ea31b5e4f03c499e0383b2edac9e1615167b1495fc1b5beaec4881cc78fd471002e781d
+DIST textpow-1.4.0.tar.gz 386724 SHA256 71e6a2666a163fc6ad6562953f2e684f927c408dfedd892acfff2698ef76f080 SHA512 134b38e277118cf626e3e3643e447d7c7914dc89dba527682c4d6318a0d3b96edb81a68ac5e039158058de371ab9a326088cb119069c55032de7c2f1dadffdcc WHIRLPOOL 8525797d34d3465d684465ec88ececc137abc0a3270cc2019aee28a9c1676350d50ea2d8596b3232c6f9c36f584d1245a03ca11a92d78ec1ef0a0caf4249c28c
diff --git a/dev-ruby/textpow/metadata.xml b/dev-ruby/textpow/metadata.xml
new file mode 100644
index 000000000000..61358cbe7797
--- /dev/null
+++ b/dev-ruby/textpow/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+ <upstream>
+ <remote-id type="github">grosser/textpow</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/textpow/textpow-1.3.1-r1.ebuild b/dev-ruby/textpow/textpow-1.3.1-r1.ebuild
new file mode 100644
index 000000000000..a7a290738ca5
--- /dev/null
+++ b/dev-ruby/textpow/textpow-1.3.1-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="History.rdoc README.rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A library to parse and process Textmate bundles"
+HOMEPAGE="http://textpow.rubyforge.org/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/plist-3.0.1"
+
+all_ruby_prepare() {
+ sed -i -e '/git ls-files/d' textpow.gemspec || die
+}
diff --git a/dev-ruby/textpow/textpow-1.4.0.ebuild b/dev-ruby/textpow/textpow-1.4.0.ebuild
new file mode 100644
index 000000000000..4f0cd7d80ab6
--- /dev/null
+++ b/dev-ruby/textpow/textpow-1.4.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="History.rdoc README.rdoc"
+
+inherit ruby-fakegem
+
+SRC_URI="https://github.com/grosser/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+DESCRIPTION="A library to parse and process Textmate bundles"
+HOMEPAGE="http://textpow.rubyforge.org/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/plist-3.0.1"
+
+all_ruby_prepare() {
+ sed -i -e '/git ls-files/d' textpow.gemspec || die
+}