summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/treetop
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/treetop')
-rw-r--r--dev-ruby/treetop/Manifest3
-rw-r--r--dev-ruby/treetop/metadata.xml8
-rw-r--r--dev-ruby/treetop/treetop-1.4.15-r1.ebuild38
-rw-r--r--dev-ruby/treetop/treetop-1.5.3.ebuild38
-rw-r--r--dev-ruby/treetop/treetop-1.6.3.ebuild32
5 files changed, 119 insertions, 0 deletions
diff --git a/dev-ruby/treetop/Manifest b/dev-ruby/treetop/Manifest
new file mode 100644
index 000000000000..6a5b64548e6d
--- /dev/null
+++ b/dev-ruby/treetop/Manifest
@@ -0,0 +1,3 @@
+DIST treetop-1.4.15.gem 78336 SHA256 ffa68f201c0f62c26b0a1d13233d73194400596964696843f87ebb5d812f12ff SHA512 350e3b4fc5236f5523e7ba7486699192a689d680e60687519ffdb8707241fce493a86713d1a0a1e243654c609e221b194e151c29bee9aa7cff71ab397223791b WHIRLPOOL a474c3bb9fe43ce73c32cd795214fce168b9d8116746075ef982728b4ded802f5f5995efacf20501c42ddb90fe7e766880dd3e05dd7e8dc815cd804180007b74
+DIST treetop-1.5.3.gem 78336 SHA256 ab3c49c3a39e7c9bea88a90524545e39bed032758a130295f8d6a433c62ff472 SHA512 517ca72fe9c6d27c1ef6722a33b2639fdeb0867ad68b02a7d8795ec1b2bc3b9c9d56aaf400a4159c06c4714065c6a17e44bc985573cb11523d52b53b3a9ec9bf WHIRLPOOL b8b3300a99f65e837dabfd5beaa19d4d83c21b237736f8d675edf4a39ca8061e980b8ea4ccdab1f3c2cba0de0d25ec88db75bbd738258f1e1af2e5b4c632f345
+DIST treetop-1.6.3.gem 81920 SHA256 8b0bb528a57b9af6324ed7c9856b1d1ee2f1b53e71de79628bc47704234862bb SHA512 a4018f551ae74e84d126c4aa7e3bbcd2b2765175d1999bfac328b0b653cb6e5a5e599e51925575024af55092700bd40fd19c20c16d6cb2374d2f8d4b5f7a6229 WHIRLPOOL 20d8d302c309979fb0572c3d8388b3a39afcea31e29555a5173c78f2528a2943540587a059b087a3a380163fbac6f138ffb10e7df5dd48b0cfc42f00fe581461
diff --git a/dev-ruby/treetop/metadata.xml b/dev-ruby/treetop/metadata.xml
new file mode 100644
index 000000000000..b0254be8e627
--- /dev/null
+++ b/dev-ruby/treetop/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+ <upstream>
+ <remote-id type="github">cjheath/treetop</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/treetop/treetop-1.4.15-r1.ebuild b/dev-ruby/treetop/treetop-1.4.15-r1.ebuild
new file mode 100644
index 000000000000..a1cf6850b48a
--- /dev/null
+++ b/dev-ruby/treetop/treetop-1.4.15-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# jruby fails tests, not investigated yet.
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Treetop is a language for describing languages"
+HOMEPAGE="http://treetop.rubyforge.org/"
+LICENSE="Ruby"
+
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+SLOT="0"
+IUSE=""
+
+ruby_add_bdepend "test? ( >=dev-ruby/rr-0.10.2 dev-ruby/activesupport )"
+ruby_add_rdepend ">=dev-ruby/polyglot-0.3.1"
+
+all_ruby_prepare() {
+ # Use a ruby18 compatible regexp, already fixed upstream.
+ sed -i -e 's/\[:\^space:\]/\^[:space:]/' spec/compiler/character_class_spec.rb || die
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ insinto /usr/share/doc/${PF}/examples
+ doins -r examples/*
+}
diff --git a/dev-ruby/treetop/treetop-1.5.3.ebuild b/dev-ruby/treetop/treetop-1.5.3.ebuild
new file mode 100644
index 000000000000..3861c298e453
--- /dev/null
+++ b/dev-ruby/treetop/treetop-1.5.3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# jruby fails tests, not investigated yet.
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Treetop is a language for describing languages"
+HOMEPAGE="https://github.com/cjheath/treetop"
+LICENSE="Ruby"
+
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+SLOT="0"
+IUSE=""
+
+ruby_add_bdepend "test? ( >=dev-ruby/rr-1.0 dev-ruby/activesupport )"
+ruby_add_rdepend ">=dev-ruby/polyglot-0.3.1"
+
+all_ruby_prepare() {
+ # Use a ruby18 compatible regexp, already fixed upstream.
+ sed -i -e 's/\[:\^space:\]/\^[:space:]/' spec/compiler/character_class_spec.rb || die
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ insinto /usr/share/doc/${PF}/examples
+ doins -r examples/*
+}
diff --git a/dev-ruby/treetop/treetop-1.6.3.ebuild b/dev-ruby/treetop/treetop-1.6.3.ebuild
new file mode 100644
index 000000000000..84d6a6dea149
--- /dev/null
+++ b/dev-ruby/treetop/treetop-1.6.3.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Treetop is a language for describing languages"
+HOMEPAGE="https://github.com/cjheath/treetop"
+LICENSE="Ruby"
+
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+SLOT="0"
+IUSE=""
+
+ruby_add_bdepend "test? ( >=dev-ruby/rr-1.0 dev-ruby/activesupport )"
+ruby_add_rdepend ">=dev-ruby/polyglot-0.3.1:0"
+
+all_ruby_install() {
+ all_fakegem_install
+
+ insinto /usr/share/doc/${PF}/examples
+ doins -r examples/*
+}