summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/ttfunk
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/ttfunk')
-rw-r--r--dev-ruby/ttfunk/Manifest2
-rw-r--r--dev-ruby/ttfunk/metadata.xml8
-rw-r--r--dev-ruby/ttfunk/ttfunk-1.2.1.ebuild26
-rw-r--r--dev-ruby/ttfunk/ttfunk-1.4.0.ebuild26
4 files changed, 62 insertions, 0 deletions
diff --git a/dev-ruby/ttfunk/Manifest b/dev-ruby/ttfunk/Manifest
new file mode 100644
index 000000000000..8866ad50ef86
--- /dev/null
+++ b/dev-ruby/ttfunk/Manifest
@@ -0,0 +1,2 @@
+DIST ttfunk-1.2.1.tar.gz 733233 SHA256 49eddc8bc69ea2d829a08f0f753590291b3ac88b7e5e57c58cb2080aa70c0b9f SHA512 81e468a298ed0b4574573f0b6f5b23db73a32b8070520d5d143bc178d8e20cb4af4064476d7377d98301941765f24d6eeeb8ab3590878bf89531c1f729b7e97b WHIRLPOOL e3aee071bca615fd580cf21ec5f2ad3a5f44419a67d723c9aca1d1a3cb25cd22c0eee00d3aeaf8ef53361aa1588a3b0ffdf4c6cc61ddf37cf402c3048d4910c2
+DIST ttfunk-1.4.0.tar.gz 784076 SHA256 866abb6e808ef9ef92b2e9560e03913f613104dd60a2fbe7f6d1a66a2f41f8c7 SHA512 369c7230c3e1eee57f0fba77cf2bc67c3ef6c6a1d2ba0280e1c6776ea1a6aaffafd2cb1f1d410f7be9d594c640d6afa4fc985c4eea85938d2feb37c3c7886295 WHIRLPOOL e48d02eda78af068e99bea403b80f41328b160a29752738990df23596ad83b0b3c226434d3039aa70cabe0ce9f7f59cacb6193cc43b34a8baef1571c22a11444
diff --git a/dev-ruby/ttfunk/metadata.xml b/dev-ruby/ttfunk/metadata.xml
new file mode 100644
index 000000000000..ad58d17e7355
--- /dev/null
+++ b/dev-ruby/ttfunk/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+ <upstream>
+ <remote-id type="github">prawnpdf/ttfunk</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/ttfunk/ttfunk-1.2.1.ebuild b/dev-ruby/ttfunk/ttfunk-1.2.1.ebuild
new file mode 100644
index 000000000000..fbb1badece10
--- /dev/null
+++ b/dev-ruby/ttfunk/ttfunk-1.2.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+RUBY_FAKEGEM_EXTRADOC="README.rdoc"
+
+inherit ruby-fakegem versionator
+
+DESCRIPTION="A TrueType font parser written in pure ruby"
+HOMEPAGE="https://github.com/prawnpdf/ttfunk/"
+SRC_URI="https://github.com/prawnpdf/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="|| ( GPL-2 GPL-3 Ruby )"
+SLOT="$(get_version_component_range 1-2)"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+all_ruby_prepare() {
+ sed -i -e '/bundler/I s:^:#:' spec/spec_helper.rb || die
+}
diff --git a/dev-ruby/ttfunk/ttfunk-1.4.0.ebuild b/dev-ruby/ttfunk/ttfunk-1.4.0.ebuild
new file mode 100644
index 000000000000..fbb1badece10
--- /dev/null
+++ b/dev-ruby/ttfunk/ttfunk-1.4.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+RUBY_FAKEGEM_EXTRADOC="README.rdoc"
+
+inherit ruby-fakegem versionator
+
+DESCRIPTION="A TrueType font parser written in pure ruby"
+HOMEPAGE="https://github.com/prawnpdf/ttfunk/"
+SRC_URI="https://github.com/prawnpdf/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="|| ( GPL-2 GPL-3 Ruby )"
+SLOT="$(get_version_component_range 1-2)"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+all_ruby_prepare() {
+ sed -i -e '/bundler/I s:^:#:' spec/spec_helper.rb || die
+}