summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2022-08-02 06:40:30 +0200
committerHans de Graaff <graaff@gentoo.org>2022-08-02 06:41:06 +0200
commite2859c3577723dc7e118539e59a7465b84cc984b (patch)
treecb483bedc3dc20a6a823bba586494b062ac7aba6 /dev-ruby/webmock
parentmedia-sound/csound: dropped obsolete 6.16.2 (diff)
downloadgentoo-e2859c3577723dc7e118539e59a7465b84cc984b.tar.gz
gentoo-e2859c3577723dc7e118539e59a7465b84cc984b.tar.bz2
gentoo-e2859c3577723dc7e118539e59a7465b84cc984b.zip
dev-ruby/webmock: add 3.15.0
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/webmock')
-rw-r--r--dev-ruby/webmock/Manifest1
-rw-r--r--dev-ruby/webmock/webmock-3.15.0.ebuild63
2 files changed, 64 insertions, 0 deletions
diff --git a/dev-ruby/webmock/Manifest b/dev-ruby/webmock/Manifest
index 11009279069d..bf745f871ca9 100644
--- a/dev-ruby/webmock/Manifest
+++ b/dev-ruby/webmock/Manifest
@@ -1 +1,2 @@
DIST webmock-3.14.0.gem 126976 BLAKE2B 20dd463c8b784869d4379aeabf892a6b4602091a4cc01a4002161d88f24781bb2bae1e50bd0ce8077c40aab73a2243835d99551bd04d808ffdf019df071c2b01 SHA512 0c9ea5b29446de7619c45d0fb72ab305bf68150c9d657ddc223d0d258a400dc730e3fe401b46c994a5c8eb450db5ee8f7021fe8d2d6c85bc4723c657799c5ccc
+DIST webmock-3.15.0.gem 128000 BLAKE2B 10587fd127fe61076d34a36f71e6e61f43d6019a01d1906e1fa501697791deeb89a8a2cdc5fa92dee1b001cdd22055db913ae20414342faf0ae11cc301bf0e6e SHA512 9f2e6404b617cc1aa67dcaef941046f82e4602eaeef77084714a451be513fdbd6e6c54c090842c5519009d2ca0533b30ad17d225d3738cde526d037d3fe3335b
diff --git a/dev-ruby/webmock/webmock-3.15.0.ebuild b/dev-ruby/webmock/webmock-3.15.0.ebuild
new file mode 100644
index 000000000000..ff18bc5ed6e0
--- /dev/null
+++ b/dev-ruby/webmock/webmock-3.15.0.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby27 ruby30 ruby31"
+
+RUBY_FAKEGEM_TASK_TEST="test spec NO_CONNECTION=true"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Allows stubbing HTTP requests and setting expectations on HTTP requests"
+HOMEPAGE="https://github.com/bblimke/webmock"
+
+LICENSE="GPL-2"
+SLOT="3"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_rdepend "
+ >=dev-ruby/addressable-2.8.0
+ >=dev-ruby/crack-0.3.2
+ >=dev-ruby/hashdiff-0.4.0:0
+"
+
+ruby_add_bdepend "test? (
+ dev-ruby/minitest:5
+ dev-ruby/rspec:3
+ >=dev-ruby/test-unit-3.0.0
+ dev-ruby/rack
+)"
+
+all_ruby_prepare() {
+ # Remove bundler support
+ rm Gemfile || die
+ sed -i -e '/[Bb]undler/d' Rakefile || die
+ sed -i -e '/simplecov/I s:^:#:' spec/spec_helper.rb || die
+ sed -i -e '1igem "test-unit"' test/test_helper.rb || die
+
+ # There is now optional support for curb and typhoeus which we don't
+ # have in Gentoo yet. em_http_request is available in Gentoo but its
+ # version is too old. patron's latest version is not compatible.
+ # httpclient is no longer maintained and has various test failures.
+ sed -i -e '/\(curb\|typhoeus\|em-http\|patron\|httpclient\)/ s:^:#:' spec/spec_helper.rb || die
+ rm -f spec/acceptance/{typhoeus,curb,excon,em_http_request,patron,async_http_client,httpclient}/* || die
+
+ # Drop tests for dev-ruby/http for now since this package only works with ruby26
+ sed -i -e '/http_rb/ s:^:#:' spec/spec_helper.rb || die
+ rm -f spec/acceptance/http_rb/* || die
+
+ # Avoid specs that require network access
+ sed -i -e '/when request is not stubbed/,/^ end/ s:^:#:' spec/acceptance/shared/callbacks.rb
+}
+
+each_ruby_test() {
+ ${RUBY} -S rake test NO_CONNECTION=true || die
+ ${RUBY} -S rspec-3 spec || die
+
+ einfo "Delay to allow the test server to stop"
+ sleep 10
+}