summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2018-05-27 07:07:04 +0200
committerHans de Graaff <graaff@gentoo.org>2018-05-27 07:07:04 +0200
commit0a753425e886d03d790af8c20d0071cd84cf0459 (patch)
treeff2d8d30e717c0e842ff91b6e30de65e7f0cb8f3 /dev-ruby/xpath
parentdev-db/rqlite: version bump to 4.3.0 (diff)
downloadgentoo-0a753425e886d03d790af8c20d0071cd84cf0459.tar.gz
gentoo-0a753425e886d03d790af8c20d0071cd84cf0459.tar.bz2
gentoo-0a753425e886d03d790af8c20d0071cd84cf0459.zip
dev-ruby/xpath: add 3.1.0
Package-Manager: Portage-2.3.36, Repoman-2.3.9
Diffstat (limited to 'dev-ruby/xpath')
-rw-r--r--dev-ruby/xpath/Manifest1
-rw-r--r--dev-ruby/xpath/xpath-3.1.0.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/dev-ruby/xpath/Manifest b/dev-ruby/xpath/Manifest
index 35869a51dd0a..2e481f94037b 100644
--- a/dev-ruby/xpath/Manifest
+++ b/dev-ruby/xpath/Manifest
@@ -1,2 +1,3 @@
DIST xpath-2.1.0.gem 16896 BLAKE2B b8dc2b0e207c666446ba5948f6e37c71f410d8a5a027dddd17d5ccb2fa8b0c32f274a34cc144a2380b22266248acad288828114a755d4f04c2a1caeec6ee55e3 SHA512 50d80cac3fd65cbd211d3a87b8844a6607b14c841a1a5609e2370c3624daf719b937a61e526bf31aedee13346802d6bbb721d58bda2bef9c564c187b28bb90e2
DIST xpath-3.0.0.gem 13824 BLAKE2B 19b41febf466a8bd72cab071fd8e68844c3bf1b2c06ce4aefe6c5a08e4f57ec8f1fd8478c60076a7e6967a85faf49680950f66ab9ebf1d2c47326da40e1f1847 SHA512 fd1e8cfff11e8c14efb1ad2cabb9a0a3bc3d79d40b61264c524ff4524c5e7b9ff86de0746f4530fe7501f5e5e1683cb87c4a479f5e67deb7d8f93ed552ec78d6
+DIST xpath-3.1.0.gem 13824 BLAKE2B 68f8267fe5bd4d5761e24d7950bec321cfdfa82a836337d8f702796e4ff7fdf8dcc0d1d929d58a7595fafe3ca4a1c9e6853b9b4327362befca1b099162f0fa55 SHA512 e9bab0a7555369af412528f56d1fc561119523adcab6555d7b48e88f17166805fda7d73ee2a9ad01f4b87da9ffcafbbe25bc6ac5b87b608eff1b39d31d956b86
diff --git a/dev-ruby/xpath/xpath-3.1.0.ebuild b/dev-ruby/xpath/xpath-3.1.0.ebuild
new file mode 100644
index 000000000000..14f25fc184b8
--- /dev/null
+++ b/dev-ruby/xpath/xpath-3.1.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby23 ruby24 ruby25"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+inherit ruby-fakegem
+
+DESCRIPTION="XPath is a Ruby DSL around a subset of XPath 1.0"
+HOMEPAGE="https://github.com/jnicklas/xpath"
+LICENSE="MIT"
+
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~x86"
+SLOT="3"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/nokogiri-1.8:0"
+
+all_ruby_prepare() {
+ sed -i -e '/\(bundler\|pry\)/d' spec/spec_helper.rb || die
+}