summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2021-02-22 07:47:05 +0100
committerHans de Graaff <graaff@gentoo.org>2021-02-22 07:48:08 +0100
commit126b5dcd239549833a1c92a11c56cf0448d9f294 (patch)
tree44c83f8cd151e9e8fdd657178415b9ad51abd71c /dev-ruby
parentdev-ruby/httparty: add ruby27 (diff)
downloadgentoo-126b5dcd239549833a1c92a11c56cf0448d9f294.tar.gz
gentoo-126b5dcd239549833a1c92a11c56cf0448d9f294.tar.bz2
gentoo-126b5dcd239549833a1c92a11c56cf0448d9f294.zip
dev-ruby/webrobots: add ruby27
Package-Manager: Portage-3.0.13, Repoman-3.0.2 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/webrobots/webrobots-0.1.2-r2.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-ruby/webrobots/webrobots-0.1.2-r2.ebuild b/dev-ruby/webrobots/webrobots-0.1.2-r2.ebuild
new file mode 100644
index 000000000000..0a5a75709837
--- /dev/null
+++ b/dev-ruby/webrobots/webrobots-0.1.2-r2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+USE_RUBY="ruby25 ruby26 ruby27"
+
+RUBY_FAKEGEM_DOCDIR="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A library to help write robots.txt compliant web robots"
+HOMEPAGE="https://github.com/knu/webrobots"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-solaris"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/nokogiri-1.4.4"
+
+ruby_add_bdepend "test? ( dev-ruby/shoulda dev-ruby/test-unit:2 dev-ruby/webmock dev-ruby/vcr )"
+
+all_ruby_prepare() {
+ sed -i -e '/bundler/,/end/d' Rakefile test/helper.rb || die
+
+ # Avoid tests for live websites requirering a network connection.
+ sed -i -e '/robots.txt in the real world/,/^ end/ s:^:#:' test/test_webrobots.rb || die
+}
+
+each_ruby_test() {
+ ruby-ng_testrb-2 -Ilib test/test_*.rb
+}