summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-scheme/greg
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-scheme/greg')
-rw-r--r--dev-scheme/greg/Manifest1
-rw-r--r--dev-scheme/greg/files/2.0.0-notest.patch12
-rw-r--r--dev-scheme/greg/files/greg-2.0.0-test.patch12
-rw-r--r--dev-scheme/greg/greg-2.0.0-r1.ebuild30
-rw-r--r--dev-scheme/greg/greg-2.0.0.ebuild29
-rw-r--r--dev-scheme/greg/metadata.xml8
6 files changed, 92 insertions, 0 deletions
diff --git a/dev-scheme/greg/Manifest b/dev-scheme/greg/Manifest
new file mode 100644
index 000000000000..966cb192437e
--- /dev/null
+++ b/dev-scheme/greg/Manifest
@@ -0,0 +1 @@
+DIST greg-2.0.0.tar.gz 453598 SHA256 da917cc45747f1369771860d635661e8fdc6e604eb20aa2c25fae0d113e4d769 SHA512 d20523b4f6fcfcb183615866a3b322dad39579707f6979ad1edf11dac4c93f5c8dda109a4d832aae597b44397befe81afb6ae9be282556228ade1ad48e8a17eb WHIRLPOOL dfd59766a428ee2757bfebf871637e1bccd5e9ab691c10ae51e8149914aba1eaf2bf28f5999b8f934ad825a2144e31d9495954175726a4b169978b23d199f4f4
diff --git a/dev-scheme/greg/files/2.0.0-notest.patch b/dev-scheme/greg/files/2.0.0-notest.patch
new file mode 100644
index 000000000000..26a6cdf1c0ad
--- /dev/null
+++ b/dev-scheme/greg/files/2.0.0-notest.patch
@@ -0,0 +1,12 @@
+diff --git a/test/Makefile.am b/test/Makefile.am
+index 3cda45d..c61b34e 100644
+--- a/test/Makefile.am
++++ b/test/Makefile.am
+@@ -23,7 +23,6 @@
+
+
+ all:
+- ./test.sh
+
+ check:
+ ./test.sh
diff --git a/dev-scheme/greg/files/greg-2.0.0-test.patch b/dev-scheme/greg/files/greg-2.0.0-test.patch
new file mode 100644
index 000000000000..26a6cdf1c0ad
--- /dev/null
+++ b/dev-scheme/greg/files/greg-2.0.0-test.patch
@@ -0,0 +1,12 @@
+diff --git a/test/Makefile.am b/test/Makefile.am
+index 3cda45d..c61b34e 100644
+--- a/test/Makefile.am
++++ b/test/Makefile.am
+@@ -23,7 +23,6 @@
+
+
+ all:
+- ./test.sh
+
+ check:
+ ./test.sh
diff --git a/dev-scheme/greg/greg-2.0.0-r1.ebuild b/dev-scheme/greg/greg-2.0.0-r1.ebuild
new file mode 100644
index 000000000000..f0a7a835ae42
--- /dev/null
+++ b/dev-scheme/greg/greg-2.0.0-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=true
+
+inherit autotools-utils
+
+DESCRIPTION="Testing-Framework for guile"
+HOMEPAGE="http://gna.org/projects/greg/"
+SRC_URI="http://download.gna.org/${PN}/${P}.tar.gz"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+LICENSE="GPL-2"
+IUSE="static-libs"
+
+RDEPEND=">=dev-scheme/guile-1.8"
+DEPEND=""
+
+PATCHES=( "${FILESDIR}"/${P}-test.patch )
+
+src_test() {
+ cd test || die
+ export LD_LIBRARY_PATH="$LD_LIBRARY_PATH:${BUILD_DIR}/src/.libs"
+ export GUILE_LOAD_PATH="$GUILE_LOAD_PATH:${BUILD_DIR}/src/"
+ guile -s "${S}"/src/greg || die
+}
diff --git a/dev-scheme/greg/greg-2.0.0.ebuild b/dev-scheme/greg/greg-2.0.0.ebuild
new file mode 100644
index 000000000000..14f2be18112d
--- /dev/null
+++ b/dev-scheme/greg/greg-2.0.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="3"
+
+inherit autotools eutils
+
+DESCRIPTION="Testing-Framework for guile"
+HOMEPAGE="http://gna.org/projects/greg/"
+SRC_URI="http://download.gna.org/${PN}/${P}.tar.gz"
+
+SLOT="0"
+KEYWORDS="amd64 x86"
+LICENSE="GPL-2"
+IUSE=""
+
+RDEPEND=">=dev-scheme/guile-1.8"
+DEPEND=""
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PV}-notest.patch
+ eautoreconf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc NEWS README AUTHORS ChangeLog || die
+}
diff --git a/dev-scheme/greg/metadata.xml b/dev-scheme/greg/metadata.xml
new file mode 100644
index 000000000000..4bf6dbc6b1ea
--- /dev/null
+++ b/dev-scheme/greg/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci</herd>
+ <maintainer>
+ <email>sci@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>