summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-tcltk/bwidget
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-tcltk/bwidget')
-rw-r--r--dev-tcltk/bwidget/Manifest1
-rw-r--r--dev-tcltk/bwidget/bwidget-1.9.8.ebuild43
-rw-r--r--dev-tcltk/bwidget/files/bwidget-1.9.7-test.patch31
-rw-r--r--dev-tcltk/bwidget/files/bwidget-1.9.8-test.patch16
-rw-r--r--dev-tcltk/bwidget/metadata.xml8
5 files changed, 99 insertions, 0 deletions
diff --git a/dev-tcltk/bwidget/Manifest b/dev-tcltk/bwidget/Manifest
new file mode 100644
index 000000000000..6cf3053c1ad2
--- /dev/null
+++ b/dev-tcltk/bwidget/Manifest
@@ -0,0 +1 @@
+DIST bwidget-1.9.8.tar.gz 252668 SHA256 545016e3ee998991308f54d8ef26bbf16144ee50fa432b9100d37ef806bdb314 SHA512 437958871809c8ce285cbf4521ff08720d106dca708183ff94234015da2b04ccb3a7b05df13d8e3f46466106c91418607c5983fc4ed8d9c4285ae0a0b1071262 WHIRLPOOL 4ee88816e8abab426c846ccc8a688a347ba9bdc43288b10ec56fec3f695f7733140441a686f321035cb1aebfc100178c263945c8a36c4b15b1ad227af72ee844
diff --git a/dev-tcltk/bwidget/bwidget-1.9.8.ebuild b/dev-tcltk/bwidget/bwidget-1.9.8.ebuild
new file mode 100644
index 000000000000..adfcc4ca6483
--- /dev/null
+++ b/dev-tcltk/bwidget/bwidget-1.9.8.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils multilib virtualx
+
+MY_PN=${PN/bw/BW}
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="High-level widget set for Tcl/Tk"
+HOMEPAGE="http://tcllib.sourceforge.net/"
+SRC_URI="mirror://sourceforge/project/tcllib/${MY_PN}/${PV}/${P}.tar.gz"
+
+LICENSE="tcltk"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ppc ppc64 sparc x86"
+IUSE="doc"
+
+DEPEND="dev-lang/tk:0"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-test.patch
+}
+
+src_test() {
+ VIRTUALX_COMMAND=tclsh
+ virtualmake tests/entry.test
+}
+
+src_install() {
+ insinto /usr/$(get_libdir)/${P}
+ doins *.tcl
+ doins -r images lang
+
+ insinto /usr/share/doc/${PF}/
+ doins -r demo
+ dodoc ChangeLog README.txt
+
+ use doc && dohtml BWman/*
+}
diff --git a/dev-tcltk/bwidget/files/bwidget-1.9.7-test.patch b/dev-tcltk/bwidget/files/bwidget-1.9.7-test.patch
new file mode 100644
index 000000000000..ff293f6450ca
--- /dev/null
+++ b/dev-tcltk/bwidget/files/bwidget-1.9.7-test.patch
@@ -0,0 +1,31 @@
+Index: tests/entry.test
+==================================================================
+--- tests/entry.test
++++ tests/entry.test
+@@ -21,11 +21,11 @@
+ {-bg #ff0000 #ff0000 non-existent {unknown color name "non-existent"}}
+ {-borderwidth 1.3 1 badValue {bad screen distance "badValue"}}
+ {-command foo foo {} {}}
+ {-disabledforeground blue blue non-existent \
+ {unknown color name "non-existent"}}
+- {-editable false false shazbot {expected boolean value but got "shazbot"}}
++ {-editable false 0 shazbot {expected boolean value but got "shazbot"}}
+ {-exportselection yes 1 xyzzy {expected boolean value but got "xyzzy"}}
+ {-fg #110022 #110022 bogus {unknown color name "bogus"}}
+ {-font {Helvetica 12 italic} {Helvetica 12 italic} {} \
+ {font "" doesn't exist}}
+ {-foreground #110022 #110022 bogus {unknown color name "bogus"}}
+@@ -63,11 +63,11 @@
+ }
+ destroy .e
+
+ test Entry-2.1 {Entry} {
+ list [catch {Entry} msg] $msg
+-} {1 {no value given for parameter "path" to "Entry"}}
++} {1 {wrong # args: should be "Entry path ?arg ...?"}}
+ test Entry-2.2 {Entry} {
+ list [catch {Entry gorp} msg] $msg
+ } {1 {bad window path name "gorp"}}
+ test Entry-2.3 {Entry procedure} {
+ Entry .e
+
diff --git a/dev-tcltk/bwidget/files/bwidget-1.9.8-test.patch b/dev-tcltk/bwidget/files/bwidget-1.9.8-test.patch
new file mode 100644
index 000000000000..077abf308b88
--- /dev/null
+++ b/dev-tcltk/bwidget/files/bwidget-1.9.8-test.patch
@@ -0,0 +1,16 @@
+ tests/entry.test | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/tests/entry.test b/tests/entry.test
+index 4bc3a5f..727a7d8 100644
+--- a/tests/entry.test
++++ b/tests/entry.test
+@@ -65,7 +65,7 @@ destroy .e
+
+ test Entry-2.1 {Entry} {
+ list [catch {Entry} msg] $msg
+-} {1 {wrong # args: should be "Entry path ..."}}
++} {1 {wrong # args: should be "Entry path ?arg ...?"}}
+ test Entry-2.2 {Entry} {
+ list [catch {Entry gorp} msg] $msg
+ } {1 {bad window path name "gorp"}}
diff --git a/dev-tcltk/bwidget/metadata.xml b/dev-tcltk/bwidget/metadata.xml
new file mode 100644
index 000000000000..c9ab155ba8d5
--- /dev/null
+++ b/dev-tcltk/bwidget/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>tcltk</herd>
+ <upstream>
+ <remote-id type="sourceforge">tcllib</remote-id>
+ </upstream>
+</pkgmetadata>