summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2024-04-20 16:27:37 +0200
committerAlfredo Tupone <tupone@gentoo.org>2024-04-20 16:37:39 +0200
commit535f35b4369f28eb4f043297fc50c71e05bb9330 (patch)
treebc6ea10f13234ecf1a145ac064b8c2b37de1aef3 /dev-tcltk
parentmedia-libs/libshumate: add 1.1.4 (diff)
downloadgentoo-535f35b4369f28eb4f043297fc50c71e05bb9330.tar.gz
gentoo-535f35b4369f28eb4f043297fc50c71e05bb9330.tar.bz2
gentoo-535f35b4369f28eb4f043297fc50c71e05bb9330.zip
dev-tcltk/snack: PythonCompatUpdate
Closes: https://bugs.gentoo.org/929524 Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'dev-tcltk')
-rw-r--r--dev-tcltk/snack/files/snack-2.2.10-py3.8.patch11
-rw-r--r--dev-tcltk/snack/snack-2.2.10-r11.ebuild8
-rw-r--r--dev-tcltk/snack/snack-2.2.10-r13.ebuild (renamed from dev-tcltk/snack/snack-2.2.10-r12.ebuild)11
3 files changed, 21 insertions, 9 deletions
diff --git a/dev-tcltk/snack/files/snack-2.2.10-py3.8.patch b/dev-tcltk/snack/files/snack-2.2.10-py3.8.patch
new file mode 100644
index 000000000000..ec42b50eac88
--- /dev/null
+++ b/dev-tcltk/snack/files/snack-2.2.10-py3.8.patch
@@ -0,0 +1,11 @@
+--- a/python/tkSnack.py 2024-04-20 16:01:28.403396211 +0200
++++ b/python/tkSnack.py 2024-04-20 16:01:55.094084757 +0200
+@@ -267,7 +267,7 @@
+
+ def pitch(self, method=None, **kw):
+ """Returns a list of pitch values."""
+- if method is None or method is "amdf" or method is "AMDF":
++ if method is None or method == "amdf" or method == "AMDF":
+ result = self.tk.call((self.name, 'pitch') + self._options(kw))
+ return self._getdoubles(result)
+ else:
diff --git a/dev-tcltk/snack/snack-2.2.10-r11.ebuild b/dev-tcltk/snack/snack-2.2.10-r11.ebuild
index 86a34a7ced5e..1c38016a77ef 100644
--- a/dev-tcltk/snack/snack-2.2.10-r11.ebuild
+++ b/dev-tcltk/snack/snack-2.2.10-r11.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -13,9 +13,11 @@ DESCRIPTION="The Snack Sound Toolkit (Tcl)"
HOMEPAGE="http://www.speech.kth.se/snack/"
SRC_URI="http://www.speech.kth.se/snack/dist/${PN}${PV}.tar.gz"
+S="${WORKDIR}/${PN}${PV}/unix"
+
LICENSE="GPL-2"
-KEYWORDS="amd64 ~hppa ppc sparc x86 ~amd64-linux ~x86-linux ~ppc-macos"
SLOT="0"
+KEYWORDS="amd64 ~hppa ppc sparc x86 ~amd64-linux ~x86-linux ~ppc-macos"
IUSE="alsa examples python vorbis"
RESTRICT="!test? ( test )"
@@ -33,8 +35,6 @@ BDEPEND="python? (
REQUIRED_USE=${PYTHON_REQUIRED_USE}
-S="${WORKDIR}/${PN}${PV}/unix"
-
PATCHES=(
"${FILESDIR}"/alsa-undef-sym.patch
"${FILESDIR}"/${P}-CVE-2012-6303-fix.patch
diff --git a/dev-tcltk/snack/snack-2.2.10-r12.ebuild b/dev-tcltk/snack/snack-2.2.10-r13.ebuild
index f99820784cc1..2e42ff833080 100644
--- a/dev-tcltk/snack/snack-2.2.10-r12.ebuild
+++ b/dev-tcltk/snack/snack-2.2.10-r13.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_COMPAT=( python3_{9..12} )
DISTUTILS_USE_PEP517=setuptools
DISTUTILS_OPTIONAL=yes
@@ -13,10 +13,12 @@ DESCRIPTION="The Snack Sound Toolkit (Tcl)"
HOMEPAGE="http://www.speech.kth.se/snack/"
SRC_URI="http://www.speech.kth.se/snack/dist/${PN}${PV}.tar.gz"
+S="${WORKDIR}/${PN}${PV}/unix"
LICENSE="GPL-2"
-KEYWORDS="amd64 ~arm64 ~hppa ppc sparc x86 ~amd64-linux ~x86-linux ~ppc-macos"
SLOT="0"
+KEYWORDS="amd64 ~arm64 ~hppa ppc sparc x86 ~amd64-linux ~x86-linux ~ppc-macos"
IUSE="alsa examples python vorbis"
+
RESTRICT="!test? ( test )"
DEPEND="
@@ -33,8 +35,6 @@ BDEPEND="python? (
REQUIRED_USE=${PYTHON_REQUIRED_USE}
-S="${WORKDIR}/${PN}${PV}/unix"
-
PATCHES=(
"${FILESDIR}"/alsa-undef-sym.patch
"${FILESDIR}"/${P}-CVE-2012-6303-fix.patch
@@ -46,6 +46,7 @@ PATCHES=(
"${FILESDIR}"/${P}-configure-clang16.patch
"${FILESDIR}"/${P}-implicit.patch
"${FILESDIR}"/${P}-parallelMake.patch
+ "${FILESDIR}"/${P}-py3.8.patch
)
HTML_DOCS="${WORKDIR}/${PN}${PV}/doc/*"