summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMagnus Granberg <zorry@gentoo.org>2024-03-10 22:35:37 +0100
committerSam James <sam@gentoo.org>2024-03-14 05:37:15 +0000
commita6badccd3049ba1a477e6272f3ac82d0af6a477f (patch)
tree0c22c48b5d056fa1a148842cbf1db08d5845d806 /dev-util/buildbot
parentdev-libs/libmcrypt: filter LTO, no-SA (diff)
downloadgentoo-a6badccd3049ba1a477e6272f3ac82d0af6a477f.tar.gz
gentoo-a6badccd3049ba1a477e6272f3ac82d0af6a477f.tar.bz2
gentoo-a6badccd3049ba1a477e6272f3ac82d0af6a477f.zip
dev-util/buildbot: add 3.11.1
Signed-off-by: Magnus Granberg <zorry@gentoo.org> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-util/buildbot')
-rw-r--r--dev-util/buildbot/Manifest1
-rw-r--r--dev-util/buildbot/buildbot-3.11.1.ebuild187
-rw-r--r--dev-util/buildbot/files/buildbot-importlib.resources.patch13
3 files changed, 201 insertions, 0 deletions
diff --git a/dev-util/buildbot/Manifest b/dev-util/buildbot/Manifest
index c1b132c5f02d..eed318c38487 100644
--- a/dev-util/buildbot/Manifest
+++ b/dev-util/buildbot/Manifest
@@ -1,3 +1,4 @@
DIST buildbot-3.11.0.tar.gz 2523691 BLAKE2B e64a84fa1678d313ef922cb43e3a2df974e1c8e7b8c53a1ec20b6ef177eee5ca66bbe012bdf4754cc135e91fba883237b370f99fbbf780ef1fcab07305f941a7 SHA512 86f6545573473aa48890a9b6e5165c55c5223ab365a1f7bf019e468396f52c4cb3dc93458aae15cef40ff0eb576bd55002a8ae78144cd86271d9a230f1bd40b8
+DIST buildbot-3.11.1.tar.gz 2524103 BLAKE2B aa95e6f6963e0504e1e61147a4ceb09448f804ece33251c45914b731572923de68f6cda88f9a3c37eab2b695dfcb379c1745ce3b280e04232075819d41c5030b SHA512 ea9155c48fb44d6cf967e3b821bcca368f2a50bcc49e2b889e237ff17d0e6a222253a2fa2cd7876ade2edef05d50cead05090c3e73ecda0530e7d6c617376b8b
DIST buildbot-3.6.1.tar.gz 2458176 BLAKE2B 4587ed222e2fae424f3c4f275e67e72bf25b0ce88231a29f931582d82fbe93a846f85b14bdc64740939466ccdc3f15dab3774244aa5c0a293250b52b542014ea SHA512 62a993d1acd8bc5cc916f009909b4b099d9f64007fe790dc219104f248bb21e0ab8f1771c354ef61e6d8ba497451cdef5e7a7de17a87cfd1e941b3b49fbf2206
DIST buildbot-3.9.0.tar.gz 2505725 BLAKE2B 144a16655a8ec23d74ba190a7867a2dce9c65ea6009aa53ea11494be6f03f8d45bc6568a36511812e7664bcc7de9540728b91264251a46301cbd7ebec04c2069 SHA512 9103c5e08f9d5335c0281403d81fc939cc91b81e8051d4590f29e00779392ac706934d209312e51aafc44a35ab768ad54cbd251afe50e326c52e2f1b0d72196b
diff --git a/dev-util/buildbot/buildbot-3.11.1.ebuild b/dev-util/buildbot/buildbot-3.11.1.ebuild
new file mode 100644
index 000000000000..cbcbf3a1fd00
--- /dev/null
+++ b/dev-util/buildbot/buildbot-3.11.1.ebuild
@@ -0,0 +1,187 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_REQ_USE="sqlite"
+PYTHON_COMPAT=( python3_{10..12} )
+inherit readme.gentoo-r1 systemd distutils-r1 pypi
+
+DESCRIPTION="BuildBot build automation system"
+HOMEPAGE="https://buildbot.net/
+ https://github.com/buildbot/buildbot
+ https://pypi.org/project/buildbot/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~amd64-linux ~x86-linux"
+
+IUSE="crypt docker examples irc test"
+RESTRICT="!test? ( test )"
+
+# use python's importlib
+PATCHES=(
+ "${FILESDIR}/buildbot-importlib.resources.patch"
+)
+
+RDEPEND="
+ acct-user/buildbot
+ >=dev-python/alembic-1.6.0[${PYTHON_USEDEP}]
+ >=dev-python/autobahn-0.16.0[${PYTHON_USEDEP}]
+ >=dev-python/croniter-1.3.0[${PYTHON_USEDEP}]
+ >=dev-python/msgpack-0.6.0[${PYTHON_USEDEP}]
+ >=dev-python/jinja-2.1[${PYTHON_USEDEP}]
+ >=dev-python/python-dateutil-1.5[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/pyjwt[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ >=dev-python/sqlalchemy-1.3.0[${PYTHON_USEDEP}]
+ <dev-python/sqlalchemy-1.5.0[${PYTHON_USEDEP}]
+ >=dev-python/twisted-18.7.0[${PYTHON_USEDEP}]
+ >=dev-python/txaio-2.2.2[${PYTHON_USEDEP}]
+ >=dev-python/unidiff-0.7.5[${PYTHON_USEDEP}]
+ >=dev-python/zope-interface-4.1.1[${PYTHON_USEDEP}]
+ crypt? (
+ >=dev-python/pyopenssl-16.0.0[${PYTHON_USEDEP}]
+ dev-python/service-identity[${PYTHON_USEDEP}]
+ || (
+ >=dev-python/twisted-18.7.0[${PYTHON_USEDEP},ssl(-)]
+ >=dev-python/twisted-18.7.0[${PYTHON_USEDEP},crypt(-)]
+ )
+ dev-python/idna[${PYTHON_USEDEP}]
+ )
+ irc? (
+ dev-python/txrequests[${PYTHON_USEDEP}]
+ )
+ docker? (
+ >=dev-python/docker-7.0.0[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ )
+"
+BDEPEND="
+ test? (
+ ${RDEPEND}
+ ~dev-util/buildbot-pkg-${PV}[${PYTHON_USEDEP}]
+ ~dev-util/buildbot-worker-${PV}[${PYTHON_USEDEP}]
+ ~dev-util/buildbot-www-${PV}[${PYTHON_USEDEP}]
+ >=dev-python/boto3-1.12.48[${PYTHON_USEDEP}]
+ dev-python/lz4[${PYTHON_USEDEP}]
+ dev-python/ldap3[${PYTHON_USEDEP}]
+ >=dev-python/markdown-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/moto-4.2.13[${PYTHON_USEDEP}]
+ dev-python/parameterized[${PYTHON_USEDEP}]
+ dev-python/pypugjs[${PYTHON_USEDEP}]
+ dev-python/txrequests[${PYTHON_USEDEP}]
+ dev-python/treq[${PYTHON_USEDEP}]
+ )"
+
+DOC_CONTENTS="The \"buildbot\" user and the \"buildmaster\" init script has been added
+to support starting buildbot through Gentoo's init system. To use this,
+execute \"emerge --config =${CATEGORY}/${PF}\" to create a new instance.
+The scripts can run as a different user if desired."
+
+src_prepare() {
+ # disable all warnings as errors
+ sed -e "/warnings.filterwarnings('error')/d" -i buildbot/test/__init__.py || die
+ # https://github.com/buildbot/buildbot/issues/6776
+ # https://bugs.gentoo.org/904062
+ rm buildbot/test/integration/test_try_client.py || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ "${EPYTHON}" -m twisted.trial buildbot || die "Tests failed with ${EPYTHON}"
+}
+
+src_install() {
+ distutils-r1_src_install
+
+ doman docs/buildbot.1
+
+ if use examples; then
+ dodoc -r docs/examples
+ fi
+
+ newconfd "${FILESDIR}/buildmaster.confd" buildmaster
+ newinitd "${FILESDIR}/buildmaster.initd" buildmaster
+ systemd_dounit "${FILESDIR}/buildmaster.target"
+ systemd_newunit "${FILESDIR}/buildmaster_at.service" "buildmaster@.service"
+ systemd_install_serviced "${FILESDIR}/buildmaster_at.service.conf" "buildmaster@.service"
+
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+
+ if [[ -n ${REPLACING_VERSIONS} ]]; then
+ ewarn
+ ewarn "Starting with buildbot-0.8.12-r2, more than one instance of buildmaster"
+ ewarn "can be run simultaneously. Note that \"BASEDIR\" in the buildbot configuration file"
+ ewarn "is now the common base directory for all instances. If you are migrating from an older"
+ ewarn "version, make sure that you copy the current contents of \"BASEDIR\" to a subdirectory."
+ ewarn "The name of the subdirectory corresponds to the name of the buildmaster instance."
+ ewarn "In order to start the service running OpenRC-based systems need to link to the init file:"
+ ewarn " ln --symbolic --relative /etc/init.d/buildmaster /etc/init.d/buildmaster.myinstance"
+ ewarn " rc-update add buildmaster.myinstance default"
+ ewarn " /etc/init.d/buildmaster.myinstance start"
+ ewarn "Systems using systemd can do the following:"
+ ewarn " systemctl enable buildmaster@myinstance.service"
+ ewarn " systemctl enable buildmaster.target"
+ ewarn " systemctl start buildmaster.target"
+ elog
+ elog "Upstream recommends the following when upgrading:"
+ elog "Each time you install a new version of Buildbot, you should run the"
+ elog "\"buildbot upgrade-master\" command on each of your pre-existing build masters."
+ elog "This will add files and fix (or at least detect) incompatibilities between"
+ elog "your old config and the new code."
+ fi
+ elog
+ elog "In order to create a new instance of buildmaster, execute:"
+ elog " emerge --config =${CATEGORY}/${PF}"
+}
+
+pkg_config() {
+ local buildmaster_path="/var/lib/buildmaster"
+ local log_path="/var/log/buildmaster"
+
+ einfo "This will prepare a new buildmaster instance in ${buildmaster_path}."
+ einfo "Press Control-C to abort."
+
+ einfo "Enter the name for the new instance: "
+ read instance_name
+ [[ -z "${instance_name}" ]] && die "Invalid instance name"
+
+ local instance_path="${buildmaster_path}/${instance_name}"
+ local instance_log_path="${log_path}/${instance_name}"
+
+ if [[ -e "${instance_path}" ]]; then
+ eerror "The instance with the specified name already exists:"
+ eerror "${instance_path}"
+ die "Instance already exists"
+ fi
+
+ local buildbot="/usr/bin/buildbot"
+ if [[ ! -d "${buildmaster_path}" ]]; then
+ mkdir --parents "${buildmaster_path}" || die "Unable to create directory ${buildmaster_path}"
+ fi
+ "${buildbot}" create-master "${instance_path}" &>/dev/null || die "Creating instance failed"
+ chown --recursive buildbot:buildbot "${instance_path}" || die "Setting permissions for instance failed"
+ mv "${instance_path}/master.cfg.sample" "${instance_path}/master.cfg" \
+ || die "Moving sample configuration failed"
+ ln --symbolic --relative "/etc/init.d/buildmaster" "/etc/init.d/buildmaster.${instance_name}" \
+ || die "Unable to create link to init file"
+
+ if [[ ! -d "${instance_log_path}" ]]; then
+ mkdir --parents "${instance_log_path}" || die "Unable to create directory ${instance_log_path}"
+ chown --recursive buildbot:buildbot "${instance_log_path}" \
+ || die "Setting permissions for instance failed"
+ fi
+ ln --symbolic --relative "${instance_log_path}/twistd.log" "${instance_path}/twistd.log" \
+ || die "Unable to create link to log file"
+
+ einfo "Successfully created a buildmaster instance at ${instance_path}."
+ einfo "To change the default settings edit the master.cfg file in this directory."
+}
diff --git a/dev-util/buildbot/files/buildbot-importlib.resources.patch b/dev-util/buildbot/files/buildbot-importlib.resources.patch
new file mode 100644
index 000000000000..3854b93fe4b8
--- /dev/null
+++ b/dev-util/buildbot/files/buildbot-importlib.resources.patch
@@ -0,0 +1,13 @@
+https://github.com/buildbot/buildbot/pull/7270
+We don't use older python then 3.10 so use importlib.resources
+--- a/buildbot/www/plugin.py 2023-12-27 11:18:13.107479017 +0100
++++ b/buildbot/www/plugin.py 2023-12-27 11:20:55.710106750 +0100
+@@ -14,7 +14,7 @@
+ # Copyright Buildbot Team Members
+
+
+-import importlib_resources
++import importlib.resources as importlib_resources
+
+ from twisted.web import static
+