summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-util/cpptest
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-util/cpptest')
-rw-r--r--dev-util/cpptest/Manifest1
-rw-r--r--dev-util/cpptest/cpptest-1.1.2.ebuild31
-rw-r--r--dev-util/cpptest/metadata.xml16
3 files changed, 48 insertions, 0 deletions
diff --git a/dev-util/cpptest/Manifest b/dev-util/cpptest/Manifest
new file mode 100644
index 000000000000..2a47153ea110
--- /dev/null
+++ b/dev-util/cpptest/Manifest
@@ -0,0 +1 @@
+DIST cpptest-1.1.2.tar.gz 458982 SHA256 9e4fdf156b709397308536eb6b921e3aea1f463c6613f9a0c1dfec9614386027 SHA512 da1030c69a5886e752b9ae08b65c501334c7d2d4abd2174190209ce11ed351239a615b9f7c5019ee601289523b2c21a1205d2042e59aea6c2882d77d636fc57a WHIRLPOOL f68e7b3c3a3944f5d41792ddd0dcc2d521ed0ec25b0aeae7cba7fb2c6c82bbd7a6d3a96981d3df885ef730ac1c3a7fc46a97386b984de1be08b7f1f1d39eab48
diff --git a/dev-util/cpptest/cpptest-1.1.2.ebuild b/dev-util/cpptest/cpptest-1.1.2.ebuild
new file mode 100644
index 000000000000..598ac2c550e8
--- /dev/null
+++ b/dev-util/cpptest/cpptest-1.1.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit eutils
+
+DESCRIPTION="Simple but powerful unit testing framework for C++"
+HOMEPAGE="http://cpptest.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="amd64 ppc ppc64 x86"
+IUSE="doc"
+
+DEPEND="doc? ( app-doc/doxygen )"
+RDEPEND=""
+
+DOCS=( AUTHORS BUGS NEWS README )
+
+src_configure() {
+ econf \
+ $(use_enable doc) \
+ --htmldir=/usr/share/doc/${PF}/html/
+}
+
+src_install() {
+ default
+ prune_libtool_files
+}
diff --git a/dev-util/cpptest/metadata.xml b/dev-util/cpptest/metadata.xml
new file mode 100644
index 000000000000..eaf162a17c2d
--- /dev/null
+++ b/dev-util/cpptest/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>sping@gentoo.org</email>
+ <name>Sebastian Pipping</name>
+ </maintainer>
+ <longdescription lang="en">
+ CppTest is a portable and powerful, yet simple, unit testing framework for handling
+ automated tests in C++. The focus lies on usability and extendability.
+ Several output formats are supported and new ones are easily added.
+ </longdescription>
+ <upstream>
+ <remote-id type="sourceforge">cpptest</remote-id>
+ </upstream>
+</pkgmetadata>