summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-util/geany-plugins/geany-plugins-1.23.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-util/geany-plugins/geany-plugins-1.23.ebuild')
-rw-r--r--dev-util/geany-plugins/geany-plugins-1.23.ebuild101
1 files changed, 101 insertions, 0 deletions
diff --git a/dev-util/geany-plugins/geany-plugins-1.23.ebuild b/dev-util/geany-plugins/geany-plugins-1.23.ebuild
new file mode 100644
index 000000000000..00f5e337c2ba
--- /dev/null
+++ b/dev-util/geany-plugins/geany-plugins-1.23.ebuild
@@ -0,0 +1,101 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools-utils vala versionator
+
+DESCRIPTION="A collection of different plugins for Geany"
+HOMEPAGE="http://plugins.geany.org/geany-plugins"
+SRC_URI="http://plugins.geany.org/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ia64 ppc ppc64 sparc x86"
+IUSE="+commander debugger devhelp enchant gpg gtkspell lua markdown multiterm nls scope soup webkit"
+
+LINGUAS="be ca da de es fr gl ja pt pt_BR ru tr zh_CN"
+
+COMMON_DEPEND=">=dev-util/geany-$(get_version_component_range 1-2)
+ commander? ( x11-libs/gtk+:2 )
+ dev-libs/libxml2:2
+ dev-libs/glib:2
+ debugger? ( x11-libs/vte:0 )
+ devhelp? (
+ dev-util/devhelp
+ gnome-base/gconf:2
+ net-libs/webkit-gtk:2
+ x11-libs/gtk+:2
+ x11-libs/libwnck:1
+ )
+ enchant? ( app-text/enchant )
+ gpg? ( app-crypt/gpgme )
+ gtkspell? ( app-text/gtkspell:2 )
+ lua? ( dev-lang/lua )
+ markdown? (
+ app-text/discount
+ net-libs/webkit-gtk:2
+ x11-libs/gtk+:2
+ )
+ multiterm? (
+ $(vala_depend)
+ x11-libs/gtk+:2
+ >=x11-libs/vte-0.28:0
+ )
+ scope? ( x11-libs/vte:0 )
+ soup? ( net-libs/libsoup )
+ webkit? (
+ net-libs/webkit-gtk:2
+ x11-libs/gtk+:2
+ x11-libs/gdk-pixbuf:2
+ )"
+RDEPEND="${COMMON_DEPEND}
+ scope? ( sys-devel/gdb )"
+DEPEND="${COMMON_DEPEND}
+ nls? ( sys-devel/gettext )
+ virtual/pkgconfig"
+
+src_prepare() {
+ # bundled lib buster
+ rm markdown/peg-markdown/markdown_lib.c || die
+
+ autotools-utils_src_prepare
+ use multiterm && vala_src_prepare
+}
+
+src_configure() {
+ # GeanyGenDoc requires ctpl which isn’t yet in portage
+ local myeconfargs=(
+ --docdir=/usr/share/doc/${PF}
+ --disable-cppcheck
+ --disable-extra-c-warnings
+ --disable-geanygendoc
+ # peg-markdown is bundled, use app-text/discount instead
+ --disable-peg-markdown
+ --enable-geanymacro
+ --enable-geanynumberedbookmarks
+ --enable-gproject
+ --enable-pretty-printer
+ --enable-tableconvert
+ --enable-treebrowser
+ --enable-xmlsnippets
+ $(use_enable commander)
+ $(use_enable debugger)
+ $(use_enable devhelp)
+ $(use_enable enchant spellcheck)
+ $(use_enable gpg geanypg)
+ $(use_enable gtkspell)
+ $(use_enable markdown)
+ $(use_enable multiterm)
+ $(use_enable lua geanylua)
+ $(use_enable nls)
+ $(use_enable scope)
+ # Having updatechecker… when you’re using a package manager?
+ $(use_enable soup updatechecker)
+ $(use_enable soup geniuspaste)
+ $(use_enable webkit webhelper)
+ )
+
+ autotools-utils_src_configure
+}