summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-12-30 19:43:22 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-12-30 19:45:46 +0100
commit4a7495631b6bf30ba8fcd214e508b9f47efdf4ab (patch)
treed479a2a62f69b71db4d2024e0e37af8f3beb6d3b /dev-util/heaptrack
parentapp-crypt/pesign: Remove broken gcc-ar hack (diff)
downloadgentoo-4a7495631b6bf30ba8fcd214e508b9f47efdf4ab.tar.gz
gentoo-4a7495631b6bf30ba8fcd214e508b9f47efdf4ab.tar.bz2
gentoo-4a7495631b6bf30ba8fcd214e508b9f47efdf4ab.zip
*/*: Switch my own packages to cmake.eclass
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-util/heaptrack')
-rw-r--r--dev-util/heaptrack/heaptrack-9999.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/dev-util/heaptrack/heaptrack-9999.ebuild b/dev-util/heaptrack/heaptrack-9999.ebuild
index 99a1d52e0ce5..b9572355eb6e 100644
--- a/dev-util/heaptrack/heaptrack-9999.ebuild
+++ b/dev-util/heaptrack/heaptrack-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit cmake-utils kde.org xdg-utils
+inherit cmake kde.org xdg-utils
DESCRIPTION="Fast heap memory profiler"
HOMEPAGE="http://milianw.de/blog/heaptrack-a-heap-memory-profiler-for-linux"
@@ -46,9 +46,9 @@ src_configure() {
local mycmakeargs=(
-DHEAPTRACK_BUILD_GUI=$(usex gui)
-DBUILD_TESTING=$(usex test)
- $(cmake-utils_use_find_package zstd Zstd)
+ $(cmake_use_find_package zstd Zstd)
)
- cmake-utils_src_configure
+ cmake_src_configure
}
xdg_pkg_postinst() {