summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2018-08-03 13:56:00 -0700
committerPatrick McLean <chutzpah@gentoo.org>2018-08-03 13:57:45 -0700
commit449d47052ac7abec73082c344a16394364fa63f8 (patch)
tree61571bdbf6f927b86a7caa0248b5f7f14d288843 /dev-util/herdtools7
parentdev-ada/gnatcoll-db: fix install when there is no library (diff)
downloadgentoo-449d47052ac7abec73082c344a16394364fa63f8.tar.gz
gentoo-449d47052ac7abec73082c344a16394364fa63f8.tar.bz2
gentoo-449d47052ac7abec73082c344a16394364fa63f8.zip
dev-utils/herdtools7: Version bump to 1.51
Package-Manager: Portage-2.3.44, Repoman-2.3.10
Diffstat (limited to 'dev-util/herdtools7')
-rw-r--r--dev-util/herdtools7/Manifest1
-rw-r--r--dev-util/herdtools7/herdtools7-7.51.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/dev-util/herdtools7/Manifest b/dev-util/herdtools7/Manifest
index 0394d5bf5893..545f1b64cf38 100644
--- a/dev-util/herdtools7/Manifest
+++ b/dev-util/herdtools7/Manifest
@@ -1 +1,2 @@
DIST herdtools7-7.47.tar.gz 763045 BLAKE2B 983411c9c383fabba70598a5b6891f8c1cbc6ff803c2c5b855834cc17f560085e4db03adc193e8f132568f2468164ba84563b8cfae539c27e6877582a0e374b5 SHA512 85295815fb725b78e7015f597cdad10c3a52db2e40b179efb314f6750c7e5ec09393fac4038dafe0b7eb3f5db74d10a032384a384adf3c97bf846cb016f5180c
+DIST herdtools7-7.51.tar.gz 803546 BLAKE2B 17a6c4cbb8fc1034ddb0ec3eb4438181142943634157d0f20c752ee5e04f4dc30d2512b9a7a2df22517b9182986795e4e1a6992a9aa44e35a4cdd877ee1d91c3 SHA512 35edc4360ec97a7c26fbd6c0e5e02e9032a54cdaf20d7cdab32ea28d69b08991404fb601ee73fe8bff79126335dc83b6d7a4204964eedf39a6a6776bc2a9bc6d
diff --git a/dev-util/herdtools7/herdtools7-7.51.ebuild b/dev-util/herdtools7/herdtools7-7.51.ebuild
new file mode 100644
index 000000000000..80e9b8f64f1b
--- /dev/null
+++ b/dev-util/herdtools7/herdtools7-7.51.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit opam
+
+DESCRIPTION="The Herd toolsuite to deal with .cat memory models"
+HOMEPAGE="http://diy.inria.fr/sources/index.html"
+SRC_URI="https://github.com/herd/herdtools7/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="CeCILL-B"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-ml/ocamlbuild"
+RDEPEND=">=dev-lang/ocaml-4.02.0"
+
+src_compile() {
+ ./build.sh /usr || die "Build failed"
+}
+
+src_install() {
+ ./install.sh "${ED}/usr" || die "Install failed"
+}