summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-util/obs-service-git_tarballs
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-util/obs-service-git_tarballs')
-rw-r--r--dev-util/obs-service-git_tarballs/Manifest1
-rw-r--r--dev-util/obs-service-git_tarballs/metadata.xml8
-rw-r--r--dev-util/obs-service-git_tarballs/obs-service-git_tarballs-0.1.7.ebuild32
3 files changed, 41 insertions, 0 deletions
diff --git a/dev-util/obs-service-git_tarballs/Manifest b/dev-util/obs-service-git_tarballs/Manifest
new file mode 100644
index 000000000000..fbc550853e95
--- /dev/null
+++ b/dev-util/obs-service-git_tarballs/Manifest
@@ -0,0 +1 @@
+DIST obs-service-git_tarballs-0.1.7+git.1375261502.72b5224.tar.gz 11006 SHA256 b82cf6c1c7533e881a2feaad6393dabfcd37c067167f2a1b4a351c697be3b180 SHA512 4c8557aa0139a6b65a7993b5ebd5b3cbf3a9f9bbd7da50d56619ed6dc54bdba6e098af92163cf4819acc42e5d4106b6056f120c6f4d0cc38e67daf5c92cc0e6a WHIRLPOOL bd13f9085213c542da852b0a7f751511bc354d908c391cb8b034a24aeb6e6b50cdc776388faf56697a8084f3c1742e0767cfff977a7823164e157b95cae1deb3
diff --git a/dev-util/obs-service-git_tarballs/metadata.xml b/dev-util/obs-service-git_tarballs/metadata.xml
new file mode 100644
index 000000000000..efc0b67b56e3
--- /dev/null
+++ b/dev-util/obs-service-git_tarballs/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>suse</herd>
+<longdescription lang="en">
+This is a source service for Open Build Service. This service is parsing all spec files and downloads all Source files which are specified via a http, https or ftp url.
+</longdescription>
+</pkgmetadata>
diff --git a/dev-util/obs-service-git_tarballs/obs-service-git_tarballs-0.1.7.ebuild b/dev-util/obs-service-git_tarballs/obs-service-git_tarballs-0.1.7.ebuild
new file mode 100644
index 000000000000..a7a9bc43650b
--- /dev/null
+++ b/dev-util/obs-service-git_tarballs/obs-service-git_tarballs-0.1.7.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit obs-service
+
+HASH="git.1375261502.72b5224"
+SRC_URI="${OBS_URI}/${P}+${HASH}.tar.gz"
+IUSE=""
+KEYWORDS="~amd64 ~x86"
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ dev-vcs/git
+"
+
+S="${WORKDIR}/${P}+${HASH}"
+
+src_unpack() {
+ default
+}
+
+src_install() {
+ # different folder and files in this module
+ exeinto /usr/libexec/obs/service
+ doexe ${OBS_SERVICE_NAME}
+
+ insinto /usr/libexec/obs/service
+ doins ${OBS_SERVICE_NAME}.service
+}