summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2021-07-25 23:26:45 +0200
committerLars Wendler <polynomial-c@gentoo.org>2021-07-25 23:28:17 +0200
commit1c773130cf8deda820fca8a35fcd0e42d8895a85 (patch)
tree4f84ebcadb08306c9592d9cf3b12161e9c68d092 /dev-util/pkgconf
parentsys-kernel/gentoo-kernel-bin: Bump to 5.4.135 (diff)
downloadgentoo-1c773130cf8deda820fca8a35fcd0e42d8895a85.tar.gz
gentoo-1c773130cf8deda820fca8a35fcd0e42d8895a85.tar.bz2
gentoo-1c773130cf8deda820fca8a35fcd0e42d8895a85.zip
dev-util/pkgconf: Bump to version 1.8.0
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'dev-util/pkgconf')
-rw-r--r--dev-util/pkgconf/Manifest1
-rw-r--r--dev-util/pkgconf/pkgconf-1.8.0.ebuild85
2 files changed, 86 insertions, 0 deletions
diff --git a/dev-util/pkgconf/Manifest b/dev-util/pkgconf/Manifest
index e9b0033d030e..24bf37ff64f2 100644
--- a/dev-util/pkgconf/Manifest
+++ b/dev-util/pkgconf/Manifest
@@ -1,3 +1,4 @@
DIST pkgconf-1.6.3.tar.xz 291216 BLAKE2B 04bf58590e2f0b37bac7b24b3d595ad08680e85647548cbd642495398d95706f9f738af5c6f9b9ad8801567caa20ade85d4c4d74179f08313420683cb1b34263 SHA512 437c5a5c9866e2047e62e0592639930b2420d4afd41d98cef51f3475165418a39e916477860025314828a6ee0a4eefc10fdf26bda66f80c291f324d9674fa5c1
DIST pkgconf-1.7.3.tar.xz 293148 BLAKE2B b0fdad9e86c7e2aaf5f268de779730e55e14d6f0ddbec50f354b888aa9ca284f6d1d4c462f00b815cd6e0e17a3b41025ce77485f66a7d527f519a7b80283774d SHA512 37b6c4f9f3b93970e35b6970fde22fbbde65e7fa32a5634b3fdfc25cc1f33843582722ad13d9a8e96fd6768406fcbe86bf5feb76996ddd0bb66d6ff91e65f0b6
DIST pkgconf-1.7.4.tar.xz 293888 BLAKE2B af814174b59e3ea7009230f639a6237226caafb22300946904dd10810c0b5cfcbfeea21767a3a1d2c2b5cb1fe4b7b1d995a52d820fcfce3adb383c66762b7576 SHA512 92c080684898b42824a1f1a7e3ce8a600896fc9c20fcf263f032b856fa4c7139607f87ba44d18ed358b8c5f4f04477708800d20a4e10f96e4268a55682f7f0c1
+DIST pkgconf-1.8.0.tar.xz 296304 BLAKE2B 6585a855a313406f77d26fba3cc3cef798b27c4b7ece81738bdba12f36ee93fbcaf838e1065406c28adc20852e34e2de14bc5f4837982f9cc35360d9a3ac83a5 SHA512 58204006408ad5ce91222ed3c93c2e0b61c04fa83c0a8ad337b747b583744578dbebd4ad5ccbc577689637caa1c5dc246b7795ac46e39c6666b1aa78199b7c28
diff --git a/dev-util/pkgconf/pkgconf-1.8.0.ebuild b/dev-util/pkgconf/pkgconf-1.8.0.ebuild
new file mode 100644
index 000000000000..3923dd6417ea
--- /dev/null
+++ b/dev-util/pkgconf/pkgconf-1.8.0.ebuild
@@ -0,0 +1,85 @@
+# Copyright 2012-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit multilib multilib-minimal
+
+if [[ ${PV} == "9999" ]] ; then
+ inherit autotools git-r3
+ EGIT_REPO_URI="https://git.sr.ht/~kaniini/pkgconf"
+else
+ SRC_URI="http://distfiles.dereferenced.org/${PN}/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~ppc-macos ~x64-macos"
+fi
+
+DESCRIPTION="pkg-config compatible replacement with no dependencies other than ANSI C89"
+HOMEPAGE="https://git.sr.ht/~kaniini/pkgconf"
+
+LICENSE="ISC"
+SLOT="0/3"
+IUSE="+pkg-config test"
+
+# tests require 'kyua'
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ test? (
+ dev-libs/atf
+ dev-util/kyua
+ )
+"
+RDEPEND="
+ pkg-config? ( !dev-util/pkgconfig )
+"
+
+MULTILIB_CHOST_TOOLS=(
+ /usr/bin/pkgconf$(get_exeext)
+)
+
+src_prepare() {
+ default
+
+ [[ ${CHOST} == *-darwin9 ]] && eapply "${FILESDIR}"/${P}-darwin9.patch
+
+ [[ ${PV} == "9999" ]] && eautoreconf
+ if use pkg-config; then
+ MULTILIB_CHOST_TOOLS+=(
+ /usr/bin/pkg-config$(get_exeext)
+ )
+ fi
+}
+
+multilib_src_configure() {
+ local ECONF_SOURCE="${S}"
+ local args=(
+ --disable-static
+ --with-system-includedir="${EPREFIX}/usr/include"
+ --with-system-libdir="${EPREFIX}/$(get_libdir):${EPREFIX}/usr/$(get_libdir)"
+ )
+ econf "${args[@]}"
+}
+
+multilib_src_test() {
+ unset PKG_CONFIG_LIBDIR PKG_CONFIG_PATH
+ default
+}
+
+multilib_src_install() {
+ default
+
+ if use pkg-config; then
+ dosym pkgconf$(get_exeext) /usr/bin/pkg-config$(get_exeext)
+ dosym pkgconf.1 /usr/share/man/man1/pkg-config.1
+ else
+ rm "${ED}"/usr/share/aclocal/pkg.m4 || die
+ rmdir "${ED}"/usr/share/aclocal || die
+ rm "${ED}"/usr/share/man/man7/pkg.m4.7 || die
+ rmdir "${ED}"/usr/share/man/man7 || die
+ fi
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ find "${ED}" -type f -name '*.la' -delete || die
+}