summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2020-03-22 11:09:17 +0100
committerJeroen Roovers <jer@gentoo.org>2020-03-22 11:09:32 +0100
commit587ef1171ffeffa68e6b8cfa48e80ae3f1022b50 (patch)
treee2983d3cd5486a3a814a5e40b33026bb5f7e7de5 /dev-util/redo
parentdev-util/redo: Version 0.42a (diff)
downloadgentoo-587ef1171ffeffa68e6b8cfa48e80ae3f1022b50.tar.gz
gentoo-587ef1171ffeffa68e6b8cfa48e80ae3f1022b50.tar.bz2
gentoo-587ef1171ffeffa68e6b8cfa48e80ae3f1022b50.zip
dev-util/redo: Update live ebuild
Package-Manager: Portage-2.3.94, Repoman-2.3.21 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'dev-util/redo')
-rw-r--r--dev-util/redo/redo-99999.ebuild14
1 files changed, 10 insertions, 4 deletions
diff --git a/dev-util/redo/redo-99999.ebuild b/dev-util/redo/redo-99999.ebuild
index 6e92129f9b4a..eb551f91c49d 100644
--- a/dev-util/redo/redo-99999.ebuild
+++ b/dev-util/redo/redo-99999.ebuild
@@ -2,9 +2,9 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python2_7 )
+PYTHON_COMPAT=( python3_{6,7,8} )
PYTHON_REQ_USE="sqlite"
-inherit git-r3 multilib multiprocessing python-single-r1
+inherit git-r3 multilib multiprocessing python-utils-r1 python-single-r1
DESCRIPTION="Smaller, easier, more powerful, and more reliable than make"
HOMEPAGE="https://github.com/apenwarr/redo"
@@ -13,7 +13,7 @@ EGIT_REPO_URI="https://github.com/apenwarr/redo"
LICENSE="LGPL-2"
SLOT="0"
KEYWORDS=""
-REQUIRED_USE=${PYTHON_REQUIRED_USE}
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
BDEPEND="
$(python_gen_cond_dep '
@@ -26,6 +26,10 @@ RDEPEND="
${BDEPEND}
"
+src_configure() {
+ echo ${PYTHON} > redo/whichpython || die
+}
+
src_compile() {
./do -j$(makeopts_jobs) build || die
}
@@ -38,7 +42,7 @@ src_test() {
src_install() {
DESTDIR="${D}" \
DOCDIR="${D}/usr/share/doc/${PF}" \
- LIBDIR="${D}/usr/$(get_libdir)/${PN}" \
+ LIBDIR="${D}/$(python_get_sitedir)/${PN}" \
./do -j$(makeopts_jobs) \
install || die
@@ -47,4 +51,6 @@ src_install() {
sed -i \
-e 's|/lib/|/'"$(get_libdir)"'/|g' \
"${D}"/usr/bin/* || die
+
+ python_optimize
}