summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2020-01-01 21:24:29 -0800
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2020-01-01 21:27:42 -0800
commit666ab8900a8fc1adc34f0e27c387fbc1bad9ef46 (patch)
tree889ee109e7b41ac8d2e2bbebd88dca1c8cc9e103 /dev-util/schroot
parentgames-util/lutris: add slot dep for gnome-base/gnome-desktop (diff)
downloadgentoo-666ab8900a8fc1adc34f0e27c387fbc1bad9ef46.tar.gz
gentoo-666ab8900a8fc1adc34f0e27c387fbc1bad9ef46.tar.bz2
gentoo-666ab8900a8fc1adc34f0e27c387fbc1bad9ef46.zip
dev-util/schroot: revbump
use debian patchset 6 keyword on ~ppc64 add bootst slotdep migrate to EAPI=7 and cmake.eclass remove postinst hacks and messages use tmpfiles to create symlinks and runtime dirs Bug: https://bugs.gentoo.org/589466 Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Diffstat (limited to 'dev-util/schroot')
-rw-r--r--dev-util/schroot/Manifest1
-rw-r--r--dev-util/schroot/files/schroot.tmpfilesd2
-rw-r--r--dev-util/schroot/schroot-1.6.10-r5.ebuild126
3 files changed, 129 insertions, 0 deletions
diff --git a/dev-util/schroot/Manifest b/dev-util/schroot/Manifest
index a41729c723e3..e0894c0588e8 100644
--- a/dev-util/schroot/Manifest
+++ b/dev-util/schroot/Manifest
@@ -1,2 +1,3 @@
DIST schroot_1.6.10-2.debian.tar.xz 34296 BLAKE2B 5c712bca72f938d01a9927d846ab48bca83f7f7ed01cee7b7d4caf9c6b5b38ad650152f68dd989fd93032fb669b8208fff09eaf83be7b7e712fcd41caafbc191 SHA512 ea980199b90a2cffc36348e01e2de229c5cb4321f10bcde4b593eeaaa18f34ab9187cc9c717e6043c477819fefbd793cc707e1e77a5bae1c1815a668956cd84c
+DIST schroot_1.6.10-6.debian.tar.xz 76576 BLAKE2B 719c994703df8fb391b3a8c8f83a5afea4247b4f817e16317b6ed0ba7ec0f962d669c4d50a120eabdd9054b1a31bb58cc426324108cf77fe5b1aec0024bc03c2 SHA512 44177da262c0a8a511534aba964196cdb5a8a7ec094727122954638c29cdc9b80ef0a1ffb709c4841918effb44fe2c0f8912ae87cfa9e4696dbbe9f55adb1211
DIST schroot_1.6.10.orig.tar.xz 797328 BLAKE2B 1f91531f22c5b0a75e5bb74effc660efe4819acc59b007355c12a01c0a1de12674881dd0fbbcab00575a02629662fca799d48f5b967eb527812ed8c08ff9ad28 SHA512 25155989c7811ab4c7bf3cdceaa8d0ffb12f08388143891def96fcd205f1cc401dad9a74f0e9a9ef8610d50174ff8319a8368401431dc87e1a11c0241e61fcbe
diff --git a/dev-util/schroot/files/schroot.tmpfilesd b/dev-util/schroot/files/schroot.tmpfilesd
new file mode 100644
index 000000000000..0c91363a9da9
--- /dev/null
+++ b/dev-util/schroot/files/schroot.tmpfilesd
@@ -0,0 +1,2 @@
+d /run/schroot/mount 0755 root root -
+L /var/lib/schroot/mount - - - - /run/schroot/mount
diff --git a/dev-util/schroot/schroot-1.6.10-r5.ebuild b/dev-util/schroot/schroot-1.6.10-r5.ebuild
new file mode 100644
index 000000000000..9752f1064497
--- /dev/null
+++ b/dev-util/schroot/schroot-1.6.10-r5.ebuild
@@ -0,0 +1,126 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit bash-completion-r1 cmake pam tmpfiles
+
+MY_P=${PN}_${PV}
+DEB_REL=6
+
+DESCRIPTION="Utility to execute commands in a chroot environment"
+HOMEPAGE="https://packages.debian.org/source/sid/schroot"
+SRC_URI="mirror://debian/pool/main/${PN::1}/${PN}/${MY_P}.orig.tar.xz
+ mirror://debian/pool/main/${PN::1}/${PN}/${MY_P}-${DEB_REL}.debian.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc64 ~x86"
+IUSE="btrfs +dchroot debug doc lvm nls pam test"
+RESTRICT="!test? ( test )"
+
+COMMON_DEPEND="
+ >=dev-libs/boost-1.42.0:=
+ >=sys-apps/util-linux-2.16
+ btrfs? ( >=sys-fs/btrfs-progs-0.19-r2 )
+ lvm? ( sys-fs/lvm2 )
+ pam? ( sys-libs/pam )
+"
+
+DEPEND="${COMMON_DEPEND}
+ app-arch/xz-utils
+ sys-apps/groff
+ doc? (
+ app-doc/doxygen
+ media-gfx/graphviz
+ )
+ nls? (
+ >=app-text/po4a-0.40
+ sys-devel/gettext
+ )
+ test? ( >=dev-util/cppunit-1.10.0 )
+"
+RDEPEND="${COMMON_DEPEND}
+ sys-apps/debianutils
+ dchroot? ( !sys-apps/dchroot )
+ nls? ( virtual/libintl )
+"
+
+src_unpack() {
+ unpack ${MY_P}.orig.tar.xz
+ cd "${S}"
+ unpack ${MY_P}-${DEB_REL}.debian.tar.xz
+}
+
+src_prepare() {
+ sed -i -e 's/warn(/message(WARNING /' man/CMakeLists.txt || die
+ eapply "${S}"/debian/patches/*.patch
+ cmake_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -Dbtrfs-snapshot=$(usex btrfs)
+ -Ddchroot=$(usex dchroot)
+ -Ddchroot-dsa=$(usex dchroot)
+ -Ddebug=$(usex debug)
+ -Ddoxygen=$(usex doc)
+ -Dlvm-snapshot=$(usex lvm)
+ -Dnls=$(usex nls)
+ -Dpam=$(usex pam)
+ -Dtest=$(usex test)
+ -Dbash_completion_dir="$(get_bashcompdir)"
+ -DCMAKE_INSTALL_SYSCONFDIR="${EPREFIX}/etc"
+ -DCMAKE_INSTALL_LOCALSTATEDIR="${EPREFIX}/var"
+ -DSCHROOT_MOUNT_DIR="${EPREFIX}/run/${PN}/mount"
+ )
+ if ! use nls; then
+ mycmakeargs+=(-DPO4A_EXECUTABLE=NOTFOUND)
+ fi
+
+ cmake_src_configure
+}
+
+src_compile() {
+ cmake_src_compile all $(usev doc)
+}
+
+src_test() {
+ if [[ $EUID -ne 0 ]]; then
+ ewarn "Disabling tests because you are not root"
+ return 0
+ fi
+
+ cmake_src_test
+}
+
+src_install() {
+ cmake_src_install
+
+ keepdir /var/lib/schroot/{session,unpack,union/{overlay,underlay}}
+
+ docinto /usr/share/doc/${PF}/contrib/setup.d
+ dodoc contrib/setup.d/05customdir contrib/setup.d/09fsck contrib/setup.d/10mount-ssh
+
+ newdoc debian/schroot.NEWS NEWS.debian
+
+ newinitd "${FILESDIR}"/schroot.initd schroot
+ newconfd "${FILESDIR}"/schroot.confd schroot
+ newtmpfiles "${FILESDIR}"/schroot.tmpfilesd schroot.conf
+
+ if use doc; then
+ docinto html/sbuild
+ dodoc "${BUILD_DIR}"/doc/sbuild/html/*
+ docinto html/schroot
+ dodoc "${BUILD_DIR}"/doc/schroot/html/*
+ fi
+
+ if use pam; then
+ rm -f "${ED}"/etc/pam.d/schroot
+ pamd_mimic_system schroot auth account session
+ fi
+}
+
+pkg_postinst() {
+ tmpfiles_process ${PN}.conf
+}