summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2021-02-24 08:16:07 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2021-02-24 08:16:51 +0000
commit38f7f70eb2ad3e1e35c56b842f7996e1b5a8d9c9 (patch)
treecfe353879cf4274dd579e3438770e35b43b444dd /dev-util
parentdev-lang/nim: bump up to 1.4.4 (diff)
downloadgentoo-38f7f70eb2ad3e1e35c56b842f7996e1b5a8d9c9.tar.gz
gentoo-38f7f70eb2ad3e1e35c56b842f7996e1b5a8d9c9.tar.bz2
gentoo-38f7f70eb2ad3e1e35c56b842f7996e1b5a8d9c9.zip
dev-util/shards: bump up to 0.14.0
Package-Manager: Portage-3.0.15, Repoman-3.0.2 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/shards/Manifest1
-rw-r--r--dev-util/shards/shards-0.14.0.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-util/shards/Manifest b/dev-util/shards/Manifest
index 6bb7ed221d15..097947ee6781 100644
--- a/dev-util/shards/Manifest
+++ b/dev-util/shards/Manifest
@@ -1,2 +1,3 @@
DIST crystal-molinillo-0.1.0.tar.gz 23932 BLAKE2B c9bcd707a3208f5d80e6e3030523d50f86cb5977799de8ea6035d014094e3c2fff9bb189fa98f566e72e1e7ad161e47e44c89d9b264d47f109b2e891ecb469e5 SHA512 8d74d95896cd7ff510c87e2ffba6ae5f04ceeddde574930ee609851312b65d713a315cc24f9aa3fab02f9447ccb25ef2dd2e8179640b8c5cfb3d7d6b52d1ded5
DIST shards-0.13.0.tar.gz 55407 BLAKE2B 430abf54b5b035e966112a5b300a8924e0d6c6c4866e4cefba816c1b901876210990678a2d9b0c6bbc9da095decc217b64da32da61a5501e6045dfe64e10bfdf SHA512 7b5540b009f23cfc9630b206884a81c80a63991f64e84eed29545fef0e6a888e3854c6b0c8d958d4af3d6cef4718d7cb08d7948dcd2c9629c82b552776500b2b
+DIST shards-0.14.0.tar.gz 61662 BLAKE2B f590b8eb876cb7a5d5bbade13b3ee78db443ef24f9abefe9ba662a7018ee0e543950e84ef388bd3cf81960883a60de4eb2409616790c0caef6d06f8fa19ff288 SHA512 214f038f3ddedca8297fe6deac1d12a632b7563c5eda796771f925abe7f197c637328eb1fd1fdd51063131e51fcc73edd6be59c9b213779b6ed5090e8a715fe6
diff --git a/dev-util/shards/shards-0.14.0.ebuild b/dev-util/shards/shards-0.14.0.ebuild
new file mode 100644
index 000000000000..ed35979dd3c2
--- /dev/null
+++ b/dev-util/shards/shards-0.14.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit multiprocessing toolchain-funcs
+
+CRYSTAL_MOLINILLO_PV=0.1.0
+CRYSTAL_MOLINILLO_P=crystal-molinillo-${CRYSTAL_MOLINILLO_PV}
+
+DESCRIPTION="Dependency manager for the Crystal language"
+HOMEPAGE="https://github.com/crystal-lang/shards"
+SRC_URI="
+ https://github.com/crystal-lang/shards/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ https://github.com/crystal-lang/crystal-molinillo/archive/v${CRYSTAL_MOLINILLO_PV}.tar.gz -> ${CRYSTAL_MOLINILLO_P}.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="
+ >dev-lang/crystal-0.11.1[yaml]
+"
+RDEPEND="${DEPEND}"
+
+RESTRICT=test # missing files in tarball
+
+src_prepare() {
+ default
+
+ # bundle crystal-molinillo to bootstrap 'shards'
+ mkdir -p lib || die
+ ln -s ../../${CRYSTAL_MOLINILLO_P} lib/molinillo || die
+
+ tc-export CC
+}
+
+src_compile() {
+ emake release=1 FLAGS="--link-flags=\"${LDFLAGS}\" --verbose --threads $(makeopts_jobs)"
+}
+
+src_install() {
+ dobin bin/${PN}
+ dodoc README.md
+}