summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2021-02-25 07:48:44 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2021-02-25 07:48:57 +0000
commit517d1e5f010273189e162e4bd64da8c2a58f7c72 (patch)
tree0bb477564db1fbef6f102bc214ade7b39f4bbe66 /dev-util
parentwww-plugins/chrome-binary-plugins: automated update (89.0.4389.69) (diff)
downloadgentoo-517d1e5f010273189e162e4bd64da8c2a58f7c72.tar.gz
gentoo-517d1e5f010273189e162e4bd64da8c2a58f7c72.tar.bz2
gentoo-517d1e5f010273189e162e4bd64da8c2a58f7c72.zip
dev-util/include-what-you-use: use clang:= depend
include-what-you-use links to clang and llvm libraries. Needs a rebuild when SONAME changes. Reported-by: Daniel M. Weeks Closes: https://bugs.gentoo.org/771792 Package-Manager: Portage-3.0.15, Repoman-3.0.2 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/include-what-you-use/include-what-you-use-11.0-r1.ebuild (renamed from dev-util/include-what-you-use/include-what-you-use-11.0.ebuild)10
1 files changed, 7 insertions, 3 deletions
diff --git a/dev-util/include-what-you-use/include-what-you-use-11.0.ebuild b/dev-util/include-what-you-use/include-what-you-use-11.0-r1.ebuild
index 19caadf0f6ca..dc5b3760f2ca 100644
--- a/dev-util/include-what-you-use/include-what-you-use-11.0.ebuild
+++ b/dev-util/include-what-you-use/include-what-you-use-11.0-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -20,8 +20,8 @@ KEYWORDS="~amd64 ~x86"
LLVM_MAX_SLOT=11
-RDEPEND="sys-devel/llvm:${LLVM_MAX_SLOT}
- sys-devel/clang:${LLVM_MAX_SLOT}
+RDEPEND="
+ sys-devel/clang:${LLVM_MAX_SLOT}=
${PYTHON_DEPS}
"
DEPEND="${RDEPEND}"
@@ -30,6 +30,10 @@ REQUIRED_USE=${PYTHON_REQUIRED_USE}
S=${WORKDIR}/${PN}-${UPSTREAM_PV}
+llvm_check_deps() {
+ has_version "sys-devel/clang:${LLVM_SLOT}"
+}
+
pkg_setup() {
llvm_pkg_setup
python-single-r1_pkg_setup