summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-vcs/bzr-git
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-vcs/bzr-git')
-rw-r--r--dev-vcs/bzr-git/Manifest1
-rw-r--r--dev-vcs/bzr-git/bzr-git-0.6.8-r1.ebuild41
-rw-r--r--dev-vcs/bzr-git/bzr-git-0.6.8.ebuild37
-rw-r--r--dev-vcs/bzr-git/metadata.xml5
4 files changed, 84 insertions, 0 deletions
diff --git a/dev-vcs/bzr-git/Manifest b/dev-vcs/bzr-git/Manifest
new file mode 100644
index 000000000000..d70782568a0c
--- /dev/null
+++ b/dev-vcs/bzr-git/Manifest
@@ -0,0 +1 @@
+DIST bzr-git-0.6.8.tar.gz 117453 SHA256 b157db228717900d109990df349c656d2297803a20f88edb8280f2e9d73bfc27 SHA512 23bd236bdd8bed53a691be03ae0e22bef804e164d4d0ec3760e2ee49d2b83d9cdff64207f33b6e7f088b7d94f7b14249948befb653f3391096210056ebe613cf WHIRLPOOL 9c0d21707a5f556abc685adc987f6777abc21f5339ec0120fa339e60c905ac579c84817b80f4dc7f5170242088c26ca4b6f9eefcfaa7dfbd2252d2efac0927aa
diff --git a/dev-vcs/bzr-git/bzr-git-0.6.8-r1.ebuild b/dev-vcs/bzr-git/bzr-git-0.6.8-r1.ebuild
new file mode 100644
index 000000000000..d14b550aeebe
--- /dev/null
+++ b/dev-vcs/bzr-git/bzr-git-0.6.8-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+DISTUTILS_SINGLE_IMPL=1
+
+inherit distutils-r1
+
+DESCRIPTION="Support for Git branches in Bazaar"
+HOMEPAGE="http://bazaar-vcs.org/BzrForeignBranches/Git"
+SRC_URI=""
+
+LICENSE="GPL-2"
+SLOT="0"
+
+if [[ ${PV} = 9999 ]]; then
+ inherit bzr
+ EBZR_REPO_URI="lp:bzr-git"
+ KEYWORDS=""
+else
+ SRC_URI="http://samba.org/~jelmer/bzr/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+IUSE=""
+# Test are broken, they want API functions from Dulwich which are not
+# installed in Gentoo
+RESTRICT="test"
+
+# Check info.py for dulwich and bzr version dependency info.
+# The file should be fairly straightforward to understand.
+DEPEND=""
+RDEPEND=">=dev-python/dulwich-0.8.2[${PYTHON_USEDEP}]
+ >=dev-vcs/bzr-2.5.0[${PYTHON_USEDEP}]"
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+}
diff --git a/dev-vcs/bzr-git/bzr-git-0.6.8.ebuild b/dev-vcs/bzr-git/bzr-git-0.6.8.ebuild
new file mode 100644
index 000000000000..87cb700ecdf2
--- /dev/null
+++ b/dev-vcs/bzr-git/bzr-git-0.6.8.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+
+inherit distutils
+
+DESCRIPTION="Support for Git branches in Bazaar"
+HOMEPAGE="http://bazaar-vcs.org/BzrForeignBranches/Git"
+SRC_URI=""
+
+LICENSE="GPL-2"
+SLOT="0"
+
+if [[ ${PV} = 9999 ]]; then
+ inherit bzr
+ EBZR_REPO_URI="lp:bzr-git"
+ KEYWORDS=""
+else
+ SRC_URI="http://samba.org/~jelmer/bzr/${P}.tar.gz"
+ KEYWORDS="amd64 x86"
+fi
+
+IUSE=""
+# Test are broken, they want API functions from Dulwich which are not
+# installed in Gentoo
+RESTRICT="test"
+
+# Check info.py for dulwich and bzr version dependency info.
+# The file should be fairly straightforward to understand.
+DEPEND=""
+RDEPEND=">=dev-python/dulwich-0.8.2
+ >=dev-vcs/bzr-2.5.0"
diff --git a/dev-vcs/bzr-git/metadata.xml b/dev-vcs/bzr-git/metadata.xml
new file mode 100644
index 000000000000..e74a92d1562c
--- /dev/null
+++ b/dev-vcs/bzr-git/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>bazaar</herd>
+</pkgmetadata>