summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2020-09-20 11:43:01 +0200
committerFabian Groffen <grobian@gentoo.org>2020-09-20 11:43:11 +0200
commit3da0a79d8a9860bcae33a98da3338498a75e32fb (patch)
tree7b1d157348e9b23309eaade0781baacbb7cd2ffe /dev-vcs
parentmedia-libs/lensfun: Fix warnings that clang turns into errors (diff)
downloadgentoo-3da0a79d8a9860bcae33a98da3338498a75e32fb.tar.gz
gentoo-3da0a79d8a9860bcae33a98da3338498a75e32fb.tar.bz2
gentoo-3da0a79d8a9860bcae33a98da3338498a75e32fb.zip
dev-vcs/hg-git-0.9.0: bump to official release, thanks Alexey Mishustin
Closes: https://bugs.gentoo.org/743547 Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Fabian Groffen <grobian@gentoo.org>
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/hg-git/Manifest1
-rw-r--r--dev-vcs/hg-git/hg-git-0.9.0.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-vcs/hg-git/Manifest b/dev-vcs/hg-git/Manifest
index 11d0193775af..1035a61e6a85 100644
--- a/dev-vcs/hg-git/Manifest
+++ b/dev-vcs/hg-git/Manifest
@@ -1 +1,2 @@
+DIST hg-git-0.9.0.tar.bz2 129138 BLAKE2B a3758d3ff4daae98bccb71ac5471418b191596d7605c5fe867fde230a8deaacb3097b7f5f6f34ee55ba871a850c1c6f7cb6c1e9c05e388419136aecd66b775ea SHA512 03982292f042b9b48f58eeb04413f563b35fa8be1c31ca27825db8fbf293e4dfcb4bb62b6f504d82438a11c967496fb9bbd6aff5d77ae7eefdeb7747c53fcb82
DIST hg-git-0.9.0a1.tar.bz2 128165 BLAKE2B dfe415a26554d6de714b64aa79f771e08f2c7ac02ee42732524b85a6572003bd428ea29823774d5ea4fa0eee251629bcbc78d9421773c312925a0114e51098ff SHA512 43119bacd4bfc169c8403b3d67e14609ada454a7635c50af5db3683ccd36e1d3be2ec0896204f0850b0cb0c09ded24ae723ad3eb6ddc381553f8c2b2ff2c84a1
diff --git a/dev-vcs/hg-git/hg-git-0.9.0.ebuild b/dev-vcs/hg-git/hg-git-0.9.0.ebuild
new file mode 100644
index 000000000000..96c5e8576a8e
--- /dev/null
+++ b/dev-vcs/hg-git/hg-git-0.9.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+MY_PV=${PV/_rc/a}
+DESCRIPTION="push to and pull from a Git repository using Mercurial"
+HOMEPAGE="https://hg-git.github.io https://pypi.org/project/hg-git/"
+SRC_URI="https://foss.heptapod.net/mercurial/hg-git/-/archive/${MY_PV}/${PN}-${MY_PV}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND="
+ >=dev-vcs/mercurial-4.3[${PYTHON_USEDEP}]
+ >=dev-python/dulwich-0.19.0[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+S="${WORKDIR}/${PN}-${MY_PV}"