summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYixun Lan <dlan@gentoo.org>2021-02-11 14:43:17 +0800
committerYixun Lan <dlan@gentoo.org>2021-02-11 14:45:14 +0800
commit717491dad8460d31c1686c4f9335246fba787b58 (patch)
tree62bc75db7bad441eda70b53d6dd04b09cb6e965c /dev-vcs
parentdev-ml/ocurl: Stabilize 0.9.1 ppc, #769317 (diff)
downloadgentoo-717491dad8460d31c1686c4f9335246fba787b58.tar.gz
gentoo-717491dad8460d31c1686c4f9335246fba787b58.tar.bz2
gentoo-717491dad8460d31c1686c4f9335246fba787b58.zip
dev-vcs/stgit: version bump, 1.0
Closes: https://bugs.gentoo.org/769752 Package-Manager: Portage-3.0.13, Repoman-3.0.2 Signed-off-by: Yixun Lan <dlan@gentoo.org>
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/stgit/Manifest1
-rw-r--r--dev-vcs/stgit/stgit-1.0.ebuild80
2 files changed, 81 insertions, 0 deletions
diff --git a/dev-vcs/stgit/Manifest b/dev-vcs/stgit/Manifest
index 44b657d89a38..d426c3976374 100644
--- a/dev-vcs/stgit/Manifest
+++ b/dev-vcs/stgit/Manifest
@@ -1,2 +1,3 @@
DIST stgit-0.21.tar.gz 319605 BLAKE2B 92bb879d8b8804c8a1b2ca8038d010a0b5118970a4482d87d6bc295992849511c33acb46f376034af6609d42c0323d692bff0ea9bf217cc860e53915fb3c982e SHA512 394c2b30596819f1376bd7432be6923a8dad73f58f049022fe64d1520fd75418665af8069aac98843df051f7fbefbb367762ad4ba57f13bf747819035c7d63ee
DIST stgit-0.23.tar.gz 303836 BLAKE2B 018e0caf74a3c449a71362e3694b2ddf030f5ee23e3212a98b378b7118bae9fd15d0e4ab2a2a746a12b34e46aa2edb86657a4a7125f3c5ca8aa0142fe3d73534 SHA512 b3c9b5c0833cb7e5137faf0df48af6a11b9508b994cdf55b587567d1c146fd4ae29e7beb6d1a34b3f87e5b3854af035dd7e5ca35338c20740e91da7b47c4568d
+DIST stgit-1.0.tar.gz 302201 BLAKE2B 2be1eb648edbefed6270e8f52039afd5d6d4140e8e16656a9f28f6b168eb5ce02c814a3e2b91bc628a80de1e15f0491b82af18fc2cad4e556bcd23ef247fe082 SHA512 e33db953d810f024ee2159ea5bb1b1367a5c673d78d789e8b20ad1d773dccaaf0fe4ccb713b8de082d4a79a3f51d421a2d3d88be24f2e0e770e070e640744894
diff --git a/dev-vcs/stgit/stgit-1.0.ebuild b/dev-vcs/stgit/stgit-1.0.ebuild
new file mode 100644
index 000000000000..e44a2c6fd258
--- /dev/null
+++ b/dev-vcs/stgit/stgit-1.0.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+DISTUTILS_USE_SETUPTOOLS=no
+
+inherit bash-completion-r1 distutils-r1
+
+DESCRIPTION="Manage a stack of patches using GIT as a backend"
+HOMEPAGE="https://stacked-git.github.io"
+UPSTREAM_VER=
+[[ -n ${UPSTREAM_VER} ]] && \
+ UPSTREAM_PATCHSET_URI="https://dev.gentoo.org/~dlan/distfiles/${P}-upstream-patches-${UPSTREAM_VER}.tar.xz"
+
+SRC_URI="https://github.com/ctmarinas/stgit/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ ${UPSTREAM_PATCHSET_URI}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc"
+
+RDEPEND=">=dev-vcs/git-1.6.3.3"
+
+# NOTE: It seems to be quite important which asciidoc version to use.
+# So keep an eye on it for the future.
+DEPEND="${RDEPEND}
+ doc? (
+ app-text/asciidoc
+ app-text/xmlto
+ dev-lang/perl
+ )"
+
+pkg_setup() {
+ if ! use doc; then
+ echo
+ ewarn "Manpages will not be built and installed."
+ ewarn "Enable the 'doc' useflag, if you want them."
+ echo
+ fi
+}
+
+python_prepare_all() {
+ # Upstream's patchset
+ [[ -n ${UPSTREAM_VER} ]] && \
+ eapply "${WORKDIR}"/patches-upstream
+
+ # this will be a noop, as we are working with a tarball,
+ # but throws git errors --> just get rid of it
+ echo "version=\"${PV}\"" > "${S}"/stgit/builtin_version.py
+
+ distutils-r1_python_prepare_all
+}
+
+src_compile() {
+ distutils-r1_src_compile
+
+ # bug 526468
+ if use doc; then
+ emake DESTDIR="${D}" \
+ htmldir="${EPREFIX}/usr/share/doc/${PF}/html/" \
+ mandir="${EPREFIX}/usr/share/man/" \
+ doc
+ fi
+}
+
+src_install() {
+ if use doc; then
+ emake DESTDIR="${D}" \
+ htmldir="${EPREFIX}/usr/share/doc/${PF}/html/" \
+ mandir="${EPREFIX}/usr/share/man/" \
+ install-doc install-html
+ fi
+
+ distutils-r1_src_install
+
+ newbashcomp completion/stgit.bash 'stg'
+}