summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-action/lugaru-demo
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-action/lugaru-demo')
-rw-r--r--games-action/lugaru-demo/Manifest1
-rw-r--r--games-action/lugaru-demo/lugaru-demo-1.0c.ebuild58
-rw-r--r--games-action/lugaru-demo/metadata.xml5
3 files changed, 64 insertions, 0 deletions
diff --git a/games-action/lugaru-demo/Manifest b/games-action/lugaru-demo/Manifest
new file mode 100644
index 000000000000..fe704640c687
--- /dev/null
+++ b/games-action/lugaru-demo/Manifest
@@ -0,0 +1 @@
+DIST lugaru-linux-x86-1.0c.bin 35539193 SHA256 ad330c9f5496a1fc54fb3640723420a80dfee9da47a71ef7a34a38848c885ade SHA512 fda5287b3836f0f81f391b93aee991ac003bc6e4adbb4d064c05853fd3d348bb71d4e4d1f078dcf149b76e507b26f051205446d5d26e10159e83b59231e756f5 WHIRLPOOL 5a2b8422bd572ba88c47872f642c57d5469c5484172456a103e05e51421eef5e12f6173a6353c4bd816bb4e68b1a4c6a319d135b4e4068251bbf7c7a70b98107
diff --git a/games-action/lugaru-demo/lugaru-demo-1.0c.ebuild b/games-action/lugaru-demo/lugaru-demo-1.0c.ebuild
new file mode 100644
index 000000000000..83bf6185a324
--- /dev/null
+++ b/games-action/lugaru-demo/lugaru-demo-1.0c.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils games
+
+DESCRIPTION="3D arcade with unique fighting system and anthropomorphic characters"
+HOMEPAGE="http://www.wolfire.com/lugaru"
+SRC_URI="http://cdn.wolfire.com/games/lugaru/lugaru-linux-x86-${PV}.bin"
+
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="-* amd64 x86"
+IUSE=""
+RESTRICT="mirror bindist strip"
+
+DEPEND="app-arch/unzip"
+RDEPEND="sys-libs/glibc
+ amd64? (
+ >=x11-libs/libX11-1.6.2[abi_x86_32(-)]
+ >=x11-libs/libXext-1.3.2[abi_x86_32(-)]
+ )
+ x86? (
+ x11-libs/libX11
+ x11-libs/libXext
+ )"
+
+QA_PREBUILT="${GAMES_PREFIX_OPT:1}"/${PN}/lugaru
+
+S=${WORKDIR}/data
+
+src_unpack() {
+ tail -c +194469 "${DISTDIR}"/${A} > ${A}.zip
+ unpack ./${A}.zip
+ rm -f ${A}.zip
+
+ # Duplicate file and can't be handled by portage, bug #14983
+ rm -f "${S}/Data/Textures/Quit.png "
+}
+
+src_install() {
+ local dir=${GAMES_PREFIX_OPT}/${PN}
+
+ insinto "${dir}"
+ doins -r Data
+
+ dodoc *.txt
+
+ exeinto "${dir}"
+ doexe lugaru
+ games_make_wrapper ${PN} ./lugaru "${dir}" "${dir}"
+
+ newicon lugaru.png ${PN}.png
+ make_desktop_entry ${PN} "Lugaru Demo" ${PN}
+
+ prepgamesdirs
+}
diff --git a/games-action/lugaru-demo/metadata.xml b/games-action/lugaru-demo/metadata.xml
new file mode 100644
index 000000000000..d3c2cc926f0b
--- /dev/null
+++ b/games-action/lugaru-demo/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>