summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-arcade/cavezofphear
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-arcade/cavezofphear')
-rw-r--r--games-arcade/cavezofphear/Manifest1
-rw-r--r--games-arcade/cavezofphear/cavezofphear-0.5.1.ebuild37
-rw-r--r--games-arcade/cavezofphear/files/cavezofphear-0.5.1-gentoo.patch36
-rw-r--r--games-arcade/cavezofphear/metadata.xml5
4 files changed, 79 insertions, 0 deletions
diff --git a/games-arcade/cavezofphear/Manifest b/games-arcade/cavezofphear/Manifest
new file mode 100644
index 000000000000..17a59039d63e
--- /dev/null
+++ b/games-arcade/cavezofphear/Manifest
@@ -0,0 +1 @@
+DIST phear-0.5.1.tar.bz2 25750 SHA256 9af83c2246dc05531e3d1d11ea931fe38e7086b513fb8e295c7e95b54c68e687 SHA512 23326a63acc06e77a1dd3505345940f8ef31b671282e00f623b181fe1cdbdf1b7e4b37a6e91ea430348a02239ed1450736dc075ea3af3eee0e8acb115aa89f3b WHIRLPOOL 4891f223c91728164e785b781ec957f0c65b31d2e2b32a3db68d3952695e68728bbec566a5b07847ae6157ee0075edd19b7f84fbee8ee458f1690670dc0e9683
diff --git a/games-arcade/cavezofphear/cavezofphear-0.5.1.ebuild b/games-arcade/cavezofphear/cavezofphear-0.5.1.ebuild
new file mode 100644
index 000000000000..764940f77366
--- /dev/null
+++ b/games-arcade/cavezofphear/cavezofphear-0.5.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils games
+
+DESCRIPTION="A boulder dash / digger-like game for console using ncurses"
+HOMEPAGE="http://www.x86.no/cavezofphear/"
+SRC_URI="http://www.x86.no/${PN}/${P/cavezof}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 ppc ppc64 ~sparc x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND=">=sys-libs/ncurses-5"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S=${WORKDIR}/${P/cavezof/}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+ sed -i \
+ -e "s:get_data_dir(.):\"${GAMES_DATADIR}/${PN}/\":" \
+ src/{chk.c,main.c,gplot.c} \
+ || die
+}
+
+src_install() {
+ dogamesbin src/phear
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins -r data/*
+ dodoc ChangeLog README* TODO
+ prepgamesdirs
+}
diff --git a/games-arcade/cavezofphear/files/cavezofphear-0.5.1-gentoo.patch b/games-arcade/cavezofphear/files/cavezofphear-0.5.1-gentoo.patch
new file mode 100644
index 000000000000..fbf79af44519
--- /dev/null
+++ b/games-arcade/cavezofphear/files/cavezofphear-0.5.1-gentoo.patch
@@ -0,0 +1,36 @@
+diff -ru phear-0.5.1.orig/Makefile phear-0.5.1/Makefile
+--- phear-0.5.1.orig/Makefile 2007-02-27 06:21:55.000000000 -0500
++++ phear-0.5.1/Makefile 2013-01-18 02:09:56.403224104 -0500
+@@ -2,7 +2,7 @@
+ DESTDIR_DATA = /usr/local/share
+
+ make:
+- cd src && make
++ $(MAKE) -C src phear
+ clean:
+ rm -f phear editor
+ install:
+diff -ru phear-0.5.1.orig/src/Makefile phear-0.5.1/src/Makefile
+--- phear-0.5.1.orig/src/Makefile 2011-12-12 07:26:03.000000000 -0500
++++ phear-0.5.1/src/Makefile 2013-01-18 02:10:48.218423433 -0500
+@@ -2,10 +2,8 @@
+
+ DESTDIR = ..
+
+-CC = gcc
+ INSTALL = install
+-CFLAGS ?= -s -Wall -O2
+-LDFLAGS += -lncurses
++LDLIBS = `pkg-config ncurses --libs`
+
+ all: phear install clean
+
+@@ -13,7 +11,7 @@
+ $(CC) $(CFLAGS) -c $^ -o $@
+
+ phear: $(OBJS)
+- $(CC) $(CFLAGS) -o $@ $^ ${LDFLAGS}
++ $(CC) $(CFLAGS) -o $@ $^ ${LDFLAGS} $(LDLIBS)
+
+ install: install-game
+
diff --git a/games-arcade/cavezofphear/metadata.xml b/games-arcade/cavezofphear/metadata.xml
new file mode 100644
index 000000000000..d3c2cc926f0b
--- /dev/null
+++ b/games-arcade/cavezofphear/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>