summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-arcade/gnome-robots
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-arcade/gnome-robots')
-rw-r--r--games-arcade/gnome-robots/Manifest2
-rw-r--r--games-arcade/gnome-robots/gnome-robots-3.14.2.ebuild34
-rw-r--r--games-arcade/gnome-robots/gnome-robots-3.16.1.ebuild30
-rw-r--r--games-arcade/gnome-robots/metadata.xml5
4 files changed, 71 insertions, 0 deletions
diff --git a/games-arcade/gnome-robots/Manifest b/games-arcade/gnome-robots/Manifest
new file mode 100644
index 000000000000..a13cd25e2c3f
--- /dev/null
+++ b/games-arcade/gnome-robots/Manifest
@@ -0,0 +1,2 @@
+DIST gnome-robots-3.14.2.tar.xz 1638328 SHA256 812b7908c0a5a44348cc92c87737ec38542f0e569f88fb9c0984baafbe6d1851 SHA512 8ffbe432d0434af228300081c169acb295a16bd912b56501ebc8b8d15a472786f0b2551e8c9418c08a14adc3766da446aae253eb7ba129de284601e0b7767ebb WHIRLPOOL c0cbb2b539cff1a6d8f7dc9053002f5532772ccf7d0d940e63216361b4018005e77cba03a6e60164bcc4e3b8efba472e37358c81c97497f216a50ea9344d2809
+DIST gnome-robots-3.16.1.tar.xz 1589712 SHA256 dd9e202dea07e864a9cb92ae6003079f296278d49d0239f4b8da130b73a01f36 SHA512 91609f20082bb1314573d31220f59fe38468d7d0246fc29a561bd8e5302814885c240cf654eabe9127481def9376dda083465e5afcc6a5e8dc8872614aaddc02 WHIRLPOOL b26ad6ade1550f377514fceeb136bf2fafea8abf95984adf674e541844f61eb64d388d670333b73b6fe3d8d88f4f170318e5f90aba0b4da0f7fcb168fb8d40c7
diff --git a/games-arcade/gnome-robots/gnome-robots-3.14.2.ebuild b/games-arcade/gnome-robots/gnome-robots-3.14.2.ebuild
new file mode 100644
index 000000000000..9d0dd2d000df
--- /dev/null
+++ b/games-arcade/gnome-robots/gnome-robots-3.14.2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+
+inherit gnome-games
+
+DESCRIPTION="Avoid the robots and make them crash into each other"
+HOMEPAGE="https://wiki.gnome.org/Apps/Robots"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="amd64 ~arm x86"
+IUSE=""
+
+RDEPEND="
+ >=dev-libs/glib-2.32:2
+ >=gnome-base/librsvg-2.36.2:2
+ >=media-libs/libcanberra-0.26[gtk3]
+ >=x11-libs/gtk+-3.12:3
+"
+DEPEND="${RDEPEND}
+ app-text/yelp-tools
+ dev-util/appdata-tools
+ >=dev-util/intltool-0.50
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_configure() {
+ gnome-games_src_configure APPDATA_VALIDATE=$(type -P true)
+}
diff --git a/games-arcade/gnome-robots/gnome-robots-3.16.1.ebuild b/games-arcade/gnome-robots/gnome-robots-3.16.1.ebuild
new file mode 100644
index 000000000000..4531af901fe9
--- /dev/null
+++ b/games-arcade/gnome-robots/gnome-robots-3.16.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+
+inherit gnome-games
+
+DESCRIPTION="Avoid the robots and make them crash into each other"
+HOMEPAGE="https://wiki.gnome.org/Apps/Robots"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+RDEPEND="
+ >=dev-libs/glib-2.32:2
+ >=gnome-base/librsvg-2.36.2:2
+ >=media-libs/libcanberra-0.26[gtk3]
+ >=x11-libs/gtk+-3.15:3
+"
+DEPEND="${RDEPEND}
+ app-text/yelp-tools
+ dev-libs/appstream-glib
+ >=dev-util/intltool-0.50
+ sys-devel/gettext
+ virtual/pkgconfig
+"
diff --git a/games-arcade/gnome-robots/metadata.xml b/games-arcade/gnome-robots/metadata.xml
new file mode 100644
index 000000000000..da6fd63d0085
--- /dev/null
+++ b/games-arcade/gnome-robots/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>gnome</herd>
+</pkgmetadata>