summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-arcade/syobon
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-arcade/syobon')
-rw-r--r--games-arcade/syobon/Manifest1
-rw-r--r--games-arcade/syobon/metadata.xml12
-rw-r--r--games-arcade/syobon/syobon-1.0.1.ebuild41
3 files changed, 54 insertions, 0 deletions
diff --git a/games-arcade/syobon/Manifest b/games-arcade/syobon/Manifest
new file mode 100644
index 000000000000..7ef37b643317
--- /dev/null
+++ b/games-arcade/syobon/Manifest
@@ -0,0 +1 @@
+DIST syobon_1.0.1_src.tar.gz 2721153 SHA256 e7aaf73098e6bd748ae682aab4e959e887a742647124aac813f864e5106b943a SHA512 9a8ff389bb23563a16f1b56aefdb93cf0ee5be74c6d48276ce76a17159bc021f517a69eb300a1c17ee81d4112ba26f0d386a1e2e37bced681044c3a3ca4f7ca5 WHIRLPOOL 64171ea0e3d2c4a0f442383468b442376baddeabe7fda408f104802ceb25e3a8cde6549828e4f6e7f9a9961bdb1f5f0ab55e71359c04f28e38b57c049f294367
diff --git a/games-arcade/syobon/metadata.xml b/games-arcade/syobon/metadata.xml
new file mode 100644
index 000000000000..a9fbbd57dbe8
--- /dev/null
+++ b/games-arcade/syobon/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+<email>joker@gentoo.org</email>
+<name>Christian Birchinger</name>
+</maintainer>
+<herd>games</herd>
+<longdescription>
+Syobon Action (also known as Cat Mario or Neko Mario) is a platform game with a similar gameplay experience as Super Mario Bros, except it's a lot more difficult.
+</longdescription>
+</pkgmetadata>
diff --git a/games-arcade/syobon/syobon-1.0.1.ebuild b/games-arcade/syobon/syobon-1.0.1.ebuild
new file mode 100644
index 000000000000..13327d5fea25
--- /dev/null
+++ b/games-arcade/syobon/syobon-1.0.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit games
+
+MY_P="${PN}_${PV}_src"
+
+DESCRIPTION="Syobon Action (also known as Cat Mario or Neko Mario)"
+HOMEPAGE="http://zapek.com/?p=189"
+SRC_URI="http://download.zapek.com/software/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="media-libs/libsdl[sound,video,joystick]
+ media-libs/sdl-gfx
+ media-libs/sdl-image[png]
+ media-libs/sdl-ttf
+ media-libs/sdl-mixer[vorbis]"
+
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S=${WORKDIR}/${PN}
+
+src_compile() {
+ emake GAMEDATA="${GAMES_DATADIR}/${PN}"
+}
+
+src_install() {
+ dogamesbin ${PN}
+
+ insinto "${GAMES_DATADIR}/${PN}"
+ doins -r BGM SE res
+ dodoc README.txt
+ prepgamesdirs
+}