summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-arcade/xscavenger
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-arcade/xscavenger')
-rw-r--r--games-arcade/xscavenger/Manifest1
-rw-r--r--games-arcade/xscavenger/files/1.4.4-gentoo.patch200
-rw-r--r--games-arcade/xscavenger/metadata.xml5
-rw-r--r--games-arcade/xscavenger/xscavenger-1.4.4.ebuild47
4 files changed, 253 insertions, 0 deletions
diff --git a/games-arcade/xscavenger/Manifest b/games-arcade/xscavenger/Manifest
new file mode 100644
index 000000000000..da78c6bb1ba7
--- /dev/null
+++ b/games-arcade/xscavenger/Manifest
@@ -0,0 +1 @@
+DIST xscavenger-1.4.4.tgz 193346 SHA256 65c8d2224068151fcac704f34b91fb46056f77b708b1a60170a955d93751553e SHA512 5f200912b9114ea0c09f0bfcc3f06be2e7c2e1700a744319081f5f3a22c8b93663477076af27837326acf9830af6f597cf8f8fb44562db7d00128321487841ec WHIRLPOOL 1fe351967e379f1e4c4121595b216f4c7d27e127f0282ebcb3904b83437d5059f798db8a34ed0a5aab07633774b56baa27b9b3711ec0bfb8209546960952a853
diff --git a/games-arcade/xscavenger/files/1.4.4-gentoo.patch b/games-arcade/xscavenger/files/1.4.4-gentoo.patch
new file mode 100644
index 000000000000..df5936ed3de8
--- /dev/null
+++ b/games-arcade/xscavenger/files/1.4.4-gentoo.patch
@@ -0,0 +1,200 @@
+diff -urN xscavenger-1.4.4.orig/src/Imakefile xscavenger-1.4.4/src/Imakefile
+--- xscavenger-1.4.4.orig/src/Imakefile
++++ xscavenger-1.4.4/src/Imakefile
+@@ -1,20 +1,36 @@
+ # set this to the path where data files should be stored. LIBDIR
+ # is automatically defined by imake, usually to /usr/X11R6/lib/X11, so
+ # this should be a good default.
+-LIBNAME = $(LIBDIR)/scavenger
++LIBNAME = GENTOO_DATADIR/scavenger
+
+ SRCS = anim.c edit.c scav.c x.c sound.c
+ OBJS = $(SRCS:.c=.o)
+
++# the "subst" hack below is because imake uses the C preprocessor, which
++# will interpret an unquoted "/*" as a comment beginning.
++#LIB_DATA = $(subst S,/,..SdataS*)
+ LIB_DATA = \
+- ../data/badguy.lbm ../data/brownblue.lbm ../data/death.raw \
+- ../data/dig.raw ../data/fall.raw ../data/levels.scl \
+- ../data/microman.lbm ../data/pop.raw ../data/redbrick.lbm \
+- ../data/reddevil.lbm ../data/regularguy.lbm ../data/spiralthing.lbm \
++ ../data/badguy.lbm \
++ ../data/brownblue.lbm \
++ ../data/death.raw \
++ ../data/dig.raw \
++ ../data/fall.raw \
++ ../data/flashspiral.lbm \
++ ../data/gems.lbm \
++ ../data/jungle.lbm \
++ ../data/levels.scl \
++ ../data/microman.lbm \
++ ../data/pop.raw \
++ ../data/redbrick.lbm \
++ ../data/reddevil.lbm \
++ ../data/regularguy.lbm \
++ ../data/spiralthing.lbm \
+ ../data/victory.raw
+
+ LOCAL_LIBRARIES = $(XLIB)
+ EXTRA_DEFINES = -DLIBNAME=\"$(LIBNAME)\"
+
+-ComplexProgramTarget(scavenger)
++AllTarget(scavenger)
++NormalProgramTarget(scavenger,$(OBJS),,,$(XLIB))
++InstallProgram(scavenger,GENTOO_BINDIR)
+ InstallMultipleFlags($(LIB_DATA),$(LIBNAME),-m 644)
+diff -urN xscavenger-1.4.4.orig/src/scav.c xscavenger-1.4.4/src/scav.c
+--- xscavenger-1.4.4.orig/src/scav.c
++++ xscavenger-1.4.4/src/scav.c
+@@ -240,15 +240,19 @@
+
+
+
++/* 14 Dec 2002: re-wrote to be more portable - don't assume two's-complement
++ * representation for integers, and fix bug when sizeof(long) > 4.
++ */
+ long readlong()
+ {
+-long val1=0;
+-
+- val1=myci()<<24L;
+- val1|=myci()<<16L;
+- val1|=myci()<<8;
+- val1|=myci();
++ long val1=0;
++ int i,j;
+
++ for (i=0; i<4; i++) {
++ j = myci();
++ if (j==-1) return -1L;
++ val1 = (val1<<8) + j;
++ }
+ return val1;
+ }
+ int rbs()
+@@ -309,7 +313,7 @@
+ bmw=bmh=byteswide=0;
+ while( (type=readlong()) )
+ {
+- if(type==0xffffffffL) break;
++ if(type==-1L) break;
+ size=readlong();
+ if(size&1) size++;
+ if(type==BMHD)
+@@ -402,16 +406,16 @@
+ input=open(resourcename,O_RDONLY);
+ if(input<0) return -1;
+ got=read(input,buff,8);
+- if(got!=8) return -2;
+- if (strncmp(buff,"SCAV",4)) return -3;
++ if(got!=8) {close(input);return -2;}
++ if (strncmp(buff,"SCAV",4)) {close(input);return -3;}
+ max=(buff[4]<<24) | (buff[5]<<16) | (buff[6]<<8) | buff[7];
+- if(num>=max) return 0;
++ if(num>=max) {close(input);return 0;}
+ lseek(input,(num+1)<<3,SEEK_SET);
+ got=read(input,buff,8);
+ offset=(buff[0]<<24) | (buff[1]<<16) | (buff[2]<<8) | buff[3];
+ length=(buff[4]<<24) | (buff[5]<<16) | (buff[6]<<8) | buff[7];
+ if(len>length) len=length;
+- if(!offset || !len) return 0;
++ if(!offset || !len) {close(input);return 0;}
+ lseek(input,offset,SEEK_SET);
+ got=read(input,put,len);
+ close(input);
+@@ -448,8 +452,8 @@
+ input=open(resourcename,O_RDONLY);
+ if(input==-1) return -4;
+ got=read(input,buff,8);
+- if(got!=8) return -2;
+- if(strncmp(buff,"SCAV",4)) return -3;
++ if(got!=8) {close(input);return -2;}
++ if(strncmp(buff,"SCAV",4)) {close(input);return -3;}
+ output=creat(bakname,00600);
+ if(output==-1) {close(input);return -6;}
+
+@@ -473,12 +477,12 @@
+ for(i=0;i<max;i++)
+ if(headers[i+i])
+ headers[i+i]+=delta;
+- if (write(output,"SCAV",4) != 4) return -200;
+- if (!rlout(output,max)) return -200;
++ if (write(output,"SCAV",4) != 4) {close(input);close(output);return -200;}
++ if (!rlout(output,max)) {close(input);close(output);return -200;}
+ headers[num+num]=0;
+ headers[num+num+1]=len;
+ for(i=0;i<max+max;i++)
+- if (!rlout(output,headers[i])) return -200;
++ if (!rlout(output,headers[i])) {close(input);close(output);return -200;}
+
+ if(offset)
+ {
+@@ -487,8 +491,8 @@
+ while(count)
+ {
+ got=count>1024 ? 1024 : count;
+- if (read(input,copybuff,got) != got) return -200;
+- if (write(output,copybuff,got) != got) return -200;
++ if (read(input,copybuff,got) != got) {close(input);close(output);return -200;}
++ if (write(output,copybuff,got) != got) {close(input);close(output);return -200;}
+ count-=got;
+ }
+ lseek(input,length,SEEK_CUR);
+@@ -498,17 +502,17 @@
+ {
+ got=read(input, copybuff, 1024);
+ if (!got) break;
+- if (write (output, copybuff, got) != got) return -200;
++ if (write (output, copybuff, got) != got) {close(input);close(output);return -200;}
+ offset += got;
+ }
+ if(len)
+ {
+- if (write (output, take, len) != len) return -200;
++ if (write (output, take, len) != len) {close(input);close(output);return -200;}
+ lseek (output, (num+1) << 3, SEEK_SET);
+- if (!rlout (output, offset)) return -200;
++ if (!rlout (output, offset)) {close(input);close(output);return -200;}
+ }
+ close (input);
+- if (fsync(output)) return -200;
++ if (fsync(output)) {close(output);return -200;}
+ if (close(output)) return -200;
+ err=rename(bakname,resourcename);
+ if(err) return -1;
+@@ -1382,6 +1386,7 @@
+ break;
+ }
+ }
++ close(file);
+ }
+
+ void remslash(char *str)
+@@ -1416,6 +1421,8 @@
+ return -3;
+ }
+ } while(len);
++ close(input);
++ close(output);
+ return 0;
+ }
+
+@@ -1448,7 +1455,7 @@
+ printf("Failed to create directory %s, exiting\n",temp);
+ exit(1);
+ }
+- }
++ } else close(file);
+
+ sprintf(resourcename,"%s/%s/%s",localname,localdirname,LEVELSNAME);
+ file=open(resourcename,O_RDONLY);
+@@ -1485,7 +1492,7 @@
+ printf("Couldn't create %s\n",temp);
+ exit(1);
+ }
+- }
++ } else close(file);
+ }
+
+ void makercname(char *str)
diff --git a/games-arcade/xscavenger/metadata.xml b/games-arcade/xscavenger/metadata.xml
new file mode 100644
index 000000000000..d3c2cc926f0b
--- /dev/null
+++ b/games-arcade/xscavenger/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>
diff --git a/games-arcade/xscavenger/xscavenger-1.4.4.ebuild b/games-arcade/xscavenger/xscavenger-1.4.4.ebuild
new file mode 100644
index 000000000000..f7eec1119489
--- /dev/null
+++ b/games-arcade/xscavenger/xscavenger-1.4.4.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils toolchain-funcs games
+
+DESCRIPTION="Lode-Runner-like arcade game"
+HOMEPAGE="http://www.xdr.com/dash/scavenger.html"
+SRC_URI="http://www.xdr.com/dash/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+IUSE=""
+
+RDEPEND="x11-libs/libXext"
+DEPEND="${RDEPEND}
+ x11-misc/imake"
+
+S=${WORKDIR}/${P}/src
+
+src_prepare() {
+ epatch "${FILESDIR}/${PV}-gentoo.patch"
+ sed -i \
+ -e "s:GENTOO_DATADIR:${GAMES_DATADIR}:" \
+ -e "s:GENTOO_BINDIR:${GAMES_BINDIR}:" \
+ Imakefile \
+ || die
+}
+
+src_configure() {
+ xmkmf || die
+}
+
+src_compile() {
+ emake \
+ CC="$(tc-getCC)" \
+ CDEBUGFLAGS="${CFLAGS}" \
+ EXTRA_LDOPTIONS="${LDFLAGS}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc ../{CREDITS,DOC,README,TODO,changelog}
+ prepgamesdirs
+}