summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2018-04-29 11:42:39 +0200
committerPacho Ramos <pacho@gentoo.org>2018-04-29 13:25:41 +0200
commit5d1e26892212ffbdcae528cd2e38efc4f3230515 (patch)
tree5cc1ac8f2daeddcf088f680d4fa0ff1fc650f5fb /games-emulation/generator
parentgames-emulation/gcube: Drop old (diff)
downloadgentoo-5d1e26892212ffbdcae528cd2e38efc4f3230515.tar.gz
gentoo-5d1e26892212ffbdcae528cd2e38efc4f3230515.tar.bz2
gentoo-5d1e26892212ffbdcae528cd2e38efc4f3230515.zip
games-emulation/generator: Drop games.eclass, fix compilation (#650574)
Package-Manager: Portage-2.3.31, Repoman-2.3.9
Diffstat (limited to 'games-emulation/generator')
-rw-r--r--games-emulation/generator/files/generator-0.35_p4-configure.patch4
-rw-r--r--games-emulation/generator/files/generator-0.35_p4-inline.patch12
-rw-r--r--games-emulation/generator/files/generator-0.35_p4-underlink.patch4
-rw-r--r--games-emulation/generator/generator-0.35_p4-r1.ebuild54
4 files changed, 70 insertions, 4 deletions
diff --git a/games-emulation/generator/files/generator-0.35_p4-configure.patch b/games-emulation/generator/files/generator-0.35_p4-configure.patch
index 72ed087bd296..a918c4a97113 100644
--- a/games-emulation/generator/files/generator-0.35_p4-configure.patch
+++ b/games-emulation/generator/files/generator-0.35_p4-configure.patch
@@ -1,5 +1,5 @@
---- configure.ac.original 2008-03-17 13:07:48.000000000 -0400
-+++ configure.ac 2008-03-17 13:08:03.000000000 -0400
+--- a/configure.ac.original 2008-03-17 13:07:48.000000000 -0400
++++ b/configure.ac 2008-03-17 13:08:03.000000000 -0400
@@ -28,15 +28,12 @@
AC_ARG_WITH(tcltk,
AS_HELP_STRING(--with-tcltk,Create tcltk version),
diff --git a/games-emulation/generator/files/generator-0.35_p4-inline.patch b/games-emulation/generator/files/generator-0.35_p4-inline.patch
new file mode 100644
index 000000000000..e7f09fa3689c
--- /dev/null
+++ b/games-emulation/generator/files/generator-0.35_p4-inline.patch
@@ -0,0 +1,12 @@
+diff -aur generator-0.35-cbiere-r4/ym2612/support.h generator-0.35-cbiere-r4-patched/ym2612/support.h
+--- generator-0.35-cbiere-r4/ym2612/support.h 2005-08-27 05:12:29.000000000 -0400
++++ generator-0.35-cbiere-r4-patched/ym2612/support.h 2018-03-26 11:49:36.000000000 -0400
+@@ -3,7 +3,7 @@
+ #include "config.h"
+
+ #define errorlog 0
+-#define INLINE inline
++#define INLINE
+ #define HAS_YM2612 1
+ #define YM2612UpdateRequest(x)
+ #define AY8910_set_clock(chip,clock)
diff --git a/games-emulation/generator/files/generator-0.35_p4-underlink.patch b/games-emulation/generator/files/generator-0.35_p4-underlink.patch
index 964a6bea0883..b350e8b8a334 100644
--- a/games-emulation/generator/files/generator-0.35_p4-underlink.patch
+++ b/games-emulation/generator/files/generator-0.35_p4-underlink.patch
@@ -1,5 +1,5 @@
---- main/Makefile.am.old 2011-06-20 21:35:25.832460030 +0200
-+++ main/Makefile.am 2011-06-20 21:36:29.490503981 +0200
+--- a/main/Makefile.am.old 2011-06-20 21:35:25.832460030 +0200
++++ b/main/Makefile.am 2011-06-20 21:36:29.490503981 +0200
@@ -7,7 +7,7 @@
bin_PROGRAMS = @PROGRAM@
EXTRA_PROGRAMS = generator-svgalib generator-tcltk generator-allegro \
diff --git a/games-emulation/generator/generator-0.35_p4-r1.ebuild b/games-emulation/generator/generator-0.35_p4-r1.ebuild
new file mode 100644
index 000000000000..14ef210d58a8
--- /dev/null
+++ b/games-emulation/generator/generator-0.35_p4-r1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit autotools toolchain-funcs
+
+MY_P="${PN}-${PV/_p/-cbiere-r}"
+DESCRIPTION="Sega Genesis / Mega Drive emulator"
+HOMEPAGE="http://www.squish.net/generator/"
+SRC_URI="http://www.squish.net/generator/cbiere/generator/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+sdlaudio"
+
+RDEPEND="
+ virtual/jpeg:0
+ media-libs/libsdl[joystick,video]
+ sdlaudio? ( media-libs/libsdl[sound] )
+"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ default
+ eapply \
+ "${FILESDIR}"/${P}-configure.patch \
+ "${FILESDIR}"/${P}-underlink.patch \
+ "${FILESDIR}"/${P}-inline.patch
+
+ sed -i -e 's/@GTK_CFLAGS@//g' main/Makefile.am || die
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --with-cmz80 \
+ --with-sdl \
+ --without-tcltk \
+ --with-gcc=$(gcc-major-version) \
+ $(use_with sdlaudio sdl-audio)
+}
+
+src_compile() {
+ [[ -f Makefile ]] && emake clean
+ emake -j1
+}
+
+src_install() {
+ dobin main/generator-sdl
+ dodoc AUTHORS ChangeLog NEWS README TODO docs/*
+}