summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2015-10-04 11:59:28 +0200
committerMichał Górny <mgorny@gentoo.org>2015-10-04 12:11:24 +0200
commit8bd3b00dcb0b4e546d6c7cdc43a2122280873c8e (patch)
tree54220d57bcff4d519c8290166f79473999f425a2 /games-emulation/mupen64plus-audio-sdl
parentdev-haskell/conduit: amd64 stable wrt bug #550394 (diff)
downloadgentoo-8bd3b00dcb0b4e546d6c7cdc43a2122280873c8e.tar.gz
gentoo-8bd3b00dcb0b4e546d6c7cdc43a2122280873c8e.tar.bz2
gentoo-8bd3b00dcb0b4e546d6c7cdc43a2122280873c8e.zip
games-emulation/mupen64plus*: Version bump to 2.5
Bump mupen64plus to 2.5 which brings a number of bug fixes. Switch to SDL2 as its support become stable and the default. Also switch m64py to SDL2 to match. Package-Manager: portage-2.2.22
Diffstat (limited to 'games-emulation/mupen64plus-audio-sdl')
-rw-r--r--games-emulation/mupen64plus-audio-sdl/Manifest1
-rw-r--r--games-emulation/mupen64plus-audio-sdl/mupen64plus-audio-sdl-2.5.ebuild85
2 files changed, 86 insertions, 0 deletions
diff --git a/games-emulation/mupen64plus-audio-sdl/Manifest b/games-emulation/mupen64plus-audio-sdl/Manifest
index 1def790ff8df..85aaa085b07e 100644
--- a/games-emulation/mupen64plus-audio-sdl/Manifest
+++ b/games-emulation/mupen64plus-audio-sdl/Manifest
@@ -1 +1,2 @@
DIST mupen64plus-audio-sdl-src-2.0.tar.gz 26084 SHA256 943ffa6b6cdaf0cda2a24469dfa1d8e951c88c41472ded9e5c9ecbc111363286 SHA512 92ee4755c22da5a753374c7c6f5e074bf6c1ab06a0ab27d475566d50f8ed75b636b59ffe1a8c9d3d63558bf5783b999a600703951679f7bab346643c0c86871d WHIRLPOOL 82a56a49f0ffe620917dba92bf135593c7e66e2944ec0688b29cc2d5362221b81f76e162840e315476d959b445d38f3bc1bf05538fbf1fa9de96b616835b2198
+DIST mupen64plus-audio-sdl-src-2.5.tar.gz 26147 SHA256 1c59f8c2d70206350c0b9067a9722cf2dd67e5686994d5a55adbf51ee8812f59 SHA512 0c63e16449c40f15abdeed968383a218ed9876a92b2c15cbeb6554b20008d6d12996c0fd3bc1c502084791596b8535340596e95a11fe5d27576342740e76db6a WHIRLPOOL ad141c8dbe996590eecada88e943a7d8b0e2d9f4db3d02a17c8b4b1e198580b02ef28ef2b19f2267c77f3060396d068ab2fcbcd2da11ff2e6ecfa61af10bb30f
diff --git a/games-emulation/mupen64plus-audio-sdl/mupen64plus-audio-sdl-2.5.ebuild b/games-emulation/mupen64plus-audio-sdl/mupen64plus-audio-sdl-2.5.ebuild
new file mode 100644
index 000000000000..4c5fd3c4ebc0
--- /dev/null
+++ b/games-emulation/mupen64plus-audio-sdl/mupen64plus-audio-sdl-2.5.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MY_P=${PN}-src-${PV}
+inherit eutils multilib toolchain-funcs
+
+DESCRIPTION="A fork of Mupen64 Nintendo 64 emulator, SDL audio plugin"
+HOMEPAGE="http://www.mupen64plus.org/"
+SRC_URI="https://github.com/mupen64plus/${PN}/releases/download/${PV}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="libsamplerate oss speex"
+
+RDEPEND=">=games-emulation/mupen64plus-core-2.5:0=
+ media-libs/libsdl2:0=[sound]
+ libsamplerate? ( media-libs/libsamplerate:0= )
+ speex? ( media-libs/speex:0= )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ epatch_user
+
+ # avoid implicitly appending CPU flags
+ sed -i -e 's:-mmmx::g' -e 's:-msse::g' projects/unix/Makefile || die
+}
+
+src_compile() {
+ MAKEARGS=(
+ # Note: please keep this in sync in all of mupen64plus-* packages
+
+ -C projects/unix
+
+ # this basically means: GNU userspace
+ UNAME=Linux
+
+ # verbose output
+ V=1
+
+ CROSS_COMPILE="${CHOST}-"
+ CC="$(tc-getCC)"
+ CXX="$(tc-getCXX)"
+ PKG_CONFIG="$(tc-getPKG_CONFIG)"
+ # usual CFLAGS, CXXFLAGS and LDFLAGS are respected
+ # so we can leave OPTFLAGS empty
+ OPTFLAGS=
+
+ # paths, some of them are used at compile time
+ PREFIX=/usr
+ LIBDIR=/usr/$(get_libdir)
+
+ # disable unwanted magic
+ LDCONFIG=:
+ INSTALL_STRIP_FLAG=
+
+ # Package-specific stuff
+
+ # CROSS_COMPILE causes it to look for ${CHOST}-sdl2-config...
+ SDL_CFLAGS="$($(tc-getPKG_CONFIG) --cflags sdl2)"
+ SDL_LDLIBS="$($(tc-getPKG_CONFIG) --libs sdl2)"
+
+ NO_SPEEX=$(usex speex 0 1)
+ NO_SRC=$(usex libsamplerate 0 1)
+ NO_OSS=$(usex oss 0 1)
+ # not packaged (https://github.com/nemomobile/libaudioresource)
+ USE_AUDIORESOURCE=0
+ )
+
+ use amd64 && MAKEARGS+=( HOST_CPU=x86_64 )
+ use x86 && MAKEARGS+=( HOST_CPU=i386 )
+
+ emake "${MAKEARGS[@]}" all
+}
+
+src_install() {
+ emake "${MAKEARGS[@]}" DESTDIR="${D}" install
+ einstalldocs
+}