summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2020-02-26 15:33:58 +0100
committerDavid Seifert <soap@gentoo.org>2020-02-26 15:33:58 +0100
commit447ad3ceef7905cc45267886632da13f6a2bc8ed (patch)
treea4cf45efd55e505ffd316113b38afe5ca6d18c54 /games-emulation/mupen64plus-core
parentmedia-plugins/kodi-inputstream-adaptive: 2.4.3 version bump (diff)
downloadgentoo-447ad3ceef7905cc45267886632da13f6a2bc8ed.tar.gz
gentoo-447ad3ceef7905cc45267886632da13f6a2bc8ed.tar.bz2
gentoo-447ad3ceef7905cc45267886632da13f6a2bc8ed.zip
games-emulation/mupen64plus-core: Fix GCC 10 / -fno-common
Closes: https://bugs.gentoo.org/708054 Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'games-emulation/mupen64plus-core')
-rw-r--r--games-emulation/mupen64plus-core/files/mupen64plus-core-2.5.9-fix-gcc10-fno-common.patch20
-rw-r--r--games-emulation/mupen64plus-core/mupen64plus-core-2.5.9.ebuild2
2 files changed, 22 insertions, 0 deletions
diff --git a/games-emulation/mupen64plus-core/files/mupen64plus-core-2.5.9-fix-gcc10-fno-common.patch b/games-emulation/mupen64plus-core/files/mupen64plus-core-2.5.9-fix-gcc10-fno-common.patch
new file mode 100644
index 000000000000..cfc7d5a9fb49
--- /dev/null
+++ b/games-emulation/mupen64plus-core/files/mupen64plus-core-2.5.9-fix-gcc10-fno-common.patch
@@ -0,0 +1,20 @@
+--- a/src/device/r4300/idec.h
++++ b/src/device/r4300/idec.h
+@@ -82,6 +82,6 @@
+
+ #define IDEC_U53(r4300, iw, u53, u5) (void*)(((char*)(r4300)) + idec_u53((iw), (u53), (u5)))
+
+-const char* g_r4300_opcodes[R4300_OPCODES_COUNT];
++extern const char* g_r4300_opcodes[R4300_OPCODES_COUNT];
+
+ #endif
+--- a/src/main/workqueue.h
++++ b/src/main/workqueue.h
+@@ -27,7 +27,6 @@
+
+ struct work_struct;
+
+-struct work_struct *work;
+ typedef void (*work_func_t)(struct work_struct *work);
+ struct work_struct {
+ work_func_t func;
diff --git a/games-emulation/mupen64plus-core/mupen64plus-core-2.5.9.ebuild b/games-emulation/mupen64plus-core/mupen64plus-core-2.5.9.ebuild
index f7e5603250c8..5bf2f73d58f8 100644
--- a/games-emulation/mupen64plus-core/mupen64plus-core-2.5.9.ebuild
+++ b/games-emulation/mupen64plus-core/mupen64plus-core-2.5.9.ebuild
@@ -33,6 +33,8 @@ DEPEND="${RDEPEND}
REQUIRED_USE="gles2? ( !osd )"
S=${WORKDIR}/${MY_P}
+PATCHES=( "${FILESDIR}"/${PN}-2.5.9-fix-gcc10-fno-common.patch )
+
src_prepare() {
default