summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2015-10-04 11:59:28 +0200
committerMichał Górny <mgorny@gentoo.org>2015-10-04 12:11:24 +0200
commit8bd3b00dcb0b4e546d6c7cdc43a2122280873c8e (patch)
tree54220d57bcff4d519c8290166f79473999f425a2 /games-emulation/mupen64plus-ui-console
parentdev-haskell/conduit: amd64 stable wrt bug #550394 (diff)
downloadgentoo-8bd3b00dcb0b4e546d6c7cdc43a2122280873c8e.tar.gz
gentoo-8bd3b00dcb0b4e546d6c7cdc43a2122280873c8e.tar.bz2
gentoo-8bd3b00dcb0b4e546d6c7cdc43a2122280873c8e.zip
games-emulation/mupen64plus*: Version bump to 2.5
Bump mupen64plus to 2.5 which brings a number of bug fixes. Switch to SDL2 as its support become stable and the default. Also switch m64py to SDL2 to match. Package-Manager: portage-2.2.22
Diffstat (limited to 'games-emulation/mupen64plus-ui-console')
-rw-r--r--games-emulation/mupen64plus-ui-console/Manifest1
-rw-r--r--games-emulation/mupen64plus-ui-console/mupen64plus-ui-console-2.5.ebuild78
2 files changed, 79 insertions, 0 deletions
diff --git a/games-emulation/mupen64plus-ui-console/Manifest b/games-emulation/mupen64plus-ui-console/Manifest
index 9af1c63c9bb5..886522e367fe 100644
--- a/games-emulation/mupen64plus-ui-console/Manifest
+++ b/games-emulation/mupen64plus-ui-console/Manifest
@@ -1 +1,2 @@
DIST mupen64plus-ui-console-src-2.0.tar.gz 37954 SHA256 87b9ac0a5ebbc835baa4e1fba0f50e7467e87da6469aa28fdb196e2040e54877 SHA512 7276e19772cfa047ea75c0c87930d7042a41d7d30912cae7f2c44e37ce6d446e8f5bf4e8ce89e69cabcb05185fe7b59a0ff5d12a7f7bbfa010404c2bedd94ea0 WHIRLPOOL 455a3fbb5eb0027ffbf52693e41f2fe8b5a098e32daa0d532b05f0841a35905beb0ffac9b942165d0b03f975468fff75f953cb9b9de02f8a5e49944e28dfccf8
+DIST mupen64plus-ui-console-src-2.5.tar.gz 47852 SHA256 71fee012678ff88f18130e339afd8c5467a2646b7e50da75ba2d5fa342b74a67 SHA512 70293a768c2bc5f80a2f71db229021d497d675536f5dc5eb098f91b62081f993f308d410adebce208a89880f57b037d5b42fa2f95c42ce94ffe2fca326a53046 WHIRLPOOL 4016d6b456d088b19dca2e44e615593bde6e611b36ff0837f9a8d821be87db028027b82daacfccc55488f61ea0110743efb5bed9703336187f88dd8668150e19
diff --git a/games-emulation/mupen64plus-ui-console/mupen64plus-ui-console-2.5.ebuild b/games-emulation/mupen64plus-ui-console/mupen64plus-ui-console-2.5.ebuild
new file mode 100644
index 000000000000..e0a5e4392d88
--- /dev/null
+++ b/games-emulation/mupen64plus-ui-console/mupen64plus-ui-console-2.5.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MY_P=${PN}-src-${PV}
+inherit eutils multilib toolchain-funcs
+
+DESCRIPTION="A fork of Mupen64 Nintendo 64 emulator, console UI"
+HOMEPAGE="http://www.mupen64plus.org/"
+SRC_URI="https://github.com/mupen64plus/${PN}/releases/download/${PV}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=games-emulation/mupen64plus-core-2.0-r1:0=
+ media-libs/libsdl2:0=
+ !<games-emulation/mupen64plus-2.0"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ epatch_user
+
+ # avoid implicitly appending CPU flags
+ sed -i -e 's:-mmmx::g' -e 's:-msse::g' projects/unix/Makefile || die
+}
+
+src_compile() {
+ MAKEARGS=(
+ # Note: please keep this in sync in all of mupen64plus-* packages
+
+ -C projects/unix
+
+ # this basically means: GNU userspace
+ UNAME=Linux
+
+ # verbose output
+ V=1
+
+ CROSS_COMPILE="${CHOST}-"
+ CC="$(tc-getCC)"
+ CXX="$(tc-getCXX)"
+ PKG_CONFIG="$(tc-getPKG_CONFIG)"
+ # usual CFLAGS, CXXFLAGS and LDFLAGS are respected
+ # so we can leave OPTFLAGS empty
+ OPTFLAGS=
+
+ # paths, some of them are used at compile time
+ PREFIX=/usr
+ LIBDIR=/usr/$(get_libdir)
+
+ # disable unwanted magic
+ LDCONFIG=:
+ INSTALL_STRIP_FLAG=
+
+ # Package-specific stuff
+
+ # CROSS_COMPILE causes it to look for ${CHOST}-sdl2-config...
+ SDL_CFLAGS="$($(tc-getPKG_CONFIG) --cflags sdl2)"
+ SDL_LDLIBS="$($(tc-getPKG_CONFIG) --libs sdl2)"
+ )
+
+ use amd64 && MAKEARGS+=( HOST_CPU=x86_64 )
+ use x86 && MAKEARGS+=( HOST_CPU=i386 )
+
+ emake "${MAKEARGS[@]}" all
+}
+
+src_install() {
+ emake "${MAKEARGS[@]}" DESTDIR="${D}" install
+ einstalldocs
+}