summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2018-08-29 23:16:44 +0100
committerJames Le Cuirot <chewi@gentoo.org>2018-08-29 23:17:58 +0100
commit79b3c537aa2945a8cd29334f5a07fd1dfe508833 (patch)
tree5be51c4013e4836668dd005e1f0df86193ed9df8 /games-emulation/openmsx
parentx11-libs/pango: fix src_prepare chaining for correct env cleanup (diff)
downloadgentoo-79b3c537aa2945a8cd29334f5a07fd1dfe508833.tar.gz
gentoo-79b3c537aa2945a8cd29334f5a07fd1dfe508833.tar.bz2
gentoo-79b3c537aa2945a8cd29334f5a07fd1dfe508833.zip
games-emulation/openmsx: Fix SDL_ttf probe, add Python dep, EAPI 7
Closes: https://bugs.gentoo.org/655888 Package-Manager: Portage-2.3.48, Repoman-2.3.10
Diffstat (limited to 'games-emulation/openmsx')
-rw-r--r--games-emulation/openmsx/files/sdl-ttf.patch12
-rw-r--r--games-emulation/openmsx/openmsx-0.14.0.ebuild19
2 files changed, 26 insertions, 5 deletions
diff --git a/games-emulation/openmsx/files/sdl-ttf.patch b/games-emulation/openmsx/files/sdl-ttf.patch
new file mode 100644
index 000000000000..6ff469e509ed
--- /dev/null
+++ b/games-emulation/openmsx/files/sdl-ttf.patch
@@ -0,0 +1,12 @@
+diff -Naur a/build/libraries.py b/build/libraries.py
+--- a/build/libraries.py 2017-08-03 11:26:28.000000000 +0100
++++ b/build/libraries.py 2018-08-29 23:11:04.392981071 +0100
+@@ -304,7 +304,7 @@
+ class SDL_ttf(Library):
+ libName = 'SDL_ttf'
+ makeName = 'SDL_TTF'
+- header = '<SDL_ttf.h>'
++ header = '<SDL/SDL_ttf.h>'
+ function = 'TTF_OpenFont'
+ dependsOn = ('SDL', 'FREETYPE')
+
diff --git a/games-emulation/openmsx/openmsx-0.14.0.ebuild b/games-emulation/openmsx/openmsx-0.14.0.ebuild
index 8b39565b4be2..42d560e04cdc 100644
--- a/games-emulation/openmsx/openmsx-0.14.0.ebuild
+++ b/games-emulation/openmsx/openmsx-0.14.0.ebuild
@@ -1,17 +1,19 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-inherit desktop readme.gentoo-r1
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit desktop python-any-r1 readme.gentoo-r1
DESCRIPTION="MSX emulator that aims for perfection"
HOMEPAGE="http://openmsx.org/"
-SRC_URI="https://github.com/openMSX/openMSX/releases/download/RELEASE_0_14_0/${P}.tar.gz"
+SRC_URI="https://github.com/openMSX/openMSX/releases/download/RELEASE_${PV//./_}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc64 ~x86"
-IUSE=""
RDEPEND="
dev-lang/tcl:0=
@@ -23,7 +25,14 @@ RDEPEND="
media-libs/sdl-ttf
virtual/opengl
"
-DEPEND="${RDEPEND}"
+DEPEND="
+ ${RDEPEND}
+ ${PYTHON_DEPS}
+"
+
+PATCHES=(
+ "${FILESDIR}"/sdl-ttf.patch
+)
DOC_CONTENTS="
If you want to if you want to emulate real MSX systems and not