summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2021-04-06 00:26:16 +0200
committerDavid Seifert <soap@gentoo.org>2021-04-06 00:26:16 +0200
commit03215998f924c0d6cf72a79bc70d0b21b48e6844 (patch)
treea41c1402734a6d998607095bb3292a9fe6a6e6cb /games-emulation/pcsx2
parentapp-text/diff-pdf: Set WX_GTK_VER before inherit (diff)
downloadgentoo-03215998f924c0d6cf72a79bc70d0b21b48e6844.tar.gz
gentoo-03215998f924c0d6cf72a79bc70d0b21b48e6844.tar.bz2
gentoo-03215998f924c0d6cf72a79bc70d0b21b48e6844.zip
games-emulation/pcsx2: Set WX_GTK_VER before inherit
Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'games-emulation/pcsx2')
-rw-r--r--games-emulation/pcsx2/pcsx2-1.6.0-r1.ebuild8
-rw-r--r--games-emulation/pcsx2/pcsx2-1.6.0-r2.ebuild8
-rw-r--r--games-emulation/pcsx2/pcsx2-9999.ebuild5
3 files changed, 13 insertions, 8 deletions
diff --git a/games-emulation/pcsx2/pcsx2-1.6.0-r1.ebuild b/games-emulation/pcsx2/pcsx2-1.6.0-r1.ebuild
index c5dffc683898..7bdeda838f0d 100644
--- a/games-emulation/pcsx2/pcsx2-1.6.0-r1.ebuild
+++ b/games-emulation/pcsx2/pcsx2-1.6.0-r1.ebuild
@@ -2,10 +2,12 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-MY_PV="${PV/_/-}"
+WX_GTK_VER="3.0-gtk3"
inherit cmake fcaps flag-o-matic multilib toolchain-funcs wxwidgets
+MY_PV="${PV/_/-}"
+
DESCRIPTION="A PlayStation 2 emulator"
HOMEPAGE="https://pcsx2.net/"
SRC_URI="https://github.com/PCSX2/${PN}/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
@@ -32,7 +34,7 @@ RDEPEND="
x11-libs/libICE[abi_x86_32(-)]
x11-libs/libX11[abi_x86_32(-)]
x11-libs/libXext[abi_x86_32(-)]
- >=x11-libs/wxGTK-3.0.4-r301:3.0-gtk3[abi_x86_32(-),X]
+ x11-libs/wxGTK:${WX_GTK_VER}[abi_x86_32(-),X]
"
DEPEND="${RDEPEND}
dev-cpp/pngpp
@@ -96,7 +98,7 @@ src_configure() {
-DUSE_VTUNE=FALSE
)
- WX_GTK_VER="3.0-gtk3" setup-wxwidgets
+ setup-wxwidgets
cmake_src_configure
}
diff --git a/games-emulation/pcsx2/pcsx2-1.6.0-r2.ebuild b/games-emulation/pcsx2/pcsx2-1.6.0-r2.ebuild
index d394535a1003..a358ecfb9dae 100644
--- a/games-emulation/pcsx2/pcsx2-1.6.0-r2.ebuild
+++ b/games-emulation/pcsx2/pcsx2-1.6.0-r2.ebuild
@@ -2,10 +2,12 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-MY_PV="${PV/_/-}"
+WX_GTK_VER="3.0-gtk3"
inherit cmake fcaps flag-o-matic multilib toolchain-funcs wxwidgets
+MY_PV="${PV/_/-}"
+
DESCRIPTION="A PlayStation 2 emulator"
HOMEPAGE="https://pcsx2.net/"
SRC_URI="https://github.com/PCSX2/${PN}/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
@@ -32,7 +34,7 @@ RDEPEND="
x11-libs/libICE[abi_x86_32(-)]
x11-libs/libX11[abi_x86_32(-)]
x11-libs/libXext[abi_x86_32(-)]
- >=x11-libs/wxGTK-3.0.4-r301:3.0-gtk3[abi_x86_32(-),X]
+ x11-libs/wxGTK:${WX_GTK_VER}[abi_x86_32(-),X]
"
DEPEND="${RDEPEND}"
@@ -93,7 +95,7 @@ src_configure() {
-DUSE_VTUNE=FALSE
)
- WX_GTK_VER="3.0-gtk3" setup-wxwidgets
+ setup-wxwidgets
cmake_src_configure
}
diff --git a/games-emulation/pcsx2/pcsx2-9999.ebuild b/games-emulation/pcsx2/pcsx2-9999.ebuild
index 1555b343b49a..6fd902402b8c 100644
--- a/games-emulation/pcsx2/pcsx2-9999.ebuild
+++ b/games-emulation/pcsx2/pcsx2-9999.ebuild
@@ -3,6 +3,7 @@
EAPI=7
+WX_GTK_VER="3.0-gtk3"
inherit cmake fcaps flag-o-matic git-r3 toolchain-funcs wxwidgets
DESCRIPTION="A PlayStation 2 emulator"
@@ -38,7 +39,7 @@ RDEPEND="
x11-libs/libICE
x11-libs/libX11
x11-libs/libXext
- x11-libs/wxGTK:3.0-gtk3[X]
+ x11-libs/wxGTK:${WX_GTK_VER}[X]
"
DEPEND="${RDEPEND}"
BDEPEND="test? ( dev-cpp/gtest )"
@@ -81,7 +82,7 @@ src_configure() {
-DUSE_VTUNE=FALSE
)
- WX_GTK_VER="3.0-gtk3" setup-wxwidgets
+ setup-wxwidgets
cmake_src_configure
}