summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2018-11-13 13:55:18 +0100
committerLars Wendler <polynomial-c@gentoo.org>2018-11-13 13:56:31 +0100
commit5d5644824b9a132abe6e4aea0d36668cccb01b88 (patch)
tree878d83c8fc97a22c16fa75107f91d983884f230c /games-emulation/snes9x
parentdev-python/inflect: remove old (diff)
downloadgentoo-5d5644824b9a132abe6e4aea0d36668cccb01b88.tar.gz
gentoo-5d5644824b9a132abe6e4aea0d36668cccb01b88.tar.bz2
gentoo-5d5644824b9a132abe6e4aea0d36668cccb01b88.zip
games-emulation/snes9x: Bump to version 1.57
Package-Manager: Portage-2.3.51, Repoman-2.3.12 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'games-emulation/snes9x')
-rw-r--r--games-emulation/snes9x/Manifest1
-rw-r--r--games-emulation/snes9x/snes9x-1.57.ebuild139
2 files changed, 140 insertions, 0 deletions
diff --git a/games-emulation/snes9x/Manifest b/games-emulation/snes9x/Manifest
index d4e447cdd89f..e78bcb133c3e 100644
--- a/games-emulation/snes9x/Manifest
+++ b/games-emulation/snes9x/Manifest
@@ -1,2 +1,3 @@
DIST snes9x-1.55.tar.gz 2252841 BLAKE2B 52b2e3d5539d95df63ef6f90c974895bc3a3dbe1e89b3a9513a8504eab308d4827f116ebc13fd89ac9c01f7394067eeddf7fd6f640fd071ee8558a6a79f2b56c SHA512 61d1d6f9c1fc4fbf6253ac7a7d214c771563d7d60238197b2f1525a58f8f9011446f400767d39ec464c69d80574a7dcd78557c8f47605df992af28cb107c0f6e
DIST snes9x-1.56.tar.gz 2876904 BLAKE2B b58dd5c31627cbb374183adb5fe0328739bbebda8c6907ab7f9153085c45d612e51c91ad3223cc10694c9c36a00f69c303c5865d3b022f2769353884056a91b2 SHA512 b8c9438a451ed9a52a66dc04e2bea841aaa9403a2fd266e7042555f93a159ced76061233220eb6fac0f106cea08835c13ef008b2432f6d658689e0fa8ee563e6
+DIST snes9x-1.57.tar.gz 2959157 BLAKE2B 6307976247eb3a3bcb506028d75d9054ea853db5c629870a89832fd93ee2fe256799b9191922c67fcd8ef1ed2344d16326212001661c5038a88f290346b9f35c SHA512 d17ec45eeae8f57c618a51243ac54bc3a2a3f09632e4e50c51781cf8557362dbfa7856d9d4ecdebeea344041c2686e2256f6bcd2dcc71660fcf336cf887dcb1c
diff --git a/games-emulation/snes9x/snes9x-1.57.ebuild b/games-emulation/snes9x/snes9x-1.57.ebuild
new file mode 100644
index 000000000000..1d2566bda317
--- /dev/null
+++ b/games-emulation/snes9x/snes9x-1.57.ebuild
@@ -0,0 +1,139 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools flag-o-matic gnome2-utils xdg-utils
+
+DESCRIPTION="Super Nintendo Entertainment System (SNES) emulator"
+HOMEPAGE="https://github.com/snes9xgit/snes9x"
+SRC_URI="https://github.com/snes9xgit/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Snes9x GPL-2 GPL-2+ LGPL-2.1 LGPL-2.1+ ISC MIT ZLIB Info-ZIP"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86 ~x86-fbsd"
+IUSE="alsa debug gtk joystick multilib netplay nls opengl oss png pulseaudio portaudio wayland xinerama +xv"
+RESTRICT="bindist"
+
+RDEPEND="
+ sys-libs/zlib:=[minizip]
+ x11-libs/libX11
+ x11-libs/libXext
+ png? ( media-libs/libpng:0= )
+ gtk? (
+ dev-libs/glib:2
+ dev-libs/libxml2
+ >=x11-libs/gtk+-3.22:3
+ x11-libs/libXrandr
+ x11-misc/xdg-utils
+ alsa? ( media-libs/alsa-lib )
+ joystick? ( media-libs/libsdl2[joystick] )
+ opengl? (
+ media-libs/libepoxy
+ virtual/opengl
+ )
+ portaudio? ( >=media-libs/portaudio-19_pre )
+ pulseaudio? ( media-sound/pulseaudio )
+ xv? ( x11-libs/libXv )
+ wayland? ( dev-libs/wayland )
+ )
+ xinerama? ( x11-libs/libXinerama )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ x11-base/xorg-proto
+ nls? ( dev-util/intltool )"
+
+S="${WORKDIR}/${P}/unix"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.53-cross-compile.patch
+ "${FILESDIR}"/${PN}-1.56-build-system.patch
+)
+
+src_prepare() {
+ cd "${WORKDIR}"/${P} || die
+ rm -r unzip || die
+ default
+ cd unix || die
+ eautoreconf
+ if use gtk; then
+ cd ../gtk || die
+ eautoreconf
+ fi
+}
+
+src_configure() {
+ append-ldflags -Wl,-z,noexecstack
+
+ # build breaks when zlib/zip support is disabled
+ local myeconfargs=(
+ --enable-gzip
+ --enable-zip
+ --with-system-zip
+ $(use_enable joystick gamepad)
+ $(use_enable debug debugger)
+ $(use_enable netplay)
+ $(use_enable png screenshot)
+ $(use_enable xinerama)
+ )
+ econf "${myeconfargs[@]}"
+
+ if use gtk; then
+ cd ../gtk || die
+ myeconfargs=(
+ --with-gtk3
+ --with-zlib
+ --with-system-zip
+ --without-gtk2
+ $(use_enable nls)
+ $(use_with opengl)
+ $(use_with joystick)
+ $(use_with xv)
+ $(use_with netplay)
+ $(use_with alsa)
+ $(use_with oss)
+ $(use_with pulseaudio)
+ $(use_with portaudio)
+ $(use_with png screenshot)
+ $(use_with wayland)
+ )
+ econf "${myeconfargs[@]}"
+ fi
+}
+
+src_compile() {
+ emake
+ use gtk && emake -C ../gtk
+}
+
+src_install() {
+ dobin ${PN}
+
+ dodoc ../docs/{snes9x.conf.default,{changes,control-inputs,controls,snapshots}.txt}
+
+ if use gtk; then
+ emake -C ../gtk DESTDIR="${D}" install
+ dodoc ../gtk/{AUTHORS,doc/README}
+ fi
+
+ docinto html
+ dodoc {.,..}/docs/*.html
+}
+
+pkg_preinst() {
+ use gtk && gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ if use gtk ; then
+ gnome2_icon_cache_update
+ xdg_desktop_database_update
+ fi
+}
+
+pkg_postrm() {
+ if use gtk ; then
+ gnome2_icon_cache_update
+ xdg_desktop_database_update
+ fi
+}