summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2017-12-20 22:30:17 +0100
committerDavid Seifert <soap@gentoo.org>2017-12-21 02:39:44 +0100
commit114c7f44d627ae4e93b3732fe0728ba5e2f6aadd (patch)
tree56f97bca77054820acee2c4fdd03b0fe71a811bb /games-emulation
parentgames-emulation/fbzx: Remove old (diff)
downloadgentoo-114c7f44d627ae4e93b3732fe0728ba5e2f6aadd.tar.gz
gentoo-114c7f44d627ae4e93b3732fe0728ba5e2f6aadd.tar.bz2
gentoo-114c7f44d627ae4e93b3732fe0728ba5e2f6aadd.zip
games-emulation/higan: Remove old
Package-Manager: Portage-2.3.16, Repoman-2.3.6
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/higan/Manifest1
-rw-r--r--games-emulation/higan/higan-094.ebuild144
-rw-r--r--games-emulation/higan/metadata.xml6
3 files changed, 0 insertions, 151 deletions
diff --git a/games-emulation/higan/Manifest b/games-emulation/higan/Manifest
index e0bc90387027..ee06c03975e4 100644
--- a/games-emulation/higan/Manifest
+++ b/games-emulation/higan/Manifest
@@ -1,2 +1 @@
-DIST higan_v094-source.tar.xz 882732 BLAKE2B fb2794a95060befc3495f347328e62c45ee8a21b888a9958857f739f5fb138704275b3624241fee4224e78678746e68d534db6d8d839eb4a6973c092819c509b SHA512 e7e48c76cdc93d2d66db1fa0c71e64903cf4188571b2d5ecb8066dd4e2172a67da4dee68bed6fd0a532b6fd397fa4f537b97de58cc5043a9e970d48d0b66b0da
DIST higan_v099-source.7z 1012348 BLAKE2B db3eb7b8819532786e6f2dd664225abddc49d12cf5c525862578523240c76ab3ac2680537e04b347130ae7e821d1d98e6c4bf25cf47449567afd90887989aa0e SHA512 567f0c9841fb3fed1c78f2afcd9865cbfe06d04b995d4dc468269e459249b758daed949b461b5b8645ebab40edc1f4f28a566de5795325dae4f604190ca9eae6
diff --git a/games-emulation/higan/higan-094.ebuild b/games-emulation/higan/higan-094.ebuild
deleted file mode 100644
index 1401fc403ff3..000000000000
--- a/games-emulation/higan/higan-094.ebuild
+++ /dev/null
@@ -1,144 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit eutils gnome2-utils toolchain-funcs qmake-utils games
-
-MY_P=${PN}_v${PV}-source
-
-DESCRIPTION="A Nintendo multi-system emulator formerly known as bsnes"
-HOMEPAGE="http://byuu.org/higan/ https://code.google.com/p/higan/"
-SRC_URI="http://byuu.org/files/${MY_P}.tar.xz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="ao +alsa openal opengl oss profile_accuracy +profile_balanced profile_performance pulseaudio +sdl udev xv"
-REQUIRED_USE="|| ( ao openal alsa pulseaudio oss )
- || ( xv opengl sdl )
- || ( profile_accuracy profile_balanced profile_performance )"
-
-RDEPEND="
- x11-libs/gtk+:2
- x11-libs/libX11
- x11-libs/libXext
- ao? ( media-libs/libao )
- openal? ( media-libs/openal )
- alsa? ( media-libs/alsa-lib )
- pulseaudio? ( media-sound/pulseaudio )
- xv? ( x11-libs/libXv )
- opengl? ( virtual/opengl )
- sdl? ( media-libs/libsdl[X,joystick,video] )
- udev? ( virtual/udev )
-"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
-
-S=${WORKDIR}/${MY_P}
-
-disable_module() {
- sed -i \
- -e "s|$1\b||" \
- "${S}"/target-ethos/Makefile || die
-}
-
-src_prepare() {
- local i
-
- epatch "${FILESDIR}"/${P}-QA.patch
-
- sed -i \
- -e "/handle/s#/usr/local/lib#/usr/$(get_libdir)#" \
- nall/dl.hpp || die "fixing libdir failed!"
-
- # audio modules
- use ao || disable_module audio.ao
- use openal || disable_module audio.openal
- use pulseaudio || { disable_module audio.pulseaudio
- disable_module audio.pulseaudiosimple ;}
- use oss || disable_module audio.oss
- use alsa || disable_module audio.alsa
-
- # video modules
- use opengl || disable_module video.glx
- use xv || disable_module video.xv
- use sdl || disable_module video.sdl
-
- # input modules
- use sdl || disable_module input.sdl
- use udev || disable_module input.udev
-
- for i in profile_accuracy profile_balanced profile_performance ; do
- if use ${i} ; then
- cp -dRP "${S}" "${S}_${i}" || die
- fi
- done
-}
-
-src_compile() {
- local mytoolkit i
-
- mytoolkit="gtk"
-
- for i in profile_accuracy profile_balanced profile_performance ; do
- if use ${i} ; then
- cd "${S}_${i}" || die
- emake \
- platform="linux" \
- compiler="$(tc-getCXX)" \
- profile="${i#profile_}" \
- phoenix="${mytoolkit}"
-
- sed \
- -e "s:%GAMES_DATADIR%:${GAMES_DATADIR}:" \
- < "${FILESDIR}"/${PN}-wrapper \
- > out/${PN}-wrapper || die "generating wrapper failed!"
- fi
- done
-}
-
-src_install() {
- local i
-
- for i in profile_accuracy profile_balanced profile_performance ; do
- if use ${i} ; then
- # install higan
- newgamesbin "${S}_${i}"/out/${PN} ${PN}-${i#profile_}.bin
- newgamesbin "${S}_${i}"/out/${PN}-wrapper ${PN}-${i#profile_}
- make_desktop_entry "${PN}-${i#profile_}" "${PN} (${i#profile_})"
- fi
- done
-
- # copy home directory stuff to a global location
- insinto "${GAMES_DATADIR}"/${PN}
- doins -r data/cheats.bml profile/*
-
- # install shaders
- if use opengl; then
- insinto "${GAMES_DATADIR}/${PN}/Video Shaders"
- doins -r shaders/*.shader
- fi
-
- doicon -s 48 data/${PN}.png
-
- prepgamesdirs
-}
-
-pkg_preinst() {
- games_pkg_preinst
- gnome2_icon_savelist
-}
-
-pkg_postinst() {
- elog "optional dependencies:"
- elog " dev-games/higan-ananke (extra rom load options)"
- elog " games-util/higan-purify (Rom purifier)"
-
- games_pkg_postinst
- gnome2_icon_cache_update
-}
-
-pkg_postrm() {
- gnome2_icon_cache_update
-}
diff --git a/games-emulation/higan/metadata.xml b/games-emulation/higan/metadata.xml
index fad703a696a7..5bef912000c6 100644
--- a/games-emulation/higan/metadata.xml
+++ b/games-emulation/higan/metadata.xml
@@ -7,12 +7,6 @@
</maintainer>
<use>
<flag name="icarus">Build icarus library manager</flag>
- <flag name="profile_accuracy">
- Compile a binary optimized for accuracy</flag>
- <flag name="profile_balanced">
- Compile a binary with balanced optimization</flag>
- <flag name="profile_performance">
- Compile a binary optimized for performance</flag>
<flag name="udev">Enable udev based input</flag>
</use>
</pkgmetadata>