summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2018-09-03 20:07:07 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2018-09-03 20:13:01 +0100
commit7a5765256c9a8cf089c304f1dc4b2fe8fc663842 (patch)
treefa494d5d7d5675a422f3dd5225235fed537f15d9 /games-emulation
parentdev-python/oslo-db: 4.40.0 bump (diff)
downloadgentoo-7a5765256c9a8cf089c304f1dc4b2fe8fc663842.tar.gz
gentoo-7a5765256c9a8cf089c304f1dc4b2fe8fc663842.tar.bz2
gentoo-7a5765256c9a8cf089c304f1dc4b2fe8fc663842.zip
games-emulation/dolphin: update live ebuild
Changes by Samuel Bauer and by Anthony Parsons: - drop disappeared dependencies and flags: USE="ao openal portaudio" - drop 'sed' calls and use cmake options instead - disable automagic ccache autodetection Bug: https://bugs.gentoo.org/561914 Package-Manager: Portage-2.3.48, Repoman-2.3.10
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/dolphin/dolphin-9999.ebuild49
1 files changed, 12 insertions, 37 deletions
diff --git a/games-emulation/dolphin/dolphin-9999.ebuild b/games-emulation/dolphin/dolphin-9999.ebuild
index b8b2dd91a858..2d4a8a1079c9 100644
--- a/games-emulation/dolphin/dolphin-9999.ebuild
+++ b/games-emulation/dolphin/dolphin-9999.ebuild
@@ -22,16 +22,16 @@ HOMEPAGE="https://www.dolphin-emu.org/"
LICENSE="GPL-2"
SLOT="0"
-IUSE="alsa ao bluetooth discord-presence doc egl +evdev ffmpeg libav log lto openal portaudio profile pulseaudio +qt5 sdl systemd upnp"
+IUSE="alsa bluetooth discord-presence doc egl +evdev ffmpeg libav log lto profile pulseaudio +qt5 sdl systemd upnp"
RDEPEND="
- >=media-libs/libsfml-2.1
- >net-libs/enet-1.3.7
- >=net-libs/mbedtls-2.1.1:=
dev-libs/hidapi:0=
dev-libs/lzo:2=
dev-libs/pugixml:0=
media-libs/libpng:0=
+ media-libs/libsfml
+ net-libs/enet:1.3
+ net-libs/mbedtls
net-misc/curl:0=
sys-libs/readline:0=
sys-libs/zlib:0=
@@ -41,7 +41,6 @@ RDEPEND="
virtual/libusb:1
virtual/opengl
alsa? ( media-libs/alsa-lib )
- ao? ( media-libs/libao )
bluetooth? ( net-wireless/bluez )
egl? ( media-libs/mesa[egl] )
evdev? (
@@ -52,11 +51,6 @@ RDEPEND="
libav? ( media-video/libav:= )
!libav? ( media-video/ffmpeg:= )
)
- openal? (
- media-libs/openal
- media-libs/libsoundtouch
- )
- portaudio? ( media-libs/portaudio )
profile? ( dev-util/oprofile )
pulseaudio? ( media-sound/pulseaudio )
qt5? (
@@ -66,7 +60,7 @@ RDEPEND="
)
sdl? ( media-libs/libsdl2[haptic,joystick] )
systemd? ( sys-apps/systemd:0= )
- upnp? ( >=net-libs/miniupnpc-1.7 )
+ upnp? ( net-libs/miniupnpc )
"
DEPEND="${RDEPEND}
app-arch/zip
@@ -78,26 +72,6 @@ DEPEND="${RDEPEND}
src_prepare() {
cmake-utils_src_prepare
- # Remove automatic dependencies to prevent building without flags enabled.
- if use !alsa; then
- sed -i -e '/include(FindALSA/d' CMakeLists.txt || die
- fi
- if use !ao; then
- sed -i -e '/check_lib(AO/d' CMakeLists.txt || die
- fi
- if use !bluetooth; then
- sed -i -e '/check_lib(BLUEZ/d' CMakeLists.txt || die
- fi
- if use !openal; then
- sed -i -e '/include(FindOpenAL/d' CMakeLists.txt || die
- fi
- if use !portaudio; then
- sed -i -e '/CMAKE_REQUIRED_LIBRARIES portaudio/d' CMakeLists.txt || die
- fi
- if use !pulseaudio; then
- sed -i -e '/check_lib(PULSEAUDIO/d' CMakeLists.txt || die
- fi
-
# Remove all the bundled libraries that support system-installed
# preference. See CMakeLists.txt for conditional 'add_subdirectory' calls.
local KEEP_SOURCES=(
@@ -155,6 +129,13 @@ src_configure() {
-DUSE_EGL=$(usex egl)
-DUSE_UPNP=$(usex upnp)
+
+ -DENABLE_ALSA=$(usex alsa)
+ -DENABLE_BLUEZ=$(usex bluetooth)
+ # Use ccache only when user did set FEATURES=ccache (or similar)
+ # not when ccache binary is present in system (automagic).
+ -DCCACHE_BIN=CCACHE_BIN-NOTFOUND
+ -DENABLE_PULSEAUDIO=$(usex pulseaudio)
)
cmake-utils_src_configure
@@ -176,12 +157,6 @@ src_install() {
pkg_postinst() {
# Add pax markings for hardened systems
pax-mark -m "${EPREFIX}"/usr/games/bin/"${PN}"-emu
-
- if ! use portaudio; then
- ewarn "If you want microphone capabilities in dolphin-emu, rebuild with"
- ewarn "USE=\"portaudio\""
- fi
-
gnome2_icon_cache_update
}