summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-fps/etqw-demo
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-fps/etqw-demo')
-rw-r--r--games-fps/etqw-demo/Manifest1
-rw-r--r--games-fps/etqw-demo/etqw-demo-2.0_p1-r1.ebuild61
-rw-r--r--games-fps/etqw-demo/metadata.xml5
3 files changed, 67 insertions, 0 deletions
diff --git a/games-fps/etqw-demo/Manifest b/games-fps/etqw-demo/Manifest
new file mode 100644
index 000000000000..e5b9443084ef
--- /dev/null
+++ b/games-fps/etqw-demo/Manifest
@@ -0,0 +1 @@
+DIST ETQW-demo2-client-full.r1.x86.run 691248874 SHA256 dcee7afb734b259808fc7fe079afc57efa7ac23cb4c471d4897f35f3e6ca3c31 SHA512 41332208626449da74bea71a9926258f50986f0af85045d470d4405d27e497085ba318337181802be58eb50c724ab91df6b9c810e5fcc5f8dc131486d6529f38 WHIRLPOOL e564c01afaf249ed740d29a22a55733416b08253790eebbf2b25049994d6139397272ba280971ecad042ae094d9e21d4c7bc974314212cf1ce238656df3765e7
diff --git a/games-fps/etqw-demo/etqw-demo-2.0_p1-r1.ebuild b/games-fps/etqw-demo/etqw-demo-2.0_p1-r1.ebuild
new file mode 100644
index 000000000000..fe574499d274
--- /dev/null
+++ b/games-fps/etqw-demo/etqw-demo-2.0_p1-r1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit unpacker eutils versionator games
+
+MY_MAJOR=$(get_major_version)
+MY_REV=$(get_version_component_range 3)
+MY_BODY="ETQW-demo${MY_MAJOR}-client-full.r${MY_REV/p/}.x86"
+
+DESCRIPTION="Enemy Territory: Quake Wars demo"
+HOMEPAGE="http://zerowing.idsoftware.com/linux/etqw/"
+SRC_URI="mirror://idsoftware/etqw/${MY_BODY}.run"
+
+# See copyrights.txt
+LICENSE="ETQW"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+RESTRICT="strip mirror"
+
+DEPEND="app-arch/unzip"
+RDEPEND=">=sys-libs/zlib-1.2.8-r1[abi_x86_32(-)]
+ >=virtual/jpeg-62:62[abi_x86_32(-)]
+ >=media-libs/libsdl-1.2.15-r4[video,sound,opengl,abi_x86_32(-)]
+ >=x11-libs/libX11-1.6.2[abi_x86_32(-)]
+ >=x11-libs/libXext-1.3.2[abi_x86_32(-)]"
+
+S=${WORKDIR}
+dir=${GAMES_PREFIX_OPT}/${PN}
+
+QA_PREBUILT="${dir:1}/guis/libmojosetupgui_ncurses.so
+ ${dir:1}/data/*
+ ${dir:1}/data/pb/*.so"
+
+src_unpack() {
+ # exit status of 1 should just be warnings, not corrupt archive
+ unpack_zip ${A}
+}
+
+src_install() {
+ insinto "${dir}"
+ doins -r guis scripts
+
+ cd data
+ insinto "${dir}"/data
+ doins -r base pb etqw_icon.png
+ dodoc README.txt EULA.txt copyrights.txt etqwtv.txt
+
+ exeinto "${dir}"/data
+ doexe etqw *\.x86 etqw-* libCgx86* libSDL* *.sh
+
+ games_make_wrapper ${PN} ./etqw.x86 "${dir}"/data "${dir}"/data
+ # Matches with desktop entry for enemy-territory-truecombat
+ make_desktop_entry ${PN} "Enemy Territory - Quake Wars (Demo)"
+
+ games_make_wrapper ${PN}-ded ./etqwded.x86 "${dir}"/data "${dir}"/data
+
+ prepgamesdirs
+}
diff --git a/games-fps/etqw-demo/metadata.xml b/games-fps/etqw-demo/metadata.xml
new file mode 100644
index 000000000000..d3c2cc926f0b
--- /dev/null
+++ b/games-fps/etqw-demo/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>