summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-fps/quakeforge/files/quakeforge-0.5.5-noWerror.patch
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-fps/quakeforge/files/quakeforge-0.5.5-noWerror.patch')
-rw-r--r--games-fps/quakeforge/files/quakeforge-0.5.5-noWerror.patch65
1 files changed, 65 insertions, 0 deletions
diff --git a/games-fps/quakeforge/files/quakeforge-0.5.5-noWerror.patch b/games-fps/quakeforge/files/quakeforge-0.5.5-noWerror.patch
new file mode 100644
index 000000000000..5f3674155143
--- /dev/null
+++ b/games-fps/quakeforge/files/quakeforge-0.5.5-noWerror.patch
@@ -0,0 +1,65 @@
+--- tools/qwaq/Makefile.am.old 2009-11-20 15:10:00.000000000 +0100
++++ tools/qwaq/Makefile.am 2009-11-20 15:10:22.000000000 +0100
+@@ -6,7 +6,7 @@
+
+ QFCC_DEP=$(top_builddir)/tools/qfcc/source/qfcc$(EXEEXT)
+ QFCC=$(top_builddir)/tools/qfcc/source/qfcc
+-QCFLAGS=-qq -g -Werror --advanced
++QCFLAGS=-qq -g --advanced
+
+ if BUILD_QWAQ
+ qwaq=qwaq
+--- ruamoko/lib/Makefile.am.old 2009-11-20 15:12:00.000000000 +0100
++++ ruamoko/lib/Makefile.am 2009-11-20 15:12:17.000000000 +0100
+@@ -3,7 +3,7 @@
+ pkglibdir=$(libdir)/ruamoko
+
+ QFCC=$(top_builddir)/tools/qfcc/source/qfcc$(EXEEXT)
+-QCFLAGS=-qq -g -Werror
++QCFLAGS=-qq -g
+ QCPPFLAGS=$(INCLUDES)
+ PAK=$(top_builddir)/tools/pak/pak$(EXEEXT)
+ RANLIB=touch
+--- ruamoko/game/Makefile.am.old 2009-11-20 15:13:05.000000000 +0100
++++ ruamoko/game/Makefile.am 2009-11-20 15:13:21.000000000 +0100
+@@ -7,7 +7,7 @@
+
+ QFCC_DEP=$(top_builddir)/tools/qfcc/source/qfcc$(EXEEXT)
+ QFCC=$(QFCC_DEP)
+-QCFLAGS=-qq -g -Werror
++QCFLAGS=-qq -g
+ QCPPFLAGS=-I. -I$(srcdir) -I$(top_builddir)/ruamoko/include -I$(top_srcdir)/ruamoko/include
+ GZIP=if echo $@ | grep -q .gz; then gzip -f `basename $@ .gz`; if test -f `basename $@ .dat.gz`.sym; then gzip -f `basename $@ .dat.gz`.sym; fi; fi
+ if HAVE_ZLIB
+--- ruamoko/gui/Makefile.am.old 2009-11-20 15:13:52.000000000 +0100
++++ ruamoko/gui/Makefile.am 2009-11-20 15:14:09.000000000 +0100
+@@ -3,7 +3,7 @@
+ pkglibdir=$(libdir)/ruamoko
+
+ QFCC=$(top_builddir)/tools/qfcc/source/qfcc$(EXEEXT)
+-QCFLAGS=-qq -g -Werror
++QCFLAGS=-qq -g
+ QCPPFLAGS=$(INCLUDES)
+ PAK=$(top_builddir)/tools/pak/pak$(EXEEXT)
+ RANLIB=touch
+--- ruamoko/cl_menu/Makefile.am.old 2009-11-20 15:14:37.000000000 +0100
++++ ruamoko/cl_menu/Makefile.am 2009-11-20 15:15:03.000000000 +0100
+@@ -5,7 +5,7 @@
+
+ QFCC_DEP=$(top_builddir)/tools/qfcc/source/qfcc$(EXEEXT)
+ QFCC=$(QFCC_DEP)
+-QCFLAGS=-qq -g -Werror
++QCFLAGS=-qq -g
+ QCPPFLAGS=-I. -I$(srcdir) -I$(top_builddir)/ruamoko/include -I$(top_srcdir)/ruamoko/include -I$(top_builddir)/include -I$(top_srcdir)/include
+ GZIP=if echo $@ | grep -q .gz; then gzip -f `basename $@ .gz`; if test -f `basename $@ .dat.gz`.sym; then gzip -f `basename $@ .dat.gz`.sym; fi; fi
+ if HAVE_ZLIB
+--- configure.ac.old 2009-11-20 15:15:35.000000000 +0100
++++ configure.ac 2009-11-20 15:16:04.000000000 +0100
+@@ -92,6 +92,7 @@
+ AC_PROG_RANLIB
+ AC_LIBTOOL_WIN32_DLL
+ AM_PROG_LIBTOOL
++AM_PROG_AS
+
+ AC_PROG_YACC
+ if echo $YACC | grep -v bison > /dev/null; then