summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-fps/red-blue-quake2/red-blue-quake2-0.1.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-fps/red-blue-quake2/red-blue-quake2-0.1.ebuild')
-rw-r--r--games-fps/red-blue-quake2/red-blue-quake2-0.1.ebuild58
1 files changed, 58 insertions, 0 deletions
diff --git a/games-fps/red-blue-quake2/red-blue-quake2-0.1.ebuild b/games-fps/red-blue-quake2/red-blue-quake2-0.1.ebuild
new file mode 100644
index 000000000000..521b0eaa25e2
--- /dev/null
+++ b/games-fps/red-blue-quake2/red-blue-quake2-0.1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+EAPI=2
+
+inherit eutils games
+
+DESCRIPTION="red-blue Quake II ! play quake2 w/3d glasses !"
+HOMEPAGE="http://www.jfedor.org/red-blue-quake2/"
+SRC_URI="mirror://idsoftware/source/q2source-3.21.zip
+ http://www.jfedor.org/red-blue-quake2/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+IUSE=""
+
+RDEPEND="x11-libs/libX11"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+S=${WORKDIR}/quake2-3.21/linux
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PV}-gentoo.patch \
+ "${FILESDIR}/${P}"-gcc41.patch \
+ "${FILESDIR}/${P}"-ldflags.patch
+ sed -i "s:GENTOO_DIR:$(games_get_libdir)/${PN}:" sys_linux.c \
+ || die "sed failed"
+ sed -i "s:/etc/quake2.conf:${GAMES_SYSCONFDIR}/${PN}.conf:" \
+ sys_linux.c vid_so.c \
+ || die "sed failed"
+}
+
+src_compile() {
+ mkdir -p releasei386-glibc/ref_soft
+ emake \
+ GENTOO_CFLAGS="${CFLAGS}" \
+ GENTOO_DATADIR="${GAMES_DATADIR}"/quake2/baseq2/ \
+ build_release \
+ || die "emake failed"
+}
+
+src_install() {
+ cd release*
+
+ exeinto "$(games_get_libdir)"/${PN}
+ doexe gamei386.so ref_softx.so || die "doexe failed"
+ exeinto "$(games_get_libdir)"/${PN}/ctf
+ doexe ctf/gamei386.so || die "doexe failed"
+ newgamesbin quake2 red-blue-quake2 || die "newgamesbin failed"
+
+ insinto "${GAMES_SYSCONFDIR}"
+ echo "$(games_get_libdir)"/${PN} > ${PN}.conf
+ doins ${PN}.conf || die "doins failed"
+
+ prepgamesdirs
+}