summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNils Freydank <holgersson@posteo.de>2017-12-09 11:48:42 +0100
committerJames Le Cuirot <chewi@gentoo.org>2017-12-10 20:39:05 +0000
commit9bf87bcd475d577af388c9a60389c12714bd2f39 (patch)
treef30dfb1554969efa3d51a25e96fb1d63f78be7b6 /games-fps
parentgames-util/lutris: Drop pre 0.4.14 versions (diff)
downloadgentoo-9bf87bcd475d577af388c9a60389c12714bd2f39.tar.gz
gentoo-9bf87bcd475d577af388c9a60389c12714bd2f39.tar.bz2
gentoo-9bf87bcd475d577af388c9a60389c12714bd2f39.zip
games-fps/urbanterror: Version bump to 4.3.2_p20171208.
Package-Manager: Portage-2.3.17, Repoman-2.3.6 Closes: https://github.com/gentoo/gentoo/pull/6488
Diffstat (limited to 'games-fps')
-rw-r--r--games-fps/urbanterror/Manifest1
-rw-r--r--games-fps/urbanterror/urbanterror-4.3.2_p20171208.ebuild163
2 files changed, 164 insertions, 0 deletions
diff --git a/games-fps/urbanterror/Manifest b/games-fps/urbanterror/Manifest
index f9031204037d..e6931427297e 100644
--- a/games-fps/urbanterror/Manifest
+++ b/games-fps/urbanterror/Manifest
@@ -3,3 +3,4 @@ DIST urbanterror-4.3.2_p20170713.tar.gz 9984763 BLAKE2B 4771e5ecf997334d33ae4b20
DIST urbanterror-4.3.2_p20170915.tar.gz 10061394 BLAKE2B 9e42de663b1ae0ae9e16a279233c88eb419f424c3db0b4d14276cbb9ab59fba3f32b43593f5901e0a6299ef8c2e4fe1d39a789d107a7bd9c15422a3acf553cea SHA512 d22bc3a0d8d191f797f5b1e7a0671424ca6dafbe5a3bd7fbfcd0e7249b9b4b6e790a64cdf7c93690d032b38f92aee703e9e302701084703d7a79d8f60cc2433e
DIST urbanterror-4.3.2_p20171016.tar.gz 10061989 BLAKE2B 12cc4cd40f85c8d15c93fbafa5cc0c5fe2b8c2d35962aa6a24e8878525b262bab47a5f8cfef6e7a4e4d506c47a5d56fb22db99e341efac06cd1b16e1d845027b SHA512 b35bd08f6058d73eecd48304609f7064637e9f1fcad7b22a93a9fdb43f003b93c3c52f3e9a7fc4c468d70fed4ba687bcdcfa0c8749252a12d2eab1cf3ab956ea
DIST urbanterror-4.3.2_p20171105.tar.gz 10067127 BLAKE2B e843623976ad1d2379121bb834eabac634d57185c0b15ee298cf900474a7879ba0d2f45e1e6eb002d963fa83d895f8962110dc7f5dc5a209cde1aee3a9a8234a SHA512 7a9ac15a0508706c17a390a5105badbaaba3b3c0e7e23b3ab9dd16751b1d946c108febba5c2f6af3046d5431fd1c5978a2abc267a740eca1d89d77d7172b41ad
+DIST urbanterror-4.3.2_p20171208.tar.gz 10072373 BLAKE2B 9934317fb649e652628639f9ea35cdaa0466363b52ea7325198aaaa6360e07e41ec590342cd35fa1bb352ff35ba5994e9152caaf308aa0e0d8c3c2d94ea36a91 SHA512 1dd3affa8fe23f8cca4ee3c90a8d6fc86f5df2122e0121d57263be745d0af13f52cb47802636a22cb09b1bae8a100b491dc8cc0c81c413dd9cbb2ad29a69039a
diff --git a/games-fps/urbanterror/urbanterror-4.3.2_p20171208.ebuild b/games-fps/urbanterror/urbanterror-4.3.2_p20171208.ebuild
new file mode 100644
index 000000000000..32cf683aeac4
--- /dev/null
+++ b/games-fps/urbanterror/urbanterror-4.3.2_p20171208.ebuild
@@ -0,0 +1,163 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+inherit eapi7-ver flag-o-matic toolchain-funcs xdg-utils
+
+DESCRIPTION="Hollywood tactical shooter based on the ioquake3 engine"
+HOMEPAGE="http://urbanterror.info https://github.com/mickael9/ioq3"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/mickael9/ioq3.git"
+ EGIT_BRANCH="urt"
+else
+ COMMIT_ID="e3bc50248c9d6c319d4822ca23caa5d46fc118ab"
+ SRC_URI="https://github.com/mickael9/ioq3/archive/${COMMIT_ID}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/ioq3-${COMMIT_ID}"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="+altgamma +client +curl debug mumble openal +opus server +skeetshootmod voip vorbis"
+REQUIRED_USE=" || ( client server )"
+
+PATCHES=( "${FILESDIR}"/${PN}-4.3-fix-build_system.patch )
+RDEPEND="
+ client? (
+ media-libs/libsdl2:=[X,sound,joystick,opengl,video]
+ mumble? ( media-sound/mumble:= )
+ openal? ( media-libs/openal:= )
+ opus? ( media-libs/opusfile:= )
+ vorbis? (
+ media-libs/libogg:=
+ media-libs/libvorbis:=
+ )
+ )
+ curl? ( net-misc/curl )
+ ~games-fps/urbanterror-data-4.3.2
+ sys-libs/zlib:=[minizip]
+ virtual/jpeg:0
+"
+
+DEPEND="${RDEPEND}"
+
+pkg_pretend() {
+ if use client; then
+ if ! use openal && ! use opus && ! use vorbis; then
+ ewarn
+ ewarn "No sound implementation selected. Enable 'openal', 'opus' or 'vorbis' USE flag to get sound!"
+ fi
+ fi
+}
+
+src_configure() {
+ default
+
+ tc-export CC
+}
+
+src_compile() {
+ # Workaround for used zlib macro, which got renamed in Gentoo
+ # wrt bug #449510
+ append-cppflags "-DOF=_Z_OF"
+
+ local my_arch=$(usex amd64 "x86_64" "i386")
+
+ emake \
+ ARCH=${my_arch} \
+ DEFAULT_BASEDIR="/usr/share/urbanterror" \
+ BUILD_CLIENT=$(usex "client" 1 0) \
+ BUILD_SERVER=$(usex "server" 1 0) \
+ BUILD_BASEGAME=1 \
+ BUILD_MISSIONPACK=0 \
+ BUILD_GAME_SO=0 \
+ BUILD_GAME_QVM=0 \
+ BUILD_STANDALONE=1 \
+ SERVERBIN="Quake3-UrT-Ded" \
+ CLIENTBIN="Quake3-UrT" \
+ USE_RENDERER_DLOPEN=0 \
+ USE_YACC=0 \
+ BASEGAME="q3ut4"\
+ BASEGAME_CFLAGS="${CFLAGS}" \
+ USE_OPENAL=$(usex "openal" 1 0) \
+ USE_OPENAL_DLOPEN=$(usex "openal" 1 0) \
+ USE_CURL=$(usex "curl" 1 0) \
+ USE_CURL_DLOPEN=$(usex "curl" 1 0) \
+ USE_CODEC_VORBIS=$(usex "vorbis" 1 0) \
+ USE_CODEC_OPUS=$(usex "opus" 1 0) \
+ USE_MUMBLE=$(usex "mumble" 1 0) \
+ USE_SKEETMOD=$(usex "skeetshootmod" 1 0) \
+ USE_VOIP=$(usex "mumble" 1 0) \
+ USE_INTERNAL_LIBS=0 \
+ USE_LOCAL_HEADERS=0 \
+ USE_ALTGAMMA=$(usex "altgamma" 1 0)
+}
+
+src_install() {
+ local my_arch=$(usex amd64 "x86_64" "i386")
+ # docs from ioq3, not from UrbanTerror ZIP file
+ dodoc ChangeLog README.md README.ioq3.md md4-readme.txt
+
+ if use client; then
+ newbin build/$(usex debug "debug" "release")-linux-${my_arch}/Quake3-UrT.${my_arch} ${PN}
+ # Shooter as defined in https://specifications.freedesktop.org/menu-spec/latest/apas02.html
+ make_desktop_entry ${PN} "UrbanTerror" ${PN}
+ fi
+
+ if use server && ! use client; then
+ # dedicated server only
+ newbin build/$(usex debug "debug" "release")-linux-${my_arch}/Quake3-UrT-Ded.${my_arch} ${PN}-ded
+ fi
+}
+
+pkg_postinst() {
+ use client && xdg_desktop_database_update
+
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ # This is a new installation
+ if use openal; then
+ elog ""
+ elog "You might need to set:"
+ elog " seta s_useopenal \"1\""
+ elog "in your ~/.q3a/q3ut4/q3config.cfg for openal to work."
+ fi
+
+ if use altgamma; then
+ elog ""
+ elog "You might need to set:"
+ elog " seta r_altgamma \"1\""
+ elog "in your ~/.q3a/q3ut4/q3config.cfg for altgamma to work."
+ fi
+
+ if ! use altgamma; then
+ elog ""
+ elog "If you are using a modesetting graphics driver you might"
+ elog "consider setting USE=\"altgamma\"."
+ elog "For details take a look at:"
+ elog "https://bugs.freedesktop.org/show_bug.cgi?id=27222"
+ fi
+
+ if ! use client; then
+ elog ""
+ elog "You disabled client support. You won't be able to connect"
+ elog "to any servers and play. If you want to do so, enable"
+ elog "USE=\"client\"."
+ fi
+ fi
+
+ if ver_test -ge 4.3.2_p20171105; then
+ # Yippee, new features!
+ if use skeetshootmod; then
+ elog ""
+ elog "You might need to set:"
+ elog " seta sv_skeetshoot \"1\""
+ elog "in your ~/.q3a/q3ut4/q3config.cfg to use the skeetshoot mod."
+ fi
+ fi
+}
+
+pkg_postrm() {
+ use client && xdg_desktop_database_update
+}