summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2016-01-12 02:01:44 -0500
committerMichael Sterrett <mr_bones_@gentoo.org>2016-01-12 02:47:37 -0500
commite2e6074ae168a9700b9b9119f9672f43fc22a46a (patch)
tree6e3b0ed1f113b8a46c10b01325cbe10cc5c3688f /games-fps
parentnet-misc/youtube-dl: Stable for HPPA PPC64 (bug #570422). (diff)
downloadgentoo-e2e6074ae168a9700b9b9119f9672f43fc22a46a.tar.gz
gentoo-e2e6074ae168a9700b9b9119f9672f43fc22a46a.tar.bz2
gentoo-e2e6074ae168a9700b9b9119f9672f43fc22a46a.zip
games-fps/quake2-data: EAPI=5
Package-Manager: portage-2.2.26
Diffstat (limited to 'games-fps')
-rw-r--r--games-fps/quake2-data/quake2-data-3.20.ebuild15
1 files changed, 7 insertions, 8 deletions
diff --git a/games-fps/quake2-data/quake2-data-3.20.ebuild b/games-fps/quake2-data/quake2-data-3.20.ebuild
index 4bac1cd90392..985bad29a55f 100644
--- a/games-fps/quake2-data/quake2-data-3.20.ebuild
+++ b/games-fps/quake2-data/quake2-data-3.20.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=2
+EAPI=5
inherit unpacker eutils cdrom games
DESCRIPTION="iD Software's Quake 2 ... the data files"
@@ -56,16 +56,15 @@ src_install() {
if use videos ; then
insinto "${GAMES_DATADIR}"/quake2/baseq2/video
- doins "${baseq2_cdpath}"/video/* || die "doins videos"
+ doins "${baseq2_cdpath}"/video/*
fi
insinto "${GAMES_DATADIR}"/quake2/baseq2
- doins "${baseq2_cdpath}"/pak0.pak || die "couldnt grab pak0.pak"
- doins baseq2/*.pak || die "couldnt grab release paks"
- doins baseq2/maps.lst || die "couldnt grab maps.lst"
+ doins "${baseq2_cdpath}"/pak0.pak
+ doins baseq2/*.pak baseq2/maps.lst
dodir "${GAMES_DATADIR}"/quake2/baseq2/players
cp -R "${baseq2_cdpath}"/players/* baseq2/players/* \
- "${D}/${GAMES_DATADIR}"/quake2/baseq2/players/ || die "couldnt grab player models"
+ "${D}/${GAMES_DATADIR}"/quake2/baseq2/players/ || die
for mod in ctf rogue xatrix ; do
if [[ -d ${baseq2_cdpath}/../${mod} ]] ; then
@@ -75,13 +74,13 @@ src_install() {
fi
if [[ -n $(ls "${baseq2_cdpath}"/../${mod}/*.pak 2>/dev/null) ]] ; then
insinto "${GAMES_DATADIR}"/quake2/${mod}
- doins "${baseq2_cdpath}"/../${mod}/*.pak || die "doins ${mod} pak"
+ doins "${baseq2_cdpath}"/../${mod}/*.pak
fi
fi
done
insinto "${GAMES_DATADIR}"/quake2/ctf
- doins ctf/*.{cfg,ico,pak} || die "couldnt grab ctf"
+ doins ctf/*.{cfg,ico,pak}
prepgamesdirs
}