summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-misc/dont-starve
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-misc/dont-starve')
-rw-r--r--games-misc/dont-starve/Manifest2
-rw-r--r--games-misc/dont-starve/dont-starve-2.ebuild62
-rw-r--r--games-misc/dont-starve/metadata.xml5
3 files changed, 69 insertions, 0 deletions
diff --git a/games-misc/dont-starve/Manifest b/games-misc/dont-starve/Manifest
new file mode 100644
index 000000000000..6291cef40b65
--- /dev/null
+++ b/games-misc/dont-starve/Manifest
@@ -0,0 +1,2 @@
+DIST dontstarve_x32_july21.tar.gz 174752315 SHA256 b1eb38a7cb7179b8db7d81c5070737a4acbaf1a9473912cb1bcb5c2ec784304b SHA512 d508989e6c2fe0fceb4706250c8f222acdf5a52492fa2dafa8baab25f98a029658631789cce5164f43c6e5ed529f2cf490fea321635e4077f54f09907071e921 WHIRLPOOL 18f8ee5a44c2984db86ae60bd99fc61ad87cc99890629a36c5d15a046bbd557854c1f9591b936b8bf9fc9d2248132439b8e236ded60e359a599d8cdac0770677
+DIST dontstarve_x64_july21.tar.gz 175302157 SHA256 3a3297ca6bada9c55bafe568085e75a9790f796aa7711726346d571ac40e25e6 SHA512 ef10acd493544f064fcd12868a47e650cd09f66318d57eaa994c4866c808ede4504f9e55933be66f7fad7783e72c91043c4b884970e7b80f8ea45f814828c752 WHIRLPOOL fe19306b8e220f6680d1ffaf089eb8a643f789a0e165979cf0d1f93e111f7c1e6675ffb4340496fe5ca35c263bce5af87b467cf5c2fe35d1ad64755ae311b469
diff --git a/games-misc/dont-starve/dont-starve-2.ebuild b/games-misc/dont-starve/dont-starve-2.ebuild
new file mode 100644
index 000000000000..4ddb159013b5
--- /dev/null
+++ b/games-misc/dont-starve/dont-starve-2.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils games
+
+DESCRIPTION="Wilderness survival game full of science and magic"
+HOMEPAGE="http://www.dontstarvegame.com/"
+SRC_URI="amd64? ( dontstarve_x64_july21.tar.gz )
+ x86? ( dontstarve_x32_july21.tar.gz )"
+
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+RESTRICT="fetch bindist splitdebug"
+
+MYGAMEDIR=${GAMES_PREFIX_OPT}/${PN}
+QA_PREBUILT="${MYGAMEDIR#/}/bin/dontstarve"
+if [[ $ARCH == amd64 ]] ; then
+ QA_PREBUILT="${QA_PREBUILT}
+ ${MYGAMEDIR#/}/bin/lib64/*"
+elif [[ ${ARCH} == x86 ]] ; then
+ QA_PREBUILT="${QA_PREBUILT}
+ ${MYGAMEDIR#/}/bin/lib32/*"
+fi
+
+RDEPEND="net-misc/curl
+ virtual/opengl"
+
+S=${WORKDIR}/dontstarve
+
+pkg_nofetch() {
+ einfo
+ einfo "Please buy & download \"${SRC_URI}\" from:"
+ einfo " ${HOMEPAGE}"
+ einfo "and move/link it to \"${DISTDIR}\""
+ einfo
+}
+
+src_install() {
+ local libdir=lib$(usex amd64 "64" "32")
+
+ insinto "${MYGAMEDIR}"
+ doins -r data mods
+
+ exeinto "${MYGAMEDIR}"/bin
+ doexe bin/dontstarve
+ exeinto "${MYGAMEDIR}"/bin/${libdir}
+ doexe bin/${libdir}/libfmod*
+ # unbundling libsdl2 breaks the menu, so you cannot start the game
+ doexe bin/${libdir}/libSDL2*
+
+ games_make_wrapper ${PN} "./dontstarve" "${MYGAMEDIR}/bin" "${MYGAMEDIR}/bin/${libdir}"
+ make_desktop_entry ${PN}
+
+ doicon dontstarve.xpm
+
+ prepgamesdirs
+}
diff --git a/games-misc/dont-starve/metadata.xml b/games-misc/dont-starve/metadata.xml
new file mode 100644
index 000000000000..cad5a2aa1773
--- /dev/null
+++ b/games-misc/dont-starve/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>games</herd>
+</pkgmetadata>