summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-puzzle/atomix
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-puzzle/atomix')
-rw-r--r--games-puzzle/atomix/Manifest2
-rw-r--r--games-puzzle/atomix/atomix-2.14.0.ebuild43
-rw-r--r--games-puzzle/atomix/atomix-3.16.0.ebuild28
-rw-r--r--games-puzzle/atomix/files/atomix-2.14.0-underlink.patch12
-rw-r--r--games-puzzle/atomix/metadata.xml5
5 files changed, 90 insertions, 0 deletions
diff --git a/games-puzzle/atomix/Manifest b/games-puzzle/atomix/Manifest
new file mode 100644
index 000000000000..06ae1d519e59
--- /dev/null
+++ b/games-puzzle/atomix/Manifest
@@ -0,0 +1,2 @@
+DIST atomix-2.14.0.tar.bz2 284987 SHA256 5d4e073c29e7d23d49b1bfcce9edf1e8f0c04bdb91db368e05e854e2b2636bb8 SHA512 9fffd28e1bdda80911ad99da8dc1125d43440de459679763c8502b0b0a68594ab06800198537b067ddac3768d2d90c8772e2b7a6628fa6a5e71fdca77410e709 WHIRLPOOL d5c6b96e974d80826bf5495ace5aaec2278dbe9c2e30bb5402142944e9fde52e5ebb86321bd7c89fde696c18fd60438d0cfa2ad087f1a3923d6cfca9ac82b3b2
+DIST atomix-3.16.0.tar.xz 261464 SHA256 29b0dd200344d6ceb9e4e9ad6034a4d5d14bf06dead343a3b70331f81f66a630 SHA512 bc2c78af2a6b2791d611414cdef24537f2d9e93bd6dd1fdb06a4733d876f2f2eaf197fa75578260c3de810ebbb69c99d4b4344eda0e3a77d7f52b0901eadf1d5 WHIRLPOOL 731a4f6fcd3f83f105ca7b6e0d35fb5ac7210b7fb42538aef4d7c3bea27387b40355fd25766fcdbca3211f68656fd4619f2b1c6cf176cc6a39e284f4c3f018db
diff --git a/games-puzzle/atomix/atomix-2.14.0.ebuild b/games-puzzle/atomix/atomix-2.14.0.ebuild
new file mode 100644
index 000000000000..9554d563246f
--- /dev/null
+++ b/games-puzzle/atomix/atomix-2.14.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+GNOME_TARBALL_SUFFIX=bz2
+inherit autotools gnome2
+
+DESCRIPTION="a game where you build full molecules, from simple inorganic to extremely complex organic ones"
+HOMEPAGE="http://ftp.gnome.org/pub/GNOME/sources/atomix/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+RDEPEND=">=x11-libs/pango-1.0.3
+ >=x11-libs/gtk+-2.6:2
+ >=dev-libs/glib-2.6:2
+ >=gnome-base/gconf-2.12
+ >=gnome-base/libglade-2.4
+ >=gnome-base/libgnome-2.12
+ >=gnome-base/libgnomeui-2.12
+ >=gnome-base/libbonoboui-2.0.0
+ >=gnome-base/libgnomecanvas-2.0.0
+ >=dev-libs/libxml2-2.4.23
+ dev-perl/XML-Parser"
+
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ >=dev-util/intltool-0.17"
+
+DOCS="AUTHORS ChangeLog NEWS README"
+
+src_prepare() {
+ sed -i \
+ -e '/Icon/s/\.png//' \
+ -e '/Categories/s/PuzzleGame;//' \
+ atomix.desktop.in || die
+ epatch "${FILESDIR}"/${P}-underlink.patch
+ eautoreconf
+ gnome2_src_prepare
+}
diff --git a/games-puzzle/atomix/atomix-3.16.0.ebuild b/games-puzzle/atomix/atomix-3.16.0.ebuild
new file mode 100644
index 000000000000..e118e8578683
--- /dev/null
+++ b/games-puzzle/atomix/atomix-3.16.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit gnome-games
+
+DESCRIPTION="a game where you build full molecules, from simple inorganic to extremely complex organic ones"
+HOMEPAGE="http://ftp.gnome.org/pub/GNOME/sources/atomix/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="
+ >=dev-libs/glib-2.36:2
+ >=dev-libs/libxml2-2.4.23
+ >=x11-libs/gdk-pixbuf-2.0.5:2
+ >=x11-libs/gtk+-3.10:3
+"
+DEPEND="${RDEPEND}
+ dev-libs/appstream-glib
+ >=dev-util/intltool-0.40
+ sys-devel/gettext
+ virtual/pkgconfig
+"
diff --git a/games-puzzle/atomix/files/atomix-2.14.0-underlink.patch b/games-puzzle/atomix/files/atomix-2.14.0-underlink.patch
new file mode 100644
index 000000000000..682180c048b2
--- /dev/null
+++ b/games-puzzle/atomix/files/atomix-2.14.0-underlink.patch
@@ -0,0 +1,12 @@
+--- src/Makefile.am.old 2013-12-07 22:25:30.513540434 +0100
++++ src/Makefile.am 2013-12-07 22:25:43.209654104 +0100
+@@ -26,7 +26,8 @@
+
+ atomix_LDADD = \
+ libatomix.a \
+- $(ATOMIX_LIBS)
++ $(ATOMIX_LIBS) \
++ -lm
+
+ noinst_LIBRARIES = libatomix.a
+
diff --git a/games-puzzle/atomix/metadata.xml b/games-puzzle/atomix/metadata.xml
new file mode 100644
index 000000000000..d3c2cc926f0b
--- /dev/null
+++ b/games-puzzle/atomix/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>