summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-puzzle/fish-fillets
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-puzzle/fish-fillets')
-rw-r--r--games-puzzle/fish-fillets/Manifest2
-rw-r--r--games-puzzle/fish-fillets/fish-fillets-1.0.1.ebuild56
-rw-r--r--games-puzzle/fish-fillets/metadata.xml8
3 files changed, 66 insertions, 0 deletions
diff --git a/games-puzzle/fish-fillets/Manifest b/games-puzzle/fish-fillets/Manifest
new file mode 100644
index 000000000000..8bd34503da06
--- /dev/null
+++ b/games-puzzle/fish-fillets/Manifest
@@ -0,0 +1,2 @@
+DIST fillets-ng-1.0.1.tar.gz 380290 SHA256 329a4d9515d60bebdb657d070824933b993b85864b9d3e302e6361accab992da SHA512 fe4a5186f94e953cbc85fe8b0ce804c881c96feda385cfc36e1840e448cf094c3d815fdbe32976a6697a855038951f97a384c277a1c52a048520e8da71136718 WHIRLPOOL ca70ee8e420ebb85f87ba4033eaf0738d9c29f87b347def51f5b53898b05eabdff0593f181e0a6cb7fc5e95159d8d69d040272d2c66c0be2ee1b5cab470a32a1
+DIST fillets-ng-data-1.0.0.tar.gz 146418413 SHA256 ad475a60cc96e8f5f55a7b264c390264898f1891b6ff096cc617e24d75dffd45 SHA512 61c7fe3980510a7dbd85f4c246e7e42a0f79d8e2aacd96a0c7a14189c5dee92292efb030ac92299474162995039073288283fee0f352cf08be6975a2c86703e7 WHIRLPOOL d80bbb54a465f40fb045930d767ac61e4cc5100fcd15b2fa3a4bd358b181c587bdc740851064bbd95140a4dd4f222ab9f1b4964ef089a41a523d9da1de5b25fd
diff --git a/games-puzzle/fish-fillets/fish-fillets-1.0.1.ebuild b/games-puzzle/fish-fillets/fish-fillets-1.0.1.ebuild
new file mode 100644
index 000000000000..9130c13c94f3
--- /dev/null
+++ b/games-puzzle/fish-fillets/fish-fillets-1.0.1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools eutils games
+
+DATA_PV="1.0.0"
+DESCRIPTION="Underwater puzzle game - find a safe way out"
+HOMEPAGE="http://fillets.sourceforge.net/"
+SRC_URI="mirror://sourceforge/fillets/fillets-ng-${PV}.tar.gz
+ mirror://sourceforge/fillets/fillets-ng-data-${DATA_PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+RDEPEND=">=media-libs/libsdl-1.2[sound,video]
+ >=media-libs/sdl-mixer-1.2.5[vorbis]
+ >=media-libs/sdl-image-1.2.2[png]
+ media-libs/smpeg
+ x11-libs/libX11
+ media-libs/sdl-ttf
+ dev-libs/fribidi
+ >=dev-lang/lua-5"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S=${WORKDIR}/fillets-ng-${PV}
+
+src_prepare() {
+ #.mod was renamed to .fmod in lua 5.1.3 - bug #223271
+ sed -i \
+ -e 's/\.mod(/.fmod(/' \
+ $(grep -rl "\.mod\>" "${WORKDIR}"/fillets-ng-data-${DATA_PV}) \
+ || die "sed failed"
+ rm -f missing
+ eautoreconf
+}
+
+src_configure() {
+ egamesconf \
+ --datadir="${GAMES_DATADIR}/${PN}"
+}
+
+src_install() {
+ default
+ insinto "${GAMES_DATADIR}/${PN}"
+ cd "${WORKDIR}"/fillets-ng-data-${DATA_PV} || die
+ rm -f COPYING
+ doins -r *
+ newicon images/icon.png ${PN}.png
+ make_desktop_entry fillets "Fish Fillets NG"
+ prepgamesdirs
+}
diff --git a/games-puzzle/fish-fillets/metadata.xml b/games-puzzle/fish-fillets/metadata.xml
new file mode 100644
index 000000000000..bb9d8fdaf249
--- /dev/null
+++ b/games-puzzle/fish-fillets/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>games</herd>
+ <upstream>
+ <remote-id type="sourceforge">fillets</remote-id>
+ </upstream>
+</pkgmetadata>